Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Router Xiaomi AX5 configurado en el fichero network con VLAN de Pepephone no funciona

Jfcocastellano

Tengo un Sagemcom Fast5655v2AC que lo quiero poner como bridge y utilizar un Xiaomi AX5 como router neutro configurado con la VLAN de Pepephone.

El Sagemcom lo pongo como bridge desde el menú web de Administrador y creo que por esa parte ya no hay que hacer nada más.

En cuanto al AX5 estoy siguiendo este hilo ¿Soportan PPPoE y VLAN los routers Xiaomi AX5 y AX1800? pero no me funciona. ¿Alguien sería tan amable de decirme qué falla en mi fichero /etc/config/network?

He probado también a añadir en la interface WAN option DNS y option macaddr y no funciona.

config interface 'LAN'
option ifname 'eth1 eth2 eth3'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.31.1'
option netmask '255.255.255.0'
option IPv6 '0'
option multicast_querier '0'
option igmp_snooping '0'
option macaddr '28:d1:27:5a:5c:cd'
option ieee1905managed '1'

config interface 'eth4'
option ifname 'eth4.20'
option keepup '1'

config interface 'WAN'
option proto 'DHCP'
option mtu '1500'
option ifname 'eth4.20'
NachoSH

Tienes que poner la VLAN 20 para la conexión WAN…

🗨️ 1
Jfcocastellano

Tenía entendido que la VLAN se especificaba en el apartado option ifname 'ethX.VLAN'. ¿En mi caso no sería option ifname 'eth4.20'? Está puesto en la última linea del script.

BocaDePez
BocaDePez
1

Creo que lo tienes bien, pero tienes que añadir en la segunda línea la eth4:

option ifname 'eth1 eth2 eth3'option ifname 'eth1 eth2 eth3 eth4'

🗨️ 2
Jfcocastellano

Efectivamente era eso. Mil gracias!

🗨️ 1
vukits

¡la leche! ¿te ha funcionado eso?

pues no tiene ni pies ni cabeza xD

Ju Gar63

Sabes si funciona con el Xiaomi ax3600 o el ax6000?