Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
64 lecturas y 4 respuestas
  • Cerrado

    Caonfiguracion NAT en CISCO

    Saludos a todos.

    El tema es el siguiente. Tengo que hacer entradas NAT en un router ya configurado y hoy he probado ha introducir las siguientes lineas en la configuracion:

    ip nat inside source static tcp 192.168.1.100 80 interface Dialer1 10000
    ip nat inside source static tcp 192.168.1.101 80 interface Dialer1 10001

    y tb he intentado estas:

    ip nat inside source static tcp 192.168.1.100 80 interface ATM0 10000
    ip nat inside source static tcp 192.168.1.101 80 interface ATM0 10001

    junto con las entradas nat inside y outside en la correspondiente ethernet y atm y/o dialer1.

    La configuracion del router es la siguiente:

    !
    version 12.3
    no service pad
    service timestamps debug datetime
    service timestamps log datetime
    service password-encryption
    !
    hostname rpaimr7
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 40960 debugging
    enable secret 5 $1$WEIH$4QKw6YcoEqiMKD7KKxE9S0
    enable password 7 13061E010803
    !
    username rpaimr7 privilege 15 secret 5 $1$Cq9C$Qt0ceiG9cykyPSeHYjKpx0
    aaa new-model
    !
    !
    aaa authentication login default line
    aaa authentication login acs group tacacs+ local
    aaa authentication enable default group tacacs+ enable
    aaa authorization commands 1 acs group tacacs+ if-authenticated
    aaa authorization commands 15 acs group tacacs+ if-authenticated
    aaa accounting exec default start-stop group tacacs+
    aaa accounting commands 1 default stop-only group tacacs+
    aaa accounting commands 15 default stop-only group tacacs+
    aaa session-id common
    ip subnet-zero
    !
    !
    !
    !
    no ip domain lookup
    ip ips po max-events 100
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 85.63.x.x 255.255.255.255
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    no snmp trap link-status
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 1/33
    no broadcast
    oam-pvc manage
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet2
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet3
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet4
    no ip address
    duplex auto
    speed auto
    !
    interface Dialer1
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp chap hostname rpaimr7@uni2-abiadslip
    ppp chap password 7 01100A164B0A0F02331B
    ppp pap sent-username rpaimr7@uni2-abiadslip password 7 045807141F2045431B4E
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    ip tacacs source-interface Loopback0
    no ip http server
    no ip http secure-server
    ip nat pool SERVICO 85.62.x.x 85.62.x.x netmask 255.255.0.0
    ip nat inside source list 150 pool SERVICO overload
    !
    !
    access-list 99 permit 62.36.193.89
    access-list 99 permit 62.36.193.88
    access-list 99 permit 62.36.193.93
    access-list 99 permit 62.36.193.83
    access-list 99 permit 62.36.193.80
    access-list 99 permit 62.36.193.75
    access-list 99 permit 62.36.193.74
    access-list 99 permit 62.36.193.121
    access-list 99 permit 62.36.209.3
    access-list 99 permit 62.36.74.0 0.0.0.15
    access-list 99 remark LISTA DE ACCESO TELNET MODIFICADA
    access-list 1302 permit 62.36.193.89
    access-list 1302 permit 62.36.193.88
    access-list 1302 permit 62.36.193.95
    access-list 1302 permit 62.36.193.93
    access-list 1302 permit 62.36.193.83
    access-list 1302 permit 62.36.193.80
    access-list 1302 permit 62.36.193.84
    access-list 1302 permit 62.36.193.71
    access-list 1302 permit 62.36.193.121
    access-list 1302 permit 62.36.193.118
    access-list 1302 permit 62.36.209.3
    access-list 1302 permit 62.36.193.72 0.0.0.3
    access-list 1302 remark LISTA DE ACCESO GESTION MODIFICADA
    access-list 150 permit ip 192.168.1.0 0.0.0.255 any
    snmp-server community z0rr1ll4 RO 1302
    snmp-server community c4ld3r0n RW 1302
    snmp-server trap-source Loopback0
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps tty
    snmp-server enable traps bgp
    snmp-server enable traps ipsec tunnel start
    snmp-server enable traps ipsec tunnel stop
    snmp-server host 62.36.193.121 z0rr1ll4
    tacacs-server host 62.36.193.94
    tacacs-server directed-request
    tacacs-server key 7 097444594C241B1318
    !
    control-plane
    !
    !
    line con 0
    password 7 14181C1E18012923
    no modem enable
    stopbits 1
    line aux 0
    line vty 0 4
    session-timeout 15
    access-class 99 in
    exec-timeout 15 0
    password 7 09424B1B09041E1F195B
    authorization commands 1 acs
    authorization commands 15 acs
    login authentication acs
    !
    scheduler max-task-time 5000
    end

    A ver si alguien me puede decir que estoy haciendo mal pues no doy con la tecla.

    Muchisimas gracias ante todo y espero vuestras respuestas

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      Aunque me he peleado con NAT y Cisco muchas veces, nunca he…

      Aunque me he peleado con NAT y Cisco muchas veces, nunca he tocado un router ADSL, pero aún así esa configuración no parece muy distinta a las configuraciones RDSI que he manejado. Supongo que Joe Dalton te podrá ayudar mejor, si se deja caer por aquí y quiere.

      Te comento algunos detalles que he visto.

      - En primer lugar, has puesto unas cuantas contraseñas. Las que están cifradas con MD5 no se pueden descifrar, pero las otras se descifran sin ningún problema. Vigila ésos temas.
      - Veo que el NAT estático que quieres configurar se solapa con el que ya hay configurado. Me imagino que éso no es problema, que el estático prevalece sobre el dinámico y no hay conflicto. Al menos en los PIX es así.
      - Creo que tu interfaz nat outside es el dialer y no el atm, y es por tanto el dialer el que tiene que figurar en la instrucción nat. Lo digo por que es el Dialer el que tiene la información de IP, el ATM sólo proporciona enlace.
      - No veo el dialer list por ningún lado. ¿Seguro que está funcionando la conexión?

      En fin, éso es todo lo que puedo decirte ... porque supongo que la sintaxis de los comandos está bien ¿no?

      Suerte.

      • Cerrado

        Muchas gracias xavi_super. la conexion funciona sin problemas…

        Muchas gracias xavi_super.

        la conexion funciona sin problemas tal y como esta esta configuracion, como dices supuse que la entrade del nat debia ponersela al dialer que es el que tiene la configuracion de la ip, pero como no estaba totalemtne convencido pues lo preguntaba mejor ;))

        Aun asi no me funciono de ninguna de las dos formas :(((

        Como tu mismo dijiste antes la entrada estatica que hice, pisa a la dinamica que ya ahi, pro eso no deberia ser problema, en el de mi curro lo tengo echo de esa forma y la configuracion es mia, aunke mucho mas simple que esta.

        Asi que no se xq no me redirecciona :((

        • Cerrado

          Y ¿no será que la instrucción nat static no te admite que…

          Y ¿no será que la instrucción nat static no te admite que pongas "interface Dialer ...", sino que tengas que poner directamente la IP del interfaz? He encontrado este ejemplo en la web de Cisco y se parece mucho a tu caso

          Suerte nuevamente.