BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Tagged WAN y untagged LAN sobre un mismo puerto en router AX3600

isaiasmy

Poseo un Askey HGU RFT3505VW en modo bridge (no en modo monopuesto) al cual quiero conectar un router Xiaomi AC3600 que es una versión modificada de OpenWrt al cual tengo acceso por ssh. Actualmente me funciona con la WAN en eth1 y la LAN en eth2 , eth3 y eth4 según la configuración al final de este post.

Necesito que sobre un mismo puerto (el eth1) vaya el tráfico LAN y el tráfico WAN con tag VLAN 6 para que lo procese el Askey en modo bridge.

Por un lado tengo un comportamiento que no llego a entender. El fichero original que yo cargué en la configuración WAN lo configuré con la siguiente opción para la interfaz "option ifname 'eth1.6' " (la configuración para Movistar). Sin embargo, haciendo un /etc/init.d/network restart o reload no funcionaba. Decidí hacer un reboot y el fichero se modifico a "option ifname 'eth1' " (sin la VLAN) pero funciona (no se si usando alguna opción del comando uci se puede conseguir algo similar). De hecho la configuración que he puesto más abajo es SIN el tag VLAN 6 puesto que es como el router ahora funciona. No tengo un hub y tengo que ver si el askey puedo hacer "port mirroring" de puertos (LAN o WAN) para ver que esta pasando. He capturado tráfico para ver que sacaba el router y efectivamente el DHCP van con la VLAN 6 pero el PPPoE va sin tag VLAN 6. Quizás el ASKEY si no tiene interfaz WAN coge una petición PPPoE y la reenvía hacia fuera (para eso necesito hacer port mirroring como he dicho antes).

Mi problema, es que necesito que el puerto eth1 sirva para la WAN y la LAN. He intentando en la configuración de la LAN sustituir la entrada " option ifname 'eth2 eth3 eth4' " por " option ifname 'eth1 eth2 eth3 eth4' ". El bridge con los cuatro puertos funciona (lo he comprobado) pero la interfaz WAN no levanta (no hay conexión PPPoE). No sé si hay relación con el detalle mencionado con el párrafo anterior o si hay alguna posible alternativa. No tengo claro en qué afecta que la interfaz eth1 este en modo bridge para el resto de configuraciones.

Al no ser un OpenWrt oficial, la cosa esta limitada de momento, no obstante entiendo que tendría que haber alguna alternativa para poder hacerlo. No es una cosa habitual pero diría que es algo razonable. ¿Alguna idea? Gracias.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config switch
	option name 'switch0'

config interface 'lan'
	option ifname 'eth2 eth3 eth4'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipv6 '0'
	option multicast_querier '0'
	option igmp_snooping '0'
	option macaddr '28:d1:27:4c:db:44'
	option ieee1905managed '1'
	option ipaddr '192.168.1.2'

config interface 'eth1'
	option ifname 'eth1.6'
	option keepup '1'

config interface 'wan'
	option proto 'pppoe'
	list dns '1.1.1.3'
	list dns '1.0.0.3'
	option mtu '1500'
	option peerdns '0'
	option username 'adslppp@telefonicanetpa'
	option special '0'
	option password 'adslppp'
	option ifname 'eth1'

config interface 'dhcp'
	option ifname 'eth1.6'
	option proto 'dhcp'
kotBegemot

No tengo ni idea de ese router, pero me chirria que tengas el PPPoE sobre eth1 y luego metas eth1 en un bridge.

prueba a meter el eth1 en el bridge y posteriormente monta el PPPoE sobre el bridge

🗨️ 1
isaiasmy

Mi idea inicial fue esa porque ese el fichero de configuración que genera el router y quería modificarlo lo menos posible. Más que nada por si existieran problemas al realizar un reboot o realizar algún cambio via web. Hasta que no haya soporte oficial de OpenWrt la cosa la tengo "limitada".

Respecto a lo que comentas, no se si en la configuración WAN se puede hacer referencial a la interfaz LAN o al bridge para hacer lo que comentas. Ya comentaré …

BocaDePez
BocaDePez
1

Creo que la solución es simple, no tienes el HGU en modo Bridge puro.

Para que no gestione la vlan6 el HGU debes editar la configuración editando el fichero de backup y restaurando la configuración desde el fichero modificado. Así lo tuve que hacer la última vez que toqué un HGU. Puede que haya cambiado.

De ahí que te funcione sin necesidad de vlan6 en el Puerto WAN.

Básicamente puedes configurar el modo Bridge gestionando las VLAN el HGU, que es como funciona si lo activas desde el interfaz web. En este modo solo requiere un interfaz PPPoE sin VLAN.

Luego está el modo Bridge puro, que funciona como si el HGU fuese una ONT pura y ahí sí que además del PPPoE necesitas VLAN 6 (eth1.6 en tu caso)

🗨️ 1
isaiasmy
1

Le he configurado según se indica aquí: comunidad.movistar.es/t5/Soporte-Fibra-y…td-p/2803022

En teoría en modo bridge y no en modo monopuesto. El problema es que la documentación que aporta telefónica como siempre es muy poca. Tienes algún enlace de lo que indicas, no he encontrado nada al respecto.

vukits

Al menos que lleves varios años usando GNU/Linux, yo desistiría. No porque sea dificil o fácil, sino que hay que tener ciertos conocimientos para poder depurar.

En teoría es posible, pero es muy dependiente del driver del switch… en GNU/Linux de toda la vida, se ha podido coger una interfaz ethernet duplicarla de forma lógica y asignarla dos MAC's diferentes.

🗨️ 1
isaiasmy

Es un problema de falta de documentación de la configuración posible en los routers de telefónica y que de momento el firmware del AX3600 no es un OpenWrt oficial.

isaiasmy

¿Alguien sabe la referencia para poder editar el fichero de configuración en el HGU para que acepta el tráfico ya con el tag de la VLAN 6? No lo he logrado encontrar por ningún sitio