Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Cablemodem HFC

SNMP con el TCM 410 (probablemente con otros tambien)

sorrillo

A ver, os cuento.

Hoy me han instalado el thomson tcm 410, leyendo varios hilos de este foro me he desanimado bastante, ya que hay muy poca informacion sobre el modelo.

Es curioso que ni thomson ni rca pongan nada de nada de inforamcion sobre el equipo ni drivers ni nada.

Incluso en el CD que me han dado la informacion era de modelos distintos a este.

En este link ((link roto)) aparece que el equipo tiene soporte SNMP, asi que lo primero que he pensado es ... genial, tendre graficas de velocidad con el mrtg :-)

Pues nada, el equipo no respondia a nada con el snmp aunque el nmap decia que el puerto estaba abierto (junto con el 80 que muestra informacion sobre el estado de la conexion pero poco mas).

Lo estaba dando todo por perdido hasta que he visto esta web ((link roto)), donde en un post del 07-Sep-2002 GAZT15 comenta que algunos cable modems solo permiten snmp cuando no estan conectados a Internet. Explica que es necesario quitar el cable y rebotarlo para ver el SNMP. Bueno, al ver eso he pensado "k tonteria ya ves tu que graficas me puede hacer desconectado" jejeje. Pero ya por probar no pierdo nada.

Asi que:
- Desconecto el cable
- Reinicio el modem-router
- Le pongo la ip 192.168.100.2 a mi PC para poder acceder a la que tiene el router (192.168.100.1).
- Le hago un ping al router (192.168.100.1) para que se entere que existo, temas de arp.
- Y ejecuto: snmpwalk -v 1 192.168.100.1 -c public

Y tachan ... el snmpwalk me muestra un monton de info sobre el router.

Lo mas interesante del tema es que segun la web anterior esto sirve para poder configurar el modem, osea, en principio hay permiso de escritura sobre el equipo.

Bueno, hasta ahi puedo contar (hoy no creo que le dedique mas tiempo).

Entre las partes del listado que me ha sacado descartar este:

IF-MIB::ifSpeed.1 = Gauge32: 100000000
IF-MIB::ifSpeed.2 = Gauge32: 0
IF-MIB::ifSpeed.3 = Gauge32: 30341646
IF-MIB::ifSpeed.4 = Gauge32: 0
IF-MIB::ifSpeed.5 = Gauge32: 12000000
IF-MIB::ifSpeed.6 = Gauge32: 0

Donde aparentemente se marca la velocidad de bajada (1 Mbps) y de subida (300 kbps), vamos que quiza podria servir para hacer uncapping.

O esto:

IF-MIB::ifPhysAddress.1 = STRING: 0:90:64:a4:4d:32

Que parece ser la MAC del aparato, nose que utilidad tendria cambiarla pero ahi sta.

A ver si alguien se lo curra y sigue dese ahi, que yo tengo el problema que soy como un niño, cuando me canso de un juguete lo dejo tirado y mi nivel de atencion sobre una unica cosa es muy corto :-)

Si quereis que pegue el listado completo avisad, aunque no he visto mas cosas de interes, lo otro son valores en true or false o numericos, sin ninguna descripcion.

Saludos.

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
Slaughter

Yo tengo el cablemodem 410 y me dice lo siguiente:

snmpwalk -v 1 192.168.100.1 -c public
Timeout: No Response from 192.168.100.1

Un Saludo.

🗨️ 4
sorrillo

Has seguido las instrucciones al pie de la letra ?

Puntos importantes para que funcione:

- Tener el router TCM410 desconectado de la fibra (el cable coaxial)
- Reiniciar el router
- Poner tu pc en la lan 192.168.100.x

A mi me funciono perfectamente, pero como de momento no le veo la utildad pues no lo he vuelto a probar.

Por ejemplo, no sirve para hacer graficas de trafico porque cuando el router esta conectado a la fibra el snmp queda deshabilitado. Al final las he hecho con iptables + gnuplot.

Saludos.

🗨️ 3
Slaughter

Olvidé el primer paso, desconectar el cable de fibra óptica.

¿Puedes decirme cuales son tus las reglas iptables para loggear todo el tráfico y cómo las usas en gnuplot?

Gracias.

Un Saludo.

🗨️ 2
sorrillo
BocaDePez
BocaDePez

COmo encuentro el drive del TCM 410. He perdido mi CD y no encunetro para bajar. Porfa me dá una idea!Aydama

BocaDePez
BocaDePez

Hola, que tal, hace algunos dias me pusieron el router adsl Thomsom 410 de Auna, funciona todo bien y tengo acceso a internet, lo malo es que, cuando ejecuto el Kazaa, este no se conecta. ¿tengo que abrir algun puerto del Modem? y si asi es ¿como lo hago?
Agradecería vuestra ayuda al respecto.
Saludos.
Atte "Corderito"