BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Router ya.com total en modo bridge, problemas con VOIP?

BocaDePez
BocaDePez

Hola,

Recibi el router de ya.com total (SMC7908A) y lo he configurado en modo bridged de tal manera que mi servidor linux sigue controlando todo, los puestos que se abren, la gestion de dominios dinámicos, etc. Pero me ha surgido un tema que creo que me va a dar problemas.

El problema que veo es que ahora el router no ve internet y por tanto me temo que el VOIP va a ser imposible de configurar desde el router.

Tendre que comprarme un telefono VOIP aparte? Podre configurarlo correctamente con ya.com?

Un saludo y gracias.

vukits

es una cosa rara ..está eso que se llama popularmente circuitos virtuales y no sé qué puñetas .. es lo que te ponen con IPTV sobre ADSL.. y podías hacer no sé qué líos con bridge y tal..

a ver si alguién del foro lo confirma :P

saludos

PD: ¿eins? .. pero si con DMZ vas apañao , ¿no? :-/

🗨️ 1
BocaDePez
BocaDePez

Teniendo en cuenta que ese router se satura a la mínimo, lo mejor es que haga lo mínimo posible.

BocaDePez
BocaDePez

Podrías explicar como has configurado dicho router en monopuesto (como das a entender). Gracias

🗨️ 3
anthrax

Jajaja, monopuesto y multipuesto esos vocablos hacía tiempo que no los escuchaba :D

🗨️ 2
BocaDePez
BocaDePez

:) ya ves. El caso es que como todavía no tiene la portabilidad hecha, no creo que conecte via MER y por lo tanto, cuando lo haga, el "truco" del modo bridge le dejará de funcionar.

🗨️ 1
genkaos

Es fácil. Desactivas el DHCP de la LAN del router, configuras la WAN para que use 1483 Bridging, clonas la mac address de la WAN interface del router a tu tarjeta de red y la configuras para que obtenga ip vía DHCP. Y ya está, tu tarjeta de red obtendrá la ip pública (y demás) y a trastear.

BocaDePez
BocaDePez

Os respondo un poco a todos. Soy el autor original del mensaje.

Lo de DMZ no me vale porque sinceramente no me fio del router. Es el peor router que he recibido de un ISP y aparte tiene muchas cosas que no me mola. Deja puertas abiertas (aparte del bug de 447 ya resuelto) que permite comunicar el ISP con tu máquina. Y la verdad, me gusta tener mi servidor linux controlado todo eso, que al fin y al cabo esta configurado desde hace años y me siento mucho más comodo. Aparte se actualiza solo, cosa que me jode más aun, porque segun lo istale se me actualizo y me capo el modo bridge.

Respecto al modo bridge (monopuesto) si que me funciona. Ya tengo hecha la portabilidad y conecto por MER, con lo cual puedo confirmar que este router puede funcionar en modo monopuesto sin problema. Pero, necesitais la rom de January (en la última todo esto lo han capado, manda huevos por otro lado). La podeis encontrar muy fácilmente si usais google. Una vez con ese firmware, debeis poner el modo 1483 Bridging y desactivar el DHCP del servidor. Con eso, enganchando el servidor por el cable de red os dara una IP directamente a la máquina. Yo no necesité clonar la mac ni hacer nada raro. Me funciono a la primera (y el router ya habia estado funcionando en modo multipuesto un día, por lo tanto no es un problema de que ya.com se quede con la primera mac que conecta).

El problema de esta configuración es que el router deja de ver internet (salvo que alguien me diga que no, yo lo he intentado y nada, el router viene muy capado...) y por tanto el VOIP lo debes tratar con otro aparato directamente en el servidor. Yo estaba pensando en un usar el adaptador PAP2 de linksys o bien comprar el telefono Siememes G470 IP que vi el otro dia en el MediaMark. Pero me gustaria confirmar que esos aparatos me van a funcionar correctamente, pues hace poco lei por aqui que los settings de ya.com de VOIP son secretos... (manda huevos tambien...)

🗨️ 7
genkaos

Tienes razón, no hace falta clonar la MAC. Por otra parte, puedes usar el firmware de Mayo y luego entrar a los antiguos menús de configuración quitando la cadena _ya de la URL. (p.e. 192.168.2.1/voip_account_ya.stm -> 192.168.2.1/voip_account.stm )

🗨️ 6
santito

Tienes razón genkaos, en la versión 0.10.003 lo que el quiere es la página 192.168.2.1/atmpvc.stm

Ahí se puede configurar cualquier conexión en el router. Ya configurar la VoIP para que vaya enrutada por el gateway que te has montado aguas abajo... No sé si te va a dejar. Yo ya lo intenté con un router VoIP Zoom, usándolo en modo bridged, pero no conseguí que usase para la VoIP la ruta estática definida como gateway.

Saludos

🗨️ 5
genkaos

Estás en lo cierto. Metí la pata al poner de ejemplo la configuración de la VOIP ya que los puertos FXS intentan usar la WAN Interface del propio router, y parece imposible conseguir crear una ruta estática vía 192.168.2.1/route_tbl.stm (no existe ArouteNew.exe)

🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
BocaDePez
BocaDePez
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
KirO

Sugerencia:

Monta un servidor asterisk en tu servidor linux que se conecte al servidor VoIP de Ya.com, a este servidor asterisk le conectas el aparatejo que te has comprado e intenta configurar el router para que también se conecte a tu servidor, mucha gente ha dicho que les ha sido imposible configurar el router para conectarse a un servidor VoIP en una IP privada, pero estando en Monopuesto... quien sabe... si no es posible, conecta el router al servicio VoIP a través de tu IP pública (para ello tienes que configurar el firewall tu servidor para abrirse a si mismo los puertos correspondientes, pero yo lo configuraría con cuidado para que solo tú puedas conectarte).

De esta forma tienes funcionando el PAP2T ese (ya que con Asterisk si que funcionará casi seguro) y, con un poco de suerte, las bocas RJ-11 del router.

Salu2!!

🗨️ 16
BocaDePez
BocaDePez

Pues la verdad es que si, me he quitado de lios. Ya tengo todo funcionando perfectamente:

1. Router de ya.com en modo bridge

2. Servidor linux haciendo de router

3. Asterisk configurado en el servidor (y por tanto con la ip publica de internet, para evitar problemas de NAT)

4. Telefonos enganchados al PAP2 funcionando perfectamente (llamadas entrantes y salientes correctamente funcionando)

Solo me quedaria meter algo de QOS al server para priorizar los paquetes de VOIP (con iproute2), pero la verdad es que por defecto bajando y subiendo bastantes cosas, emule puesto y demas cosas, no no noto ninguna caida en la calidad de la voz.

🗨️ 15
KirO

¿Has conseguido hacer funcionar las bocas de teléfono del router con el asterisk?

Salu2!!

🗨️ 5
BocaDePez
BocaDePez

Dice que usa PAP2 (Linksys PAP2T), así que no, no ha hecho funcionar los puertos fxo/fxs del smc7908a-isp.

🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
flashito
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez

Y tras varios meses funcionando con esta configuracion, me ha llegado este mail:

Estimado cliente,

Queremos informarte que hemos detectado la utilización de un router/ equipo de conexión no homologado por Yacom.

Este uso incurre en incumplimiento de las condiciones contractuales

*que aceptaste al solicitar nuestros servicios, y además puede comprometer la calidad del mismo. Por este motivo nos vemos obligados a informarte que dispones de un plazo de 15 días naturales, para cambiar el equipo que estás utilizando actualmente, por el homologado por Yacom que te facilitamos en el alta.

Si en este plazo de tiempo no has cambiado el equipo, o si en un futuro volviésemos a detectar el uso indebido de otro equipo no homologado, lamentándolo mucho nos veríamos obligados a resolver tu contrato y suspender la conexión a nuestro servicio.

Si necesitas alguna aclaración, no dudes en ponerte contacto con nuestro Centro de Atención al Cliente llamando al 902 902 902**

Atentamente,

🗨️ 8
BocaDePez
BocaDePez

Alguna sugerencia sobre que hacer ante esto?

El hardware es el que ellos me dieron. B-)

🗨️ 7
BocaDePez
BocaDePez
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez
🗨️ 3
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
asterisk
BocaDePez
BocaDePez

Pues a mi me va todo perfecto (incluso habiendo recibido la carta). Por si acaso cambie el setting de useragent en el sip.conf

Por cierto, hoy tuve que volver a cambiar el setting defaultexpirey a 3600, porque ya.com lo ha vuelto a cambiar y con los 1800 no registraba...

BocaDePez
BocaDePez

Habeis notado alguno el cambio q hicieron los de yacom el viernes?

Como el SMC-7908 no te deja ver los valores no puedo confirmarlo, pero en casa de mis papis dejo de funcionar el SMC-7904 y tuve q volver a poner el prehistorico D-Link 504T con una actualizacion q me mandaron hace cerca de un mes.

Curiosamente en este si se puede ver q en vez de PPPoE ahora usan 1483 Bridging, pero el DHCP del router sigue funcionando ¿¿ ??

¿Alguien mas lo ha notado?

PD: Cada vez tengo mas claro q en cuanto OpenWrt funcione en SMC-7908 le quito esa m***** de firmware (forum.archive.openwrt.org/viewtopic.php?pid=118861

🗨️ 1
BocaDePez
BocaDePez

A mi ha llegado una carta avisando del cambio. Pero todavia no he notado nada... Me tiene un poco acojonado el cambio la verdad, con lo bien que lo tengo configuradito ahora...