Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Problema con hoja de estilos en 1and1 (subdominios y carpetas)

puzzlebroken

Buenos días, (HAGO UN LLAMADO A QUIENES SON CLIENTES DE 1AND1, ellos sabrán mejor de que hablo, seguramente)

Buscando por este mar inmenso que es internet, di con un problema parecido al que yo tengo en este foro.. PERO era un tema de hace 3 años así que.. abro tema y expongo mi caso..

Por decirlo de una manera sencilla;

Mi problema es que las hojas de estilo que están dentro de un subdominio o una carpeta (dentro de la raíz) no las lee! Es decir, no funcionan.

Con el subdominio tuve hace unos meses el mismo problema, afortunadamente no paso a mayores.. Porque simplemente el estilo del sitio era el mismo que el dominio principal, así que llame a la hoja de estilos de la raíz.

Sin embargo AHORA, he instalado un blog en una carpeta..

Ejemplo:

-Dominio principal

+Blog <- Este es..

+images

+css

+js

Pero resulta que lo mismo sucede con las "carpetas".. cosa de la que me estoy enterando ahora mismo.

No pilla las hojas de estilos incluidas en la carpeta "/blog".

Alguien tiene idea de por que sucede esto?

Es problema de 1and1? con ellos es el asunto?

Quizás tengo mal distribuido el orden de carpetas en mi directorio raíz (./) de ftp?

Auxilio.

Un saludo chicos, espero algunas respuestas! No me quedéis mal que me acabo de registrarrr.. jeje..

BocaDePez
BocaDePez

Yo no soy usuario de 1&1 y desconozco su sistema CMS, pero si está Unix o derivados, diferenciará entre mayúsculas y minúsculas en la ruta. ¿Has verificado que el problema no venga de ahí?

🗨️ 1
puzzlebroken

Hola BocaDePez,

Sip, fue lo primero que he mirado! Pensando y analizando un poco el tema.. He llegado a otra posible falla y es la estructura de los archivos en el ftp.

Verás, normalmente se suben los archivos a WWW o Public_Html, sin embargo esas carpetas no las proporcionaba mi servicio.. Aunque tengo un pack con todos los derechos y funciones y me pareció muy extraño.. el caso es que yo no "cree" esas carpetas.. Luego he visto (leído por ahí) que de hecho no se pueden crear. Lo cierto es que la estructura que tengo es la siguiente:

+Dominio Principal <- Me pilla los estilos perfectamente.

+Subdominio <- No reconoce estilos

+Subdominio <- No reconoce estilos

+Subdominio <- No reconoce estilos

+Logs

---------

-Dominio Principal

+Blog <- Aquí he instalado el blog de wordpress.. (<- No reconoce estilos)

+images

+css

+js

-------

No sé si se entiende, pero esa es la estructura de los archivos que tengo, tengo dudas de que este correctamente.

Por otro lado, estuve mirando los "permisos" de cada carpeta, subcarpetas y demás.. Todos tienen un 755.

Y otra cosa penosa; el servicio de soporte técnico de 1and1.. Perdonarme por la palabra pero no sirve para una mierda!

puzzlebroken

REPOSTEO; (SOLUCIONADO) compañero!

Dejo cual era el problema:

el GRAN y PEQUEÑO problema no era otro que, acabo de comprobar que el problema es efectivamente de apache, específicamente con una regla que tengo para que todos los archivos tipo .html .js .css los ejecute como php.

Esta era: AddType application/x-httpd-php .html .js .css (en el .htaccess)

el CSS estaba cargando pero el navegador no lo reconocía como un CSS sino como un archivo HTML.

Ahí estaba todo el problema! ahora está SOLUCIONADO.

Una pregunta final; no recuerdo porque tenía esa regla (AddType x-mapp-php5 .php .shtml .html .htm .js .txt .css) pero si estaba o la puse en su tiempo, fue por algo.. Esto que es lo que hace exactamente? Porque pudo haber estado ahí o porque la pude haber puesto ahí?

Saludos.