Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Bugs/Devel

No veo bien los foros con mi n800 (mala detección del navegador?)

PezEnLaBoca

Si entro a cualquiera de los foros con mi n800, en lugar del indice normal, veo una pagina con el texto de todos los posts, sin ver donde hay nuevos mensajes y sin poder empezar un nuevo tema. Si a cambio navego desde el pc veo todo normal.

La pagina con todos los foros y los hilos individuales los veo exactamente igual en el pc y en la tableta.

Supongo que el foro esté detectando un navegador raro y por ello me presenta un formato distinto, y es bastante molesto.

El navegador de la tableta está basado en el motor de firefox 3, por lo tanto es capaz de visualizar bien casi todo.

Si de verdad se quiere presentar un formato distinto, por favor, hacerlo en base a las preferencias del usuario y no en base al navegador detectado.

adrinavarro

Has intentado cambiar el u-a?

🗨️ 6
PezEnLaBoca

No, y no quiero hacerlo, no debe ser necesario.

🗨️ 5
adrinavarro

Me parece muy bien que no quieras. Lo más normal que es que si encuentran NOKIA en el UserAgent pues te den formato móvil. Esa es la solución, si no haz lo que quieras.

🗨️ 4
PezEnLaBoca

Lo más normal es que dejen de intentar adivinar el navegador que uso y, en todo caso, tener en cuenta mis preferencias a la hora de visualizar el foro, y visto que de momento esta preferencia no existe, visualizarlo normal.
(eso sin contar que el formato móvil no es para nada funcional y cuesta mucho más de renderizar en la tableta que el formato normal).

Por cierto, en el user agent no hay NOKIA: "Firefox/3.0a1 Tablet browser 0.3.7 RX-34+RX-44+RX-48_DIABLO_4.2008.23-14", quizas sea el "Tablet" lo que haga aparecer la versión móvil (pero solo en algunas paginas), pues, bien, como he dicho más arriba, es peor la versión móvil que la normal.

🗨️ 3
PezEnLaBoca

Ninguna noveda, comentarios, observaciones?