Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra/Cable

mikrotik no me coge IP con ono en modo monopuesto

BocaDePez
BocaDePez

Buenas

tengo el router de ONO (un Netgear) el cual esta en modo monopuesto

con una tarjeta ethernet en un equipo coge IP pergfectamente, pero con el mikrotik no hay manera, es un RB951G-2HnD, si lo conecto a mi red local coge IP perfectamente del DHCP del servidor

Necesito alguna configuracion especial para ONO?

BocaDePez
BocaDePez

No necesitas ninguna configuración especial, pero los Microtik son routers con una relación calidad precio espectacular pero bastante más complicados de configurar que la media.

🗨️ 6
dakotabcn

lo se... descubri anoche por que no funcionaba el 11n, haby que habilitar el AES ademas del TKIP :p

en mi post anterior explico una posible causa, que el cablemodem si negocia a 1000 no funciona (con 2 cables diferentes) y a 100 si

si es esto voy a petar el cablemodem y que me lo cambien

🗨️ 5
BocaDePez
BocaDePez

El modo N solo funciona en AES.. pero claro, hay que saberlo ?

Configura el microtik a 100 y saldrás de dudas

🗨️ 4
BocaDePez
BocaDePez

configurado a 100 y nada

lo he reseteado de fabrica y funciona tras hacer unos comandos, esto quiere decir que mi config tiene algo que no le gusta a ONO

estos comandos los he sacado de aqui lafibra.info/index.php?topic=249.0 y adaptado a mi red (quitar dhcp, poner rango 192.168.1.xxx ...)

podria ser el tema del VLAN?

/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=\
ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=\
ether4-slave-local
set [ find default-name=ether5 ] master-port=ether2-master-local name=\
ether5-slave-local
/ip neighbor discovery
set ether1-gateway discover=no
/interface vlan
add interface=ether1-gateway l2mtu=1594 name=vlan1 vlan-id=100
/ip pool
add name=default-dhcp ranges=192.168.1.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=yes interface=ether2-master-local name=\
default
/ip address
add address=192.168.1.100/24 comment="default configuration" interface=\
ether2-master-local network=192.168.1.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=no \
interface=vlan1
/ip dhcp-server network
add address=192.168.1.0/24 comment="default configuration" gateway=\
192.168.1.100
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.1.100
name=router
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=\
established,related
add chain=input comment=webfig dst-port=81 in-interface=vlan1 protocol=tcp
add action=drop chain=input comment="default configuration" in-interface=vlan1
add action=fasttrack-connection chain=forward comment="default configuration" \
connection-state=established,related
add chain=forward comment="default configuration" connection-state=\
established,related
add action=drop chain=forward comment="default configuration" connection-state=\
invalid
add action=drop chain=forward comment="default configuration" \
connection-nat-state=!dstnat connection-state=new in-interface=vlan1
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
out-interface=vlan1
/system package update
set channel=current
/tool graphing interface
add
/tool graphing queue
add
/tool graphing resource
add
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
/tool romon port
add

🗨️ 3
BocaDePez
BocaDePez
🗨️ 2
dakotabcn
🗨️ 1
BocaDePez
BocaDePez

ONO solamente te va a dar una IP pública, por lo que debes reiniciar el Netgear entre prueba y prueba.

🗨️ 4
BocaDePez
BocaDePez

No hay que reiniciar nada, cuando quitas NAT lo hace el solito.

🗨️ 3
dakotabcn

hay que reinicarlo si cambias de MAC, ya que tiene registrada la mac del otro equipo.

en mi caso la mac es la misma por un tema de IP, pero ni reiniciandolo. el mikrotik funciona tema dhcp seguro, por que lo conecto a mi red local y coge IP enseguida

he visto algo que podria ser la causa, pero hasta la noche no lo probare, mi linux la tarjeta esta a 100 (es gigabit, pero negocia a 100 con el router) y la mikrotik se pone a 1000, si es lo que sospecho el router esta fallando la parte switch

🗨️ 2
BocaDePez
BocaDePez

No hay que reiniciar nada, yo cambio de con NAT a sin NAT en mi router un par de veces al mes cambiando MAC y lo único que hay que hacer es cambiar la configuración en el router de Ono y en el neutro y esperar alrededor de un minuto. Funciona así tanto en el Netgear que tenía antes como en el Compal que tengo ahora.

Yo apostaría a que hay algo mal configurado en el Microtik, para el que está acostumbrado al clásico router doméstico a veces se hace un poco cuesta arriba.

BocaDePez
BocaDePez

Acabo de cambiar, nueva ip sin reiniciar el router. Cuando cambias de modo (NAT o sin NAT) el propio router reinicia la parte WAN y libera la ip.