BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra
💡

Cómo funciona IPv6 en la fibra de Orange

habbim
4

Aquí simplemente traigo cómo tiene implementada IPv6 Orange en mi zona, que es en concreto Valencia con fibra de 300 Mb simétricos.

Las condiciones sobre las que se han realizado los test es con live cd de Linux Mint Mate, usando cable y el mínimo de dispositivos conectado a la red.

Pings IPv6

google ipv6ovh ipv6ipv6 netflixbandaancha ipv6

Pings IPv4

En este caso tanto OVH como Netflix no responden.

bandaancha ipv6google ipv4

Traceroutes IPv6

Haga donde lo haga siempre figura la misma ruta, si me pueden explicar el por que se agradecería.

traceroute

Captura de ifconfig:

ifconfig

Captura parámetros equipo Orange:

parámetros equipo Orange

También añadir que dispongo de una ONT ZTE de la antigua Jazztel y utilizando hardware compatible con IPv6, en mi caso FritzBox 7490 libre alemán, solo puedo obtener IPv4 sin CG-NAT.

Sobre el tema de cómo implementan IPv4 pues es utilizando el protocolo DS-LITE por lo que estoy en CG-NAT, pero sobre el tema de puertos en IPv4 no está todo perdido ya que desde el router se puede realizar una solicitud PGP para la apertura del mismo.

Sobre como filtra los puertos en IPv6 Orange, a ver he podido realizar algunas pruebas y en la zona de NAT/PAT del router se pueden abrir seleccionado el dispositivo de la lista.

A lo largo del fin de semana intentaré añadir más info y si quieren algún test más o alguna prueba aprovechen los comentarios.

pepejil
1

¿Solo tres saltos hasta el servidor remoto? Impresionante.

Por cierto, se sabe si estas pruebas también las están aplicando a su red móvil?

🗨️ 1
habbim

Yo sospecho que lo de los 3 saltos es por algún tipo de tunelizado por el camino, sobre la red móvil poniendo el APN en modo IPv6 no logro conectar.

BocaDePez
BocaDePez

¿Podrías realizar unas trazas a las siguientes direcciones?

1.- 2001:470:0:2ae::2 (Hurricane Electric Interxion Madrid)

2.- 2001:7f8:2a:0:2:1:4:9835 (guifi.net Itconic Barcelona)

3.- 2a00:1508::a2:af32:ff1d:a10e (guifi.net NOC)

4.- 2001:690:a00:1036:1113::247 (FCCN GigaPIX Lisboa)

5.- 2001:12ff:0:6192::220 (PTT IX Brasil)

6.- 2001:9b0:: (Bahnhof Pionen Stockholm)

7.- 2a02:2e00:2020:2::1 (Jazztel Madrid)

8.- 2001:1498:1::32:5 (Telefónica Madrid)

9.- 2a02:23a0:1111:9999::39 (Nixval IXP LAN)

10.- 2a03:c7c0:1:1a:: (GinerNet DE-CIX Interxion Madrid)

11.- 2a03:c7c2::1 (GinerNet BitNAP Barcelona)

Muchas gracias.

Por cierto, tengo cuidado con SLAAC, el primer salto, etc. ya que has intentado ocultar ciertos datos pero se pueden deducir facilmente.

En mi caso estoy a 6 saltos de ti desde el norte de España.

🗨️ 2
habbim

A lo largo del día te lo paso

Luke

Las trazas son todas iguales. Deben tener algún tipo de tunelización o modificación de los TTL o lo que sea. En mi caso salen todas, todas así (cambiando la IP destino, claro):

Tracing route to guifinet-6.02.catnix.net [2001:7f8:2a:0:2:1:4:9835]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  2a01:c50e:8978:xxxx
  2    <1 ms    <1 ms    <1 ms  2a01:c50e:8978:xxxx
  3     *        *        *     Request timed out.
  4    33 ms    33 ms    33 ms  guifinet-6.02.catnix.net [2001:7f8:2a:0:2:1:4:9835]

Trace complete.

Yo si quieres te pongo los pings. No hay variación entre mediciones así que pongo 1 por cada ip:

Reply from 2001:470:0:2ae::2: time=61ms
Reply from 2001:7f8:2a:0:2:1:4:9835: time=33ms
Reply from 2a00:1508::a2:af32:ff1d:a10e: time=30ms
2001:690:a00:1036:1113::247 no responde a ping
Reply from 2001:12ff:0:6192::220: time=292ms
Reply from 2001:9b0::: time=62ms
Reply from 2a02:2e00:2020:2::1: time=5ms
Reply from 2001:1498:1::32:5: time=12ms
2a02:23a0:1111:9999::39 no responde a ping
Reply from 2a03:c7c0:1:1a::: time=3ms
Reply from 2a03:c7c2::1: time=12ms

por alguna razón el primer ping de cada medición no responde, después todos.

BocaDePez
BocaDePez

desde el router se puede realizar una solicitud PGP para la apertura del mismo.

¿Has probado el PGP, sabes si funciona en la práctica?

Por cierto, ¿el router es el Livebox Fibra?

🗨️ 8
habbim

Si lo he probado y a mi por lo menos me funciona , si es el Livebox Fibra.

🗨️ 7
BocaDePez
BocaDePez

Thanks, pues bueno, funcionando el PGP realmente debe dar igual estar bajo CG-NAT o tener IP pública.

🗨️ 6
habbim

Aun así cuando tenga tiempo probare algún que otro puerto especial, a ver hay que tener en cuenta que no deja de ser una solicitud de puertos, el servidor de orange te lo podría denegar o cambiarte el puerto o darte una ip diferente(cuando la solicitud esta aprobada te sale la ip real en la que esta abierta el puerto)

🗨️ 5
Sustrai
🗨️ 4
habbim
🗨️ 3
Sustrai
🗨️ 2
habbim
🗨️ 1
BocaDePez
BocaDePez

Sabes si estás conectacto a una CTO de Orange o de Jazztel?

🗨️ 4
habbim

Es del despliegue de Jazztel pero después de la integración con orange, a ver si me explico, mi zona la congelaron cuando jazztel fue comprada y al año volvieron a cablear.

En todas las cto pone orange pero se nota que es una pegatina puesta encima del logo de jazztel y la contrata que hacia el despliegue se identifico en todo momento como Jazztel/Orange.

Por si te surge la curiosidad mi zona es la torre en valencia.

🗨️ 3
BocaDePez
BocaDePez

habbim, y estás en general contento con el Livebox Fibra? He leido montones de quejas sobre él debido a bugs en su firmware: que si lo tienen que reiniciar casi a diario porque dejan de funcionar las reglas de NAT, que si el teléfono fijo empieza a tardar en responder cuando descuelgas o llamas, etc. El fijo lo usas?

🗨️ 2
BocaDePez
BocaDePez

A ver sobre el fijo, yo utilizó vozip por otro proveedor, por eso tengo el frtizbox, lo que pasa es que el fritzbox soporta voz analógica y por hay uso el fijo de orange, en alguna llamada se me ha quedado tonto o no me detecta tono el fritz si no lo reinicio(me toca reiniciar el router de orange), por el tema de la nat no he notado nada raro eso si hay veces que hay pedidas repentinas de WiFi.

Yo por ahora solo tengo el aparato de orange por hacer pruebas con el ipv6 pero de aquí unos días volveré a mi ONT.

Por si alguien lo pregunta, aparece el IDONT en el Livebox fibra y en claro.

🗨️ 1
BocaDePez
BocaDePez
Luke

Me lo acaban de activar en Madrid (zona metro Colombia). Parece que el router ya no tiene IP pública ipv4. A hacer pruebas se ha dicho (ahora mismo voy por ipv4 porque tengo un router propio que ahora tengo que configurar)

INTERNET FOR IPV4
Ethernet Uplink:  CONECTADO
IP WAN:  192.0.0.2
Máscara de Subred:  255.255.255.248
Puerta de enlace:  192.0.0.1
DNS Primaria:  0.0.0.0
DNS Secundaria:  0.0.0.0
DDNS:  Deshabilitado
INTERNET FOR IPV6
Ethernet Status:  CONNECTED
Puerta de enlace:  FE80::E681:84FF:FE44:xxxx
LAN GUA: 2A01:C50E:xxxx:xxxx:xxxx
Prefijo delegado:  2A01:C50E:xxxx:xxxx::/56
DNSv6 Primaria:  2a01:c500::1
DNSv6 Secundaria:  2a01:c500::2
🗨️ 12
sierpinski

Me alegra mucho leer esto, a ver si las demás se van animando paulatinamente, porque no me extrañaría que lo tuvieran ya todo preparado y estén a la espera de pulsar un botón.

🗨️ 1
Luke

Si.. esto es en casa de mi novia, en mi casa tengo movistar fibra y el router coge ipv6 en el lado WAN pero no delegan ningún prefijo, el router está todo configurado para que al asignar el prefijo ipv6 por pppoe funcione todo tal cual.

Hablando de asignar prefijos, tengo un asus ac68u detrás del livebox, y parece que orange no ha activado prefix delegation en el livebox, por lo que si pongo el asus en modo "ipv6 nativo", coge IPv6 WAN pero no es asignado un prefijo para su LAN. Así que hay que ponerlo en el modo que llaman Passthrough, que hace que la subred LAN ipv6 del livebox y del asus sean la misma. Todavía tengo que probar si el firewall del asus sigue funcionando en este caso, pero así me funciona. Por alguna razón bandaancha me conecta en ipv4, pero vamos, aquí prueba:

Pinging 2001:4860:4860::8888 with 32 bytes of data:
Reply from 2001:4860:4860::8888: time=3ms
Reply from 2001:4860:4860::8888: time=3ms
Reply from 2001:4860:4860::8888: time=3ms
Reply from 2001:4860:4860::8888: time=3ms

Ping statistics for 2001:4860:4860::8888:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 3ms, Maximum = 3ms, Average = 3ms
zoltan

Tienes que tapar el tercer y el cuarto, que son los que definen tu conexión. A partir del quinto hasta el octavo segmento de la IP, son parte de hosts de tu red que puedes ajustarlos a tu gusto, en plan 2A01:C50E:x:y:bebe:cafe:69:1 con la asignación manual de la IP.

Ocultar parte de FE80 es como ocultar 192.168.x.x, es rango de red privada.

🗨️ 9
Luke

sí, había tapado el cuarto (prefijo 56) pero se me pasó en la IP lan del router. Ahora lo cambio

El fe80 lo había tapado por ser una ip link local de orange (esa ip es la puerta de enlace para el lado WAN del router, no es la link local propia del router), por si de alguna forma también podía ser identificativa más que por seguridad.

saludos!

edito: ah, pues no puedo editar ya el mensaje. Bueh, me fio del firewall :P

🗨️ 8
Luke

ya me aparece la ipv6 al postear en bandaancha. sería caché dns en algún sitio

🗨️ 6
BocaDePez
BocaDePez
🗨️ 5
Luke
🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
Luke
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
superllo

Supongo que he quitado lo problemático. Algún día me tengo que poner a ver eso del IPv6.

Luke

Pues tal como vino se fue. Ayer no había conectividad al llegar a casa por la noche, reiniciamos el router de orange y de vuelta a ipv4 con la ip pública de siempre.

misterios...

🗨️ 8
BocaDePez
BocaDePez

Probablemente hayan recibido quejas (ipv6 no funciona nada bien, algunas páginas dejan de funcionar...) y lo hayan tenido que quitar.

🗨️ 7
zoltan

Pues se han lucido y mucho los de Orange, habrán montado mal, esos tracerts que hay en este post no los tengo con IPv6 de Movistar. No he tenido ningún problema con la navegación y con la IP de IPv4 pública sin inventos raros que hacen añadir complejidad.

Es una pena esas experiencias porque harán que las operadoras tengan más miedo al cambio.

rbetancor

Me chirrían los dientes cada vez que leo cosas del estilo 'ipv6 no funciona nada bien' ... porque la forma correcta de expresarlo es 'el operador X no tiene ni PUTA IDEA de como tienen que montar ipv6'

🗨️ 5
BocaDePez
BocaDePez

Pues cosas así:

Imposibilidad de acceder a BA a través de IPv6

Imagina la cantidad de webs y servicios que tienen el IPv6 roto porque sólo lo probaron cuando lo configuraron y luego el servicio IPv6 se quedó en el olvido y lleva roto desde el pleistoceno.

Es el simple hecho de que al ser un servicio de segunda (comparado con IPv4) lo que propicia eso: registros AAAA que apuntan a IPs que no van, rutas rotas según qué operadores, servicios que no son compatibles con IPv6 (intenta entrar a /mi-ip desde IPv6. Al menos a mí me da error 500), etc.

En fin, una pérdida de tiempo, la cual lleva a que "desactivar ipv6" sea igual que "quitar la morralla de Windows 10": un paso obligatorio en la configuración de un nuevo sistema.

🗨️ 3
zoltan
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
zoltan
BocaDePez
BocaDePez

+1.

BocaDePez
BocaDePez

A mi Orange me pasó a IPV6 a principios de Junio con el router Livebox y fibra.

Tengo problemas graves, ya que tengo una cámara IP publica, y tengo que abrir los puertos PCP (PGP o CGNAT) a diario.

Entro en IPv6 PCP y hago la petición de abrir los puertos 80 y 554. Se abren sin problema, pero al cabo de unas 18h, Orange los cierra de nuevo. ¿Porque? Ni idea, pero ya no tenemos control desde nuestro router. Los puertos se abren en la centralita de Orange, y cada día se ha de volver a hacer la petición para que se pueda ver la cámara desde fuera.

El router ya no se guarda los puertos que abro. Así que cada día se ha de entrar en el router y volver a escribir la petición PCP de los 2 puertos. No conozco ninguna forma de automatizarlo.

Al final solo me quedaran 2 opciones, pedir y pagar una IPv4 fija, o bien cambiar de proveedor internet. Pero no estoy seguro que con Movistar o Vodafone, no pase lo mismo.

¿A vosotros también se os cierran los puertos abiertos con PCP diariamente?

🗨️ 6
BocaDePez
BocaDePez
-1

Ni Movistar ni Vodafone tienen la mierda de IPv6, por lo que con ellos no tendrías problemas.

Quizá, si llames a Orange, te lo quiten. Pero no creo que el teleoperador medio vaya a tener ni idea de lo que estás hablando.

🗨️ 5
zoltan

IPv6 no es una mierda, sino todo lo contrario.

El problema es que los de Orange lo están cagando en proporciones épicas, lo están haciendo fatal. Que les costaba mantener la IPv4 pública.

Ahora por culpa de Orange, IPv6 se está ganando una mala fama de forma inmerecida.

En Movistar, todos sus usuarios están recibiendo rango IPv6 en sus routers con un filtrado de salida impidiendo su uso, yo desde hace dos años y medio, por lo cual su red está totalmente preparada. Sólo falta una decisión política para abrir el grifo y pasar de 1% a 35% la penetración de IPv6 en España.

🗨️ 3
BocaDePez
BocaDePez

No es cierto que todos los usuarios de Movistar reciban IPv6. Va por centrales, algunas están preparadas y otras no.

BocaDePez
BocaDePez

Orange puede vender las IPv4 públicas a Movistar para que este siga todavía mucho tiempo sin IPv6 ?

Ahora vendiendo las IPv4 todavía puede ganarse algo. Una vez la mayoría de los operadores pasen a IPv6 ya nadie querrá comprar las IPv4.

🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez
1

Oyes campanas, pero no sabes donde.

Neophyte

Yo sospecho que en mi caso también han intentado ponerme ipv6 (orange 300/300), ya que justo el dia 25 de mayo tuve que reiniciar el router porque no tenía acceso en bastantes horas.

En mi caso tengo un R7000 con merlin, alguien realmente sabe como configurarlo para que coja ipv6 si es que realmente me la han activado?

@Luke saludos crack!!!

BocaDePez
BocaDePez

Parece que Orange va muy en serio y aprovecha el verano cuando la gente utiliza menos internet en casa para cambiar a IPv6.

Ahora también en fibra indirecta 50/50 con Orange Livebox 2.1 IPv6 con un prefijo IPv6 delegado (IPv6-PD) 2a01:c50e:xxxx:xx00::/56. No he probado todavía si el Livebox pasa todas las 256 subredes /64 por DHCPv6 a la red interior. No está mal poder tener en casa 256 distintas subredes IPv6.

IPv4 va por CG-NAT. El Livebox tiene la IP externa 192.0.0.2, la que en CG-NAT se traduce a 62.151.150.x. La puerta de enlace IPv4: 192.0.0.1.

Los servidores DNS IPv6:

2a01:c500::1

2a01:c500::2

🗨️ 7
pcmaster

¿En qué ciudad? Yo en Barcelona también tengo fibra 50/50 con un Livebox 2.1 y todavía sigo en Ipv4. De hecho, ni siquiera el router se ha actualizado a un firmware compatible IPv6.

🗨️ 3
BocaDePez
BocaDePez

Madrid centro. El firmware de Livebox es el 00.96.806B (25.01.2017-14:54:55).

Tengo un problema de momento. El Livebox no dispone de una IPv6 pública en su interfaz WAN. Sólo tiene una en LAN. Aunque deja configurar una IPv6 desde la que se permite acceder al Livebox desde fuera y se puede acceder a la IPv6 LAN de Livebox con la página de usuario y contraseña desde esa IPv6 fuera de casa, al introducir los datos muestra: "Error: no puedo conectarme desde la interfaz WAN!" Así que de momento el acceso remoto al Livebox por IPv6 desde fuera no es posible.

🗨️ 2
pcmaster

No entiendo que el Livebox tenga un prefijo delegado y no una IP pública WAN en IPv6.

En IPv4 para poder conectarte al Livebox desde fuera tenías que activar la administración remota. O sea que sospecho que sí tiene una IPV6 pública pero no deja conectarte por seguridad, has de activar igualmente la administración remota.

Mi Livebox 2.1 tiene todavía el firmware 00.96.320 (06.11.2015-09:18:11) y no encuentra actualizaciones.

🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez

a mi no me ha funcionado el dhcp-pd poniendo un asus de cliente. Asi que no se para qué un /56 si solo se asigna un /64 a LAN sin poder usar el resto. Tengo que investigar pero de primeras no me ha funcionado..

🗨️ 2
BocaDePez
BocaDePez

¿Pusiste Asus en vez de Livebox o detrás del Livebox? ¿Configuraste un "hint" /64 ó /60 ó /56 para el cliente DHCPv6-PD en Asus?

🗨️ 1
Luke

Asus detrás del livebox (no tengo ahora mismo aparatos para dar voz analógica a la casa aparte del livebox), y hasta donde sé no se puede configurar hint en el asus, al menos con el firmware estándar (o no lo he visto).

En principio según tengo entendido si el livebox estuviese configurado para hacer prefix delegation, cosa que tendría que activar orange porque no hay interfaz para ello, el asus debería coger un rango ipv6 automáticamente (más pequeño que el /56 que asigna orange, claro) ya que el livebox solo asigna un /64 a la LAN. Hay mucho espacio sin usar ahora mismo

txumino

Buenas tardes, desde ayer que reinicié tanto ont como router, me ha aparecido en el router ipv6, pero no tengo ni idea ni de como funciona ni de como hacerla funcionar, puerto que intento hacer pings a ips que por ejemplo ponen en el mensaje principal y no me funcionan, ¿me falta algo de configurar?

Además noto caída en la velocidad de internet, no me funciona igual que antes.01.jpg02.jpg