BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

ownCloud sobre NAT con el F680 super lento

BocaDePez
BocaDePez

¿Os funciona bien el NAT en el F680?

Estoy intentando usar owncloud "desde fuera", he abierto el puerto en "Port Fordwaring" y le he dicho a owncloud que acepte el dominio del dns dinámco de jazztel. Y funciona , pero super super super lento. Si accedo desde la app móvil ni siquiera se llega a conectar por el timeout tan largo. En cambio usando la red local vuela.

Tengo 200/200.

Alguna sugerencia?

BocaDePez
BocaDePez
1

Me contesto a mi mismo.

Me temo que es culpa del NAT Loopback que no debe funcionar en este router.

Lo estoy probando sobre 3G y ahora va bien. Si uso la IP pública desde casa a veces va y otras se queda pillado.

¿Me podéis confirmar si este router "premium" no hace NAT Loopback o si se le puede activar?

Saludos.

🗨️ 29
superllo

Sí que hace NAT loopback. No veo que se pueda desactivar pero no me he visto todos los apartados. Supongo que si se pudiera hacer no sería con el usuario jazztel.

🗨️ 27
BocaDePez
BocaDePez

Pues no me funciona el NAT Loopback en este router. ¿Me lo puedes confirmar?

Igual es por que es el modelo nuevo (el que no lleva antenas).

Tendré que investigar.

🗨️ 26
superllo

Yo tengo el viejo y si hago ping a la dirección xxx.ddns.jazztel.es sí que me responde la interfaz WAN.

🗨️ 25
BocaDePez
BocaDePez
🗨️ 24
superllo
🗨️ 21
BocaDePez
BocaDePez
🗨️ 20
superllo
-1
🗨️ 19
BocaDePez
BocaDePez
🗨️ 18
BocaDePez
BocaDePez
🗨️ 16
BocaDePez
BocaDePez
BocaDePez
BocaDePez
🗨️ 14
BocaDePez
BocaDePez
🗨️ 13
BocaDePez
BocaDePez
🗨️ 9
mceds
🗨️ 8
rbetancor
1
🗨️ 7
mceds
🗨️ 6
jesjimher
🗨️ 5
mceds
🗨️ 4
jesjimher
🗨️ 3
mceds
🗨️ 2
jesjimher
🗨️ 1
rbetancor
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez
1

Conclusión después de mil pruebas:

No funciona bien el NAT Loopback en este router (al menos a mí no me funcionado de ninguna manera).

Solución:

Me he instalado un servidor DNS propio que redirige xxxx.ddns.jazztel.es a la ip interna donde tengo owncloud y los otros servicios, he configurado en el F680 para que el DHCP ponga de DNS primario mi servidor dns, y ahora todo funciona perfectamente. Puedo configurar las apps de mis dispositivos móviles que sincronizan con mi owncloud. He puesto mi servidor dns en el DHCP del F680 para que lo asigne a todos los clientes en lugar de configurar el dns de forma manual solo en los dispositivos móviles por que gracias al caché del dns interno la resolución de nombres vuela.

vukits

Estoy intentando usar owncloud "desde fuera",

quieres decir, que desde dentro intentas conectarte usando la ip publica..

eso es perfectamente normal...

lo de Nat Loopback ... bueno... puede funcionar o puede que no

BocaDePez
BocaDePez

Aquí entiendo que hay dos temas diferentes. Uno es la redirección del puerto, que te lleve al servicio interno correctamente desde fuera (como casi todos hacemos con el P2P) y otra es el NAT Loopback, que te permita emular ese comportamiento pero desde dentro.

Si realmente lo haces desde fuera, desde una red ajena (sea un móvil u otro ordenador en otro domicilio) y va mal, empezaría a buscar el problema en el servicio de ownclowd en sí mismo (que no conozco y no puedo ayudar ahí, lo siento) antes de echar las culpas al comportamiento del F680.

Porque en realidad una redirección de puertos es muy tonta: o va, o no va... pero no puede ir "a veces". Ese problema, sin embargo, sí que lo veo más asociado al backend que estés utilizando.

BocaDePez
BocaDePez

Si, este router no hace nat lookup o no lo hace bien. A mi tampoco me funciona si pongo nombre desde dentro de la red local no me va, pero por ip sin problema y desde fuera me va bien siempre.

Otra cagadita del cacharro.