BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Disco encriptado

javilml85

a,

Soy nuevo en este foro, por lo que me gustaría daros las gracias por adelantado por vuestra atención.

Veréis, el problema es el siguiente, tengo 2 discos en RAID1 con la partición encriptada, debido a algún problema se me ha desconfigurado y el ordenador no arranca, lo que quiero es montarlo en linux con un par de cajas externas (aunque con uno en teoría tendría que valer),pero claro, al tener la partición encriptada, sabe que es un linux raid autodetect, lo pone como "activo" después de hacer un mdadm --assemble --scan pero no consigue montarlo(porque no tiene una tabla de particiones válida).

La cuestión es: ¿Hay alguna forma de que me pida la clave para poder montarlo y recuperar los datos que tiene?

vukits

¿Has probado a montarlo desde un LiveCD de Gparted?

BocaDePez
BocaDePez

Si, primero tienes que montar el raid, segundo la particion. Está cifrada con luks?:

cryptsetup luksOpen /dev/dispositivo disco-cifrado

Sino, prueba a meter un solo disco en tu ordenador y a instalar grub si es el disco que no tiene grub.

Imagino que hablamos de RAID por software y no por hardware.

BocaDePez
BocaDePez

El problema es que al tener la particion encriptada no me deja montarlo puesto que no existe ningún sistema de fiheros que pueda reconocer.

🗨️ 4
BocaDePez
BocaDePez

Primero tienes que montarlo como te dije:

cryptsetup luksOpen /dev/dispositivoraidquesea etiqueta

no cambies "etiqueta", sólo dispositivoraidquesea por el valor de tu raid (primero has de montar el raid)

Una vez le pongas bien la clave, verás en: /dev/mapper/ un archivo (como minimo) llamado etiqueta.

Pues bien, ahora:

mount /dev/mapper/etiqueta donde sea

o bien si tienes varias particiones tendrás que cambiar un poco el método, pero basicamente es ese.

🗨️ 3
BocaDePez
BocaDePez

que se compre un ordenador nuevo, y listo... és más fácil.

🗨️ 2
superllo

Hombre, formateando el disco se soluciona pero él quiere recuperar lo que tiene.

🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez

Si alguien encriptó los datos será para que tú no puedas verlos.

🗨️ 1
superllo

La cuestión es: ¿Hay alguna forma de que me pida la clave para poder montarlo y recuperar los datos que tiene?

En esa frase insinúa que tiene la clave.

vukits

¿has recreado la RAID?

🗨️ 1
BocaDePez
BocaDePez

El RAID 1 ya estaba creado, lo usaba yo por eso tengo la clave y lo que quiero es volver a montarlo.

BocaDePez
BocaDePez

Muy Buenas,

Tengo el mismo problema.

Despues de una reinstallacion del systema operativo, a reassembla una raid 6 con 8 discos de 1Go me ha salido un mesage de que todo se ha assemblado bien con un resize de la grapa raid....

Personalities : [raid6] [raid5] [raid4]
md0 : active raid6 sdc1[0] sdf1[7](S) sdh1[6] sdd1[5] sdg1[4] sda1[3] sdi1[2] sdb1[1]
4883799680 blocks level 6, 64k chunk, algorithm 2 [7/7] [UUUUUUU]

El problema es igual que mi compañero.

# cryptsetup luksOpen /dev/md0 md0_crypt
El dispositivo /dev/md0 no es un dispositivo LUKS válido.

Tengo todas mis fotos, trabajos, .., y no consigo crear el fichero especial de encryptacion. /dev/mapper/...

Gracias para echar una mano.