Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL

Desactivar firewall en HG556a de Vodafone para poder abrir puertos

fermaki

Tengo el router HG556a de Vodafone, le he metido varios firmwares. Actualmente tengo el V100R001C08B026.

El caso es que no consigo abrir puertos, los configuro en NAT, los configuro en port triggering, añado una regla de puerto en IP incoming filtering pero no hay tu tía. No tengo firewall en windows y no es la primera vez que configuro routers, pero este se me ha atragantado.

No consigo abrir ningún puerto. Las pruebas las estoy haciendo con el puerto 10000 para webmin y el 21 para un ftp.

Si me descargo el archivo de configuración del router y lo edito con el notepad++ siempre, con los diferentes firmwares, me aparece el firewall enabled, ¿cómo deshabilito el firewall?

Por telnet si que puedo entrar, ¿hay alguna manera de hacerlo por telnet?

jdamr2p

a mi me pasa exactamente los mismo en ubuntu con el HG553

🗨️ 1
BocaDePez
BocaDePez

bien, pero no es cuestion del sistema operativo, yo tengo el ftp en windows y el webmin en ubuntu, y no consigo abrir los puertos, creo que es por el firewall del router que está siempre activado y no se desactivarlo.

esa es mi pregunta, ¿como se desactiva el firewall del router??

nos vemos por los bares

BocaDePez
BocaDePez

Para desactivar el firewall del router hg556a, son unos pocos sencillos pasos, a los que he conseguido llegar después de 3 horas comiéndome la cabeza, primero os explico cómo y luego el método (todo el proceso se hace habiendo accedido al router como admin/VF-EShg556):

Accede a 192.168.0.1/en_US/natcfg2.html (conectado al router, claro), en esa misma pantalla te sale una casilla de verificación con la que desactivas el firewall, pero no es todo, le dices "SAVE" y te saldrá otra pantalla en la que la opción es "SAVE/REBOOT", NO le des, simplemente en la barra de direcciones escribes 192.168.0.1/en_US/main.html y ahí te vas a "Advanced Setup" --> "WAN" y le dices a todo "Next", verás que la última pantalla te da un sumario en el que la opción "Firewall" está desactivada, ahora pulsas "SAVE" NO "SAVE/REBOOT", una vez hecho esto, ya tienes el firewall desactivado, puedes comprobarlo bajando el archivo de configuración en 192.168.0.1/en_US/backupsettings.conf, guardas el archivo, lo abres con Notepad y buscas la cadena "firewall", verás que pone "disable".

Si abres una ventana de símbolo del sistema (cmd) y escribes:

telnet 192.168.0.1
User: admin
Pass: VF-EShg556

luego tecleas: sh

te abre una sesión del shell de busybox Linux interno del router, tecleas:

cd doc/en_US
ls

Y dentro hay un montón de archivos html, son todas las páginas del router, ocultas o no a las que acceden los técnicos de VF para hacerte creer que son indispensables, la forma de usar esos archivos es la siguiente, pongamos que los archivos tienes nombre del tipo xxx.html, pues en tu navegador pones 192.168.0.1/en_US/xxx.html y te saldrá la página seleccionada, muchas son las que vienen para que las veas, otras no, de ahí sale la página natcfg2.html desde donde desactivar el firewall del hg556a de Vodafone.

Un par apuntes más y dejo de daros la vara, uno es que hoy es cuando he recibido el router de Vodafone y he sacado esto, lo digo porque hay versiones que cuando entras como admin, directamente puedes acceder a "advanced Setup" → "Security" y desactivar el firewall, en mi caso no es así.

Otro es que según el país donde estéis la contraseña de admin es VF-XXhg556, donde XX es el código del país, cuidado que la contraseña es sensible a mayúsculas y minúsculas.

Otro es que donde pongo la dirección del router en el navegador (en mi caso 192.168.0.1) lo pongo así porque uso Chrome, quien no pueda acceder que lo escriba poniendo delante http://

Y la última es que espero que nadie se sienta ofendido por poner las cosas como para quien no sabe absolutamente nada, en su momento a mi también me hubiese gustado que me explicaran las cosas sin tanta jerga supuestamente sobreentendida.

🗨️ 1
BocaDePez
BocaDePez

he puesto esto:

192.168.0.1/en_US/natcfg2.html , y luego al introducir el nombre de usuario y contraseña, se queda toda la pantalla en blanco y no pasa nada.