Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
36 lecturas y 1 respuestas
  • Cerrado

    BocaDePez BocaDePez
    6

    abrir puertos control remoto emule en el alcatel thomson speedtouch 510i

    Estoy que hecho humo con este tema, a ver si alguien me hecha una mano.

    He recibido recientemente mi kit de acceso adsl de arsys con un fabuloso alcatel thomson speedtouch 510i.

    Me puse a configurarlo con ip dinamica y configuracion personalizada (DHCP)
    Rango de ips privadas 192.168.1.3 a 192.168.1.230
    Dejo desde la 192.168.1.231 hasta la 192.168.1.254 para poner servidores con ip fija.
    Sin problemas para navegar.

    Puse a trabajar el emule en mi "maquina emule" 192.168.1.254
    Funcionaba sin problema salvo el de que cogia lowid.
    Entonces abri los puertos con el software que trae para ello.
    Abri unos puertos de emule en otros diferentes a los habituales (pero que coinciden con los que puse en la configuracion del emule) pero los dos TCP 5672 y UDP 5772
    Volvi a lanzar el emule y pillo highid (hasta aquí estaba muy contento)

    Configuré en el puerto 5678 el servicio web de control remoto del emule.
    TCP 5678 servicio web de control remoto del emule.
    Lo probe en la intranet y funcionaba.

    Volví a abrir los puertos con ese programa para el puerto 5678 que lo enviase a 192.168.1.254:5678

    Todo contento me fui al curro e intente acceder desde la oficina al cliente web de mi emule… pero decepcionantemente no accedía.

    Revise la configuracion desde mi intranet de casa y curiosamente en el interfaz web de configuracion del ST en la parte de nat a ratos aparece los forward de puertos que habia configurado y a ratos no…
    Así que para cerciorame me conecte al router por telnet y comprobe que en nat estaba redirigidos dichos puertos.

    Ya mosqueado con el asunto revise el firewall y
    Encontre reglas como las siguientes reglas…

    firewall rule create chain=gestion index=0 srcintfgrp=wan prot=udp dstport=dns action=accept
    firewall rule create chain=gestion index=1 srcintfgrp=wan prot=icmp action=accept
    firewall rule create chain=gestion index=2 srcintfgrp=wan action=drop
    rule create chain=forward index=0 srcintfgrp=wan dstintfgrp=wan action=drop

    Ok…
    Entonces porque no me gustaba quite la regla con index=1 porque no me gustaba
    firewall rule delete chain=gestion index=0

    De nuevo liste las reglas y quedaban asi

    firewall rule create chain=gestion index=0 srcintfgrp=wan prot=udp dstport=dns action=accept
    firewall rule create chain=gestion index=1 srcintfgrp=wan action=drop
    firewall rule create chain=forward index=0 srcintfgrp=wan dstintfgrp=wan action=drop

    Y entonces decidi crear una regla para que aceptase mis conexiones externas al puerto 5678 que tenia redirigido
    firewall rule create chain=gestion index=0 srcintfgrp=wan prot=tcp dstport=5678 action=accept

    De nuevo liste las reglas y quedan asi:
    firewall rule create chain=gestion index=0 srcintfgrp=wan prot=tcp dstport=5678 action=accept
    firewall rule create chain=gestion index=1 srcintfgrp=wan prot=udp dstport=dns action=accept
    firewall rule create chain=gestion index=2 srcintfgrp=wan action=drop
    firewall rule create chain=forward index=0 srcintfgrp=wan dstintfgrp=wan action=drop

    Y no funciona con un navegador a http://micasa.no-ip.org:5678 desde mi trabajo
    Pero desde la intranet si funciona http://192.168.1.254:5678

    ¿Que pasa? ¿Por qué me da high id el emule, si no funciona para el TCP 5678 no deberia funcionar para el TCP de emule tampoco (que ni si quiera he añadido en la regla del firewall para que lo acepte)?

    Según estoy redactando esto se me ocurre una hipotesis que tengo que probar…
    ¿a caso el highid lo está dando por el puerto UDP del emule? Parece que en el firewall no hay ninguna regla que refiera a orgigen wan y protocolo UDP… ¿qué pasa si no existe ninguna regla para ello?
    ¿Qué pasa cuando hay dos reglas que su condicion es valida para un mismo paquete?
    En las reglas actuales:
    firewall rule create chain=gestion index=0 srcintfgrp=wan prot=tcp dstport=5678 action=accept
    Y
    firewall rule create chain=gestion index=2 srcintfgrp=wan action=drop
    Son válidas
    ¿No se aplican en el orden del index? ¿Cómo funcionan las cadenas de reglas?
    ¿Quizas quitando la regla?
    firewall rule create chain=gestion index=2 srcintfgrp=wan action=drop
    ¿Se solucione el problema con el puerto TCP 5678 por que se aplique la otra regla (la primera)?
    ¿Y entonces, si quito la regla con index=2? ¿que pasará con los otros paquetes que vayan a otros puertos TCP?

    Bueno, voy a probar mi hipotesis y estas preguntas, no obstante agradeceré cualquier comentario o respuesta a todas las preguntas formuladas, y creo que aunque yo igual haya solucionado el problema en el momento que lea vuestras respuestas, pueden ser de interes para publicarlas en cualquier foro relacionado con estos temas.

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1