Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

💡

Activar SSH en el router Xiaomi AC2350 y configurar VLAN y PPPoE de Lowi

9ave
6
Mi AIoT Router AC2350

Como tengo el router Xiaomi AC2350, quería utilizarlo para sustituir el router de Lowi configurando el PPPoE. Buscando por internet no encontré nada para configurar el PPPoE ni información en español de como acceder y activar el SSH, así que vengo a compartirlo por si a alguien le es útil.

Activar SSH en el router Xiaomi AC2350

Buscando información llegué al foro de OpenWrt. En este enlace tenéis los pasos en inglés. Hace nada se consiguió activar el SSH en el router.

Los pasos y ficheros lo tenéis en el repo de eisaev: github.com/eisaev/r2350

  • Reset a fábrica
  • Instalar el firmware chino del repositorio
  • Iniciar sesión en la web del router y guardar el valor stok= de la URL
  • Entrar en: http://<IP-router>/cgi-bin/luci/;stok=<STOK>/api/misystem/set_config_iotdev?bssid=any&user_id=any&ssid=-h%0Anvram%20set%20ssh_en%3D1%0Anvram%20commit%0Ased%20-i%20%27s%2Fchannel%3D.%2A%2Fchannel%3D%5C%5C%22debug%5C%5C%22%2Fg%27%20%2Fetc%2Finit.d%2Fdropbear%0A%2Fetc%2Finit.d%2Fdropbear%20start%0A

Cambiar el valor de <IP-router> por la IP de vuestro router y <STOK> por el valor que guardamos antes.

Con eso ya tenemos activado el SSH del router. El usuario es root y la contraseña la podéis conseguir aquí con vuestro número de serie.

Para tener el SSH de manera permanente recomiendo seguir los pasos del repositorio de github:

  • Create Full Backup
  • Flash Modified RootFS
  • Patch Bdata Partition
  • Patch art Partition

Al terminar el router estará con el firmware 3.0.36 y todo debería funcionar. Recomiendo realizar los pasos conectados directamente al router ya que es posible que en algún paso el router no de señal wifi.

Configurar el PPPoE de Lowi

Al hacer esto se pierde el acceso al configurador web, así que configurar las redes wifi ahora

Primero necesitamos el username y el password de Lowi para configurar el PPPoE en el router.

Todos los pasos lo tenéis en el siguiente hilo: Cambiar el router Sercomm H500-S de Lowi por otro

En resumen:

  • Reset a fabrica del router de Lowi desconectada de la ONT
  • Entrar al router con admin y l033i-h500s desde el portal web
  • Activar el port mirror
  • Instalar el WireShark en el ordenador, conectar la ONT al router al puerto WAN y el ordenador al LAN1 y esnifar el tráfico.
  • Pararlo a los 5 minutos y buscar WANPPPConnection.2.Username.

Ese es el username y mas abajo estará el password en WANPPPConnection.2.Password.

Mediante SSH accedemos al router a /etc/config y editamos el archivo network. Yo lo hice desde WinSCP pero se puede hacer desde Putty o similar.

La configuración ha de ser la siguiente:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0.1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.31.1'
	option netmask '255.255.255.0'
	option ipv6 '0'
	option multicast_querier '0'
	option igmp_snooping '0'
	option macaddr '<MAC-ADDRESS>'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config interface 'wan'
	option proto 'pppoe'
	option ifname 'eth0.24'
	option username '<LOWI-USERNAME>'
	option password '<LOWI-PASSWORD>'
	option ipv6 auto
	option vid '24'
	option pppd_options 'debug'

config switch_vlan 'lan_vlan'
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4 5'

config switch_vlan 'wan_vlan'
	option device 'switch0'
	option vlan '2'
	option ports '0t 1'
	option vid '24'

config device
	option name 'eth0.1'
	option mtu '1500'
	option macaddr '<MAC-ADDRESS-ETH0.1>'

config device
	option name 'eth0.24'
	option mtu '1492'
	option macaddr '<MAC-ADDRESS-ETH0.2>'

configure interface 'wwan'
	option proto 'dhcp'

A editar:

  • <MAC-ADDRESS> la que os sale en vuestro fichero network
  • <Lowi-USERNAME> el username que conseguimos con WireShark
  • <Lowi-PASSWORD> el password que conseguimos con WireShark
  • <MAC-ADDRESS-ETH0.1> la MAC que ya tenéis en vuestro fichero network de la eth0.1
  • <MAC-ADDRESS-ETH0.2> la MAC que ya tenéis en vuestro fichero network de la eth0.2

En Lowi el VLAN id es 24. Si lo intentáis en otra compañía será otro. Si es así tendréis que cambiar el 24 de eth0.24 por el VLAN de vuestra compañía al igual que el vid del fichero network.

Reiniciamos y ya os debería funcionar. Deciros que no soy un entendido de esto y seguramente se pueda optimizar el código. Lo conseguí después de varias pruebas y muchísimos intentos fallidos pero no encontré nada por internet sobre este router y el PPPoE de Lowi.

vukits

Muchas gracias por el aporte.

BocaDePez
BocaDePez
2

Gracias por la info.

Un tema sobre el SSH, si el equipo esta soportado en OpenWrt, ¿no sería más fácil instalar OpenWrt "puro" en lugar de la versión de Xiaomi? En OpenWrt no tiene demasiado misterio activar el SSH.

heffeque

Menuda currada.

Y todo porque algunas compañías no quieren que uses tu propio router por alguna extraña razón .

🗨️ 2
jesjimher

Hombre, la extraña razón es que, cuando les llames porque el internete va lento, puedan entrar y mirar qué pasa, cosa imposible si te has puesto un router neutro.

Que no quita que deberían ofrecer la opción de usar tu propio router, bajo tu cuenta y riesgo, pero motivos tienen.

🗨️ 1
heffeque

Bueno, avisas de que no das soporte a routers de terceros y santas pascuas

ByMick

Muy buen manual, muchas gracias!

Alexxa

¿Y si mi router Lowi no tiene puerto WAN? Mi router tiene un puerto de fibra óptica.

Muchas gracias por el extenso hilo.

🗨️ 1
NachoSH

El puerto WAN es el del Xiaomi. El de Lowi tiene LAN (y es el que debes conectar al Xiaomi, tras ponerlo en modo bridge).

O bien comprar una ONT.

jesjimher

Yo estuve rompiéndome los cuernos con lo de sacar usuario y password para el PPPoE reseteando el Sercomm y monitorizando con wireshark, pero no hubo manera, ese usuario genérico de serie no funcionaba (y mira que lo había hecho anteriormente con Vodafone sin problemas, pero en Lowi o han cambiado algo o algo se me escapaba). Al final, lo conseguí de una forma mucho más sencilla, sin wireshark ni nada: instalar un script en cualquier ordenador que emula el ONT, y le pide al router usuario y pass. Sirve para cualquier operador, y en 30 segundos tienes la información, sin hacer apenas nada. Aquí las instrucciones:

frikidelto.com/tutorial/como-conseguir-e…outer-neutro

Si tienes TV o teléfono fijo la cosa es más complicada, pero para el caso de Lowi, con esto ya se obtiene toda la información para configurar el internete en cualquier router genérico.