BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Windows 11 deja de conectar a mi router por wifi y dice que no tiene dirección IP válida

Richipalomino101

Hoy como todos los días, he encendido mi PC fijo por vi wifi y como siempre y mi sorpresa es que no me funciona internet. Está conectado, pero sin acceso a internet. A veces también pone conexión segura pero no carga.

Mi sorpresa, es que en la Play, o mi móvil si que funciona, y tras mucho probar esto es lo que he conseguido indagar.

  • Si creo una red wifi con mi móvil, funciona perfectamente en el PC.
  • Si reseteo de fábrica el router, durante 5-7 min, me funciona bien internet en el PC, pero tras ese tiempo deja de funcionar (en los demás dispositivos me funciona internet).

En el solucionador de problemas me dice que no tengo una dirección de IP válida.

He probado a olvidar la red wifi, establecer de fábrica los valores de red y Windows Defender, desinstalar el controlador de wifi, poner la IP y DNS por mi cuenta en IPv4, restablecer por comandos cmd el DNS caché, y otros códigos que he visto por la red y también en services una cosa de Microsoft.

Ya no se qué hacer, desconozco por qué ocurre y qué puedo hacer.

vukits

¿Qué versión de Windows es?

🗨️ 1
Richipalomino101

Windows 11 Pro.

Internet más móvil 100mb.

Llevo usándolo (es PC nuevo), desde diciembre y todo bien, la última vez que lo utilice fue ayer a última hora y todo iba bien…

BoccaDePez
1

La locura que te ha ocurrido a ti, algo parecido me ocurrió a mi, pueden ser interferencias de radio en los canales WiFi

🗨️ 1
Richipalomino101

La verdad que me sorprendió mucho, porque no he instalado nada, y el último día funcionando todo perfecto. Incluso a veces me pone conectado bueno con conexión segura, y le carga al minuto una página como Google …

Probaré lo que dices pero si interfiere en el ordenador, debería interferir en el móvil entiendo?

pikiki1979
1

Añado dos puntos que no indicas que hayas probado, por si acaso:

  • Si el WI-FI emite en 2.4 y 5 GHz, cambiar de banda.
  • Probar con otros canales.

Por si fuera tu receptor WI-FI (del PC):

  • Cambiar el adaptador a otro puerto USB o en otra ranura PCI (según el caso).
  • Prueba con otro adaptador diferente al que estás usando habitualmente.

Saludos.

🗨️ 1
Richipalomino101

En relación a la pregunta uno, si probé tanto con la 2,4G como la 5G. En ninguna va y ambas dicen lo mismo.

En relación a la segunda no tengo otro adaptador, pero el que lleva esta integrado en la placa base de serie (es un fijo) y con doble antena atras.

Nixie
1

Supongo que has probado a reiniciar Windows con la opción Reiniciar y no apagando y encendiendo, que con el inicio rápido activado no es lo mismo. A veces se queda tonto y se arregla así,

Si te dice que no tienes una IP válida, cuando dices que has asignado una IP, ¿es en el rango correcto (192.168.0.x o 192.168.1.x)? Si por algún motivo no te asigna IP y pones una a mano, el solucionador ya no debería decir que no tienes una IP válida sino otra cosa.

🗨️ 2
Richipalomino101

Correcto, reiniciaba dándole a reiniciar y en cuántos valores correctos, vi un vídeo en YouTube y diría que lo hice correcto…

192.168.1.67 por ejemplo…

🗨️ 1
Nixie

De acuerdo. Prueba también 192.168.0.67

Algunos routers usan el rango 192.168.1.x y otros 192.168.0.x

De DNS puedes poner 8.8.8.8 y 8.8.4.4

Metro Copito
1

Puede ser interferencia de algún dispositivo conectado por USB 3.

🗨️ 4
Richipalomino101

Puedo probar, el único elemento conectado por USB, es un receptor unify de Logitech, para utilizar el teclado y ratón inalámbrico, y lo utilizo desde el día uno… Pero por probarlo…

🗨️ 3
Metro Copito

Libere usted la conexión USB 3 y reinicie la PC. Yo estoy en que debe ser eso (es más común de lo que parece).

🗨️ 2
Richipalomino101

Lo pruebo esta tarde y comento, pero recordar que si reseteo de fábrica el router, durante 6-7min si me funciona correctamente internet en el PC. Después de corta.

🗨️ 1
Superpuntual
0

Señores : es un problema de Windows 11.

Tengo un MacBook Pro de 2010.

Instalado macOS y Windows 11.

En macOS funciona perfectamente . En Windows 11 NO .

Me pasa igual que el compañero . El Wifi falla en Windows 11, y es algo de Windows con determinados router .

Lo sé porque el Wifi en Windows 11 solo me falla con el LiveBox 6 de Orange .

El mismo router , bajo macOS funciona .

🗨️ 15
Richipalomino101

No se qué decirte…

Probaré está tarde con un wifi externo por USB para ver si funciona o no.

🗨️ 2
umek

Revisa que tienes los últimos drivers de la tarjeta wifi instalados sobre todo si tu portatil tiene algo de tiempo ( busca en la web del fabricante del adaptador ) . Que Windows detecte el dispositivo no quiere decir que sea capaz de hacerlo funcionar correctamente con el driver genérico.

🗨️ 1
Richipalomino101

Es un fijo nuevo del diciembre 2021, no creo que sea el problema.

PezDeRedes

A ver que nos entendamos:

Instalas un sistema operativo de nueva generación (contando versiones Insider no llega a un año) en un ordenador con 12 años, las cosas no funcionan bien y la culpa es del sistema operativo. No sé se reír o llorar con lo que se puede llegar a leer.

¡¡¡Yo quiero que mi Pentium III que tengo por ahí me corra Windows 11 y el Cyberpunk, pero no lo corre porque es que Windows 11 es una basura!!!

🗨️ 11
Metro Copito

La obsesión de estar a la última moda.

🗨️ 4
PezDeRedes

Estar a la última en software, porque a nivel de hardware ese Mac es basura pura, eso hoy en día da para navegar con no mucho abierto y para de contar.

🗨️ 3
Superpuntual
-2
🗨️ 2
Josh
1
lhacc

Una cosa es que vaya lento, y otra distinta que no conecte al wifi.

🗨️ 5
PezDeRedes

Windows no va a tener un driver en condiciones para esta tarjeta de red.

🗨️ 4
lhacc
🗨️ 3
lhacc
🗨️ 1
Richipalomino101

Buenas tardes foro, he probado a utilizar un wifi que tengo desde hace muchos años, con entrada por USB, y con ese si que funciona correctamente el wifi, en cuanto pongo el interno, se me va la conexión… que creéis que puede ser…

Pruebo lo de la ip4? seguramente sea un controlador?

Muchas gracias.

🗨️ 10
Metro Copito

Prueba a hacer tethering desde el móvil, para descartar posibles incompatibilidades. Si tampoco lo pilla, cabe la posibilidad de una avería física en el módulo wifi.

¿Has probado lo que te comenté, de liberar el puerto USB 3?

🗨️ 5
Richipalomino101

Desconozco que es tethering, puedes explicarmelo. No creo que se haya dañado el módulo wifi, sin tocarlo, ya que es interno y pertenece a una placa base, tampoco a recibido golpes, y con mi red wifi del móvil funciona…

Concretamente esta es mi placa base, ASRock B550M-ITX/AC.

El driver en cuestión es este el que aparece en mi ordenador intel dual band wireless-ac 3168.

Gracias.

🗨️ 4
Metro Copito

El tethering es la conexión del móvil y por lo que comentas, ya has comprobado que funciona adecuadamente.

También comentas que has probado entre los distintos protocolos de frecuencias del router, con idéntico resultado. Así que no se me ocurre nada más.

Bueno sí, ejecuta alguna distro Linux en modo live y si desaparece el problema, a formatear.

🗨️ 3
pikiki1979
1

Bueno, veo que al menos has podido probar con otro adaptador como te indiqué, eso acota el cerco.

Con todas las pruebas ahora parece claro que el problema radica alrededor del adaptador interno, por el motivo que sea, con la relación que tiene con Windows 11 o con el router. Pero funciona bien con el tethering de tu móvil, por lo que entiendo que no es defectuoso.

¿Tiene sentido que sea una incompatibilidad del router con Windows 11 si el USB antiguo ha funcionado bien? No sé.

Indicas que has desinstalado el controlador WI-FI. ¿Cómo se reinstaló después? Si no lo hiciste de la siguiente manera, puedes probar esto:

  1. Desinstalar el controlador WI-FI.
  2. FORZAR a que instale el controlador oficial del fabricante (no que lo gestione Windows 11):

asrock.com/mb/AMD/B550M-ITXac/index.es.asp#Download

(revisa que sea la placa exacta, te enlazo esto porque es lo que has indicado tú).

Suerte.

PD. Estoy intrigado.

🗨️ 3
Richipalomino101

He conseguido solucionarlo con este comando que he visto en internet, aunque ayer también lo probé, junto con otros muchos y no funcionaba…

cmd netsh int IP reset c:resetlog.txt

Aun así me lo apunto, por si me vuelve a fallar, instalo directamente desde el fabricante.

Muchas gracias!

🗨️ 2
Richipalomino101

Decir que en el fabricante de mi placa, solo salen windows 10, desconozco si también valdrán para windows 11. Un saludo y muchisimas gracias.

🗨️ 1
Richipalomino101
1

Parece que se ha solucionado, llevo 20 minutos y de momento va bien, he utilizado el comando en cmd netsh int IP reset c:resetlog.txt