BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

A vueltas con Drivers SATA en instalacion de XP... Todas las soluciones probadas.

Rikkjaard

Hola, llevo dos días intentando instalar los drivers Serial ATA de un disco duro para poder instalar Windows XP en un PC nuevo. Los componentes son:

Gráfica EAH3850/G/HTDI (ATI Radeon HD3850)

Athlon64 X2 5600+ (2x 2900 MHz)

Disquetera (Disquetera 34 pines)

Fuente StealthXStream 600W (600 vatios)

Caja LeXa Redline (4 x 5,25" externas)

Grabadora LG GH-22LP20 (22 / 8 / 16)

Placa Base MSI K9A2 Platinum (AMD 790FX)

Disco duro ST3500320AS (500,0 GB)

DIMM kit 4 GB DDR2-800 (4096 MB)

He intentado instalar varios XP SP2, alguno con SP3 integrado e incluso una version que hay por ahí llamada XP Total (que es la única que me ha reconocido el HD, pero luego, al arrancar, se cuelga). Con todos los SO he probado instalar los drivers SATA de MSI, he probado tanto los de la web como los que vienen en el CD de instalación; me he hecho el diskette 7 veces, pero después del F6/ S no me lo lee, y he probado con varios. He probado también creando un XP con nlite, incluyendo los drivers y nada, cuando llega el momendo de elegir la partición de instalación no me reconoce el disco. He trasteado con la bios todo lo del mundo mundial, y sí me reconoce el disco duro, así que no le encuentro explicación ninguna. Incluso he vuelto a instalar la disquetera, pero está bien conectada y es nueva, no le encuentro explicación.

No sé qué mas puedo hacer, no quiero instalar Vista...

Me voy a la calle a poner una vela por ahí a un santo, y a comprar un juego nuevo de disketes. Si en un rato se os ocurre algo decídmelo, por favor. Llevo un día y medio con esto y me va a dar algo.

Gracias mil... :(

campi

He integrado drivers sata con nlite muchas veces y siempre me ha ido perfecto.. a mi me da que o no los integras bien o te equivocas de drivers.

Siempre tienes la opcion de activar la emulación ide en la placa.. asi el disco sera como un ide y no como un sata y xp no tendrá problemas.

🗨️ 1
Rikkjaard

Pues despues de integrar SP3, en la siguiente pantalla me pide los controladores, le doy a examinar, y dentro de la carpeta correspondiente a los drivers para XP selecciono el único archivo que aparece en pantalla, y luego creo la imagen y eso. Es la 1ª vez con nlite y no sé dónde está el problema.

Y si activo la emulación ide en la placa creo que tampoco me lo reconoce. en "On Chip Ata devices" están las opciones PCI IDE Busmaster(enabled), ON Chip SATA controller (enabled) y RAID mode, este último le he probado con las opciones RAID y AHCI, y nada.

Ahora sí que me voy a por los disquetes, en 5 minutos estoy por aqui. Puedo hacerlo mejor con nlite? ¿Hay algún driver genérico para SATA? Estoy utilizando unos que se llaman ULI, entiendo que son los que corresponden, son los que están en el CD.

Gracias Campi

Frankie2004

Hola Hobbito,

La K9A2 Platinum tiene 2 controladoras SATA-II. Los puertos 1 a 4 (¿violetas?) están gestionados por el chipset AMD SB600, y los puertos 5 y 6 (¿rojos?) están controlados por una Promise T3, que no soporta unidades ópticas, solo discos duros.

El disquete del AMD está en global.msi.com.tw/index.php?func=driverf…dno=2475&i=0 debes descomprimirlo y pasar los contenidos del directorio "RAID" (no el directorio en sí) a la raíz del disquete. Tal vez ese sea el fallo, porque el fichero "TXTSETUP.OEM" debe estar en la raíz y las rutas apuntan a la raíz, sin mención alguna de la existencia de un directorio "RAID".

El disquete de la Promise está en global.msi.com.tw/index.php?func=driverf…dno=6266&i=0 y lo mismo, solo debes pasar al disquete los contenidos del directorio "FastTrack\Driver" (no el directorio en sí) a la raíz del disquete.

🗨️ 14
Rikkjaard

Con el mismo driver Promise he probado y la instalacion me repite una y otra vez que inserte de nuevo el disquette. No sé si no lo lee bien o es que no lo reconoce.

Acabo de venir de comprar una caja de disquetes de Imation. Voy a hacer los dos y a ver si se instalan, aunque me interesa solo el primero, ya que el disco lo tengo en el primer serial ATA que como bien dices son violetas, y luego están los otros dos de color rojo.

Voy a ello y os cuento. Si no me los lee, cambiaré la disquetera, es lo único que me me mosquea algo, aunque ya digo que la he revisado y parece estar bien.

Rikkjaard

No me reconoce el disquete? La luz de la disquetera se enciende, pero no oigo ni siento al poner la mano, ningún movimiento mecánico.

🗨️ 12
Frankie2004

Pero anteriormente sí habías podido copiar los ficheros, ¿no?

¿Has tocado algo del cableado? ¿La luz no estará todo el rato encendida sin apagarse?

🗨️ 11
Rikkjaard

Los discos los estoy creando en otro PC y los paso al nuevo para instalar los drivers. Cuando le doy a enter para que lea A:, se enciende la luz de la disketera pero algunas veces parece que encaja el disco, y otras no se le oye nada. Voy a meter los drivers que me has comentado connlite, no sé si el procedimiento que os he comentado es el adecuado. Es que ponerme a cambiar la disketera me da una pereza tremenda...

Hartito estoy. Gracias Frankie.

🗨️ 10
Frankie2004
🗨️ 9
Rikkjaard
🗨️ 8
campi
Rikkjaard
🗨️ 5
Rikkjaard
🗨️ 4
vukits
Frankie2004
🗨️ 1