Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Versión prelanzamiento de la app Noticias bandaancha.eu

djnacho
2

Muy buenas. Acabo de subir a la Play Store la que probablemente será la última versión beta de la app Noticias bandaancha.eu. La manera de probarla es instalar la versión que aparece en la Play Store (1.0.355) y después Unirse al programa beta de la aplicación (aparece un poco más abajo en la ficha de la app instalada). Su número de versión es v2.0.306.08102020.PR-1 y estos son los cambios respecto a su predecesora:

  • Se ha corregido el parser XML para que la descripción de la noticia fuera completamente correcta.
  • Se han cambiado las fuentes de la App. Los titulares se muestran en un naranja oscuro y la descripción en negro.
  • Se ha eliminado el cacheo del navegador interno incorporado en la app para ver las noticias.
  • Se ha añadido a petición de @vukits el botón de refresco de la página actualmente mostrada en el navegador interno.
  • Se ha añadido un mensaje de salida de la aplicación cuando el usuario pulsa el botón atrás de Android mientras está en la página principal de noticias de la app.
  • Corrección de errores menores en el código.

Y por supuesto, aquí tenéis unas capturas de pantalla de la app ya funcionando:

screenshot-20201008-193408-bandaancha-1.webpscreenshot-20201008-193453-bandaancha-1.webpscreenshot-20201008-193435-bandaancha-1.webpscreenshot-20201008-193820-trebuchet-1.webpscreenshot-20201008-193907-trebuchet-1.webpscreenshot-20201008-193923-trebuchet-1.webp

Espero que os guste, y sea útil. Dejaré este hilo unos días para ver si hay algún fallo que no haya visto y luego la subiré como actualización de la versión inicial que ya existe en la Play Store.

Ari

¿Entiendo que está optimizada solo para smartphone y no para tablets?¿O el dispositivo móvil es indiferente?

Lo pregunto porque en el móvil me va bien, en principio, pero en la tablet no me pasa de la pantalla de inicio.

Saludos y gracias por tu trabajo :)

🗨️ 7
djnacho

El dispositivo móvil es indiferente, pero con los cambios introducidos en las nuevas reglas de actualización de apps de Google, el nivel de API inferior es el 23 (se corresponde con Android 6.0). Eso quiere decir, que todos los dispositivos con Android 6.0 o inferior no van a poder ejecutar la aplicación (aquí está la obsolescencia de Google…, es posible ejecutar la app en Android 5 por ejemplo, pero a partir del 2 de noviembre Google va a decir que no).

🗨️ 6
Ari

La versión de Android en la tablet es la 10. Es una Samsung Galaxy Tab A.

De hecho he tenido que reiniciarla después de instalar la app, porque se me ha colgado.

Saludos

🗨️ 5
djnacho
captura-play-store-2.webp

Pues la app es compatible con la tablet. Ahí me quedo un poco colgado porque no se que puede pasar. No es la primera vez que los dispositivos de Samsung dan problemas con alguna app. Miraré un poco a ver si veo algo, pero vamos, todo es estándar así que debería funcionar.

🗨️ 4
Ari
Ari
PANQUEMAO
1
🗨️ 1