BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra FTTH

Reemplazar Huawei HG8240H por Ubiquiti Nano G en NEBA Jazztel

EmuAGR
1

He estado el domingo intentando configurar una ONT Ubiquiti Nano G que he pillado rebajada. No consigo que me dé internet. Parto de una conexión NEBA de Jazztel con una ONT Huawei HG8240H y router neutro funcionando.

Yo pensaba que la OLT sería Huawei vista la ONT, pero ahora no estoy seguro, si es Alcachufa voy listo. He actualizado el firmware (v4.2.1), elegido el perfil 2 (Huawei), escrito la IDONT f2017xxxxxxxxx (la Nano G añade 5 ceros detrás para rellenar, he probado a ponerlos delante). En principio no funcionaba, así que he probado a modificar el Serial Number con esta herramienta: github.com/melisska/ufiber_nano_serial_hack

El SN consiste en 48575443xxxxxxxx (HWTC en ASCII+hex), que ha podido clonar correctamente. Con la misma herramienta he puesto la MAC que reportaba el Huawei 48:7b:6b:xx:xx:xx a ver si fuera eso y tampoco. El LOID a veces lo borro y se rellena solo, no sé si da igual.

imagen.webpimagen.webpimagen.webp

Lo que veo en la pantalla física es que la Nano G detecta la señal PON y el icono de Internet aparece verde pero parpadea (con el perfil 4 ZTE no parpadea, pero tampoco parece conectar). Adjunto log parcial por si dice algo importante:

Log

<4>START GPON SerDes Init script
<4> !!! PLL locked !!! RX CDR locked !!! TX CDR locked !!! GPON BEN Calibration Done
<4>GPON SerDes Initialization Sequence Done
<2>eth0 Link UP 1000 Mbps full duplex 1000000000 Mbps 1 duplex
<6>ADDRCONF(NETDEV_CHANGE): eth0.0: link becomes ready
<6>br0: port 1(eth0.0) entered forwarding state
<6>br0: port 1(eth0.0) entered forwarding state
<4>LOGGER driver Init Done : 0x84304700
<4>enable IH WAN-WAN forwarding…
<4>Creating CPU ring for queue number 6 with 32 packets descriptor=0xc042bba0
<4> Done initializing Ring 6 Base=0xa4a53c80 End=0xa4a53e80 calculated entries= 32 RDD Base=0x04a53c80 descriptor=0xc042bba0
<4>dgasp: kerSysRegisterDyingGaspHandler: gpon0 registered
<4>Creating CPU ring for queue number 5 with 64 packets descriptor=0xc042bb78
<4> Done initializing Ring 5 Base=0xa4b8e080 End=0xa4b8e480 calculated entries= 64 RDD Base=0x04b8e080 descriptor=0xc042bb78
<4>[0;33;41m[ERROR ploamPort] get_gem_object_by_port_or_flow,1687: Failed to get GEM flow ID by GEM port: error -2
<4>[0m
<4>[0;33;41m[ERROR ploamPort] ploamIOCgetGemPortCfg,847: ploamIOCgetGemPortCfg: error -2
<4>[0m
<4>gpondef: MAC Address: 48:7B:6B:xx:xx:xx
<4>can't send sysb - no Tcont US cfg for gem (1)
<4>ERR: tcont_root_tm_get#2135: rdpa_tcont_get FAILED: tcont(1) rc(-6)
<4>ERR: rdpa_cmd_tm_ioctl#2583: dev_root_tm_get() failed: dev_type(2) dev_id(1) rc(35)
<4>ERR: rdpa_cmd_tm_ioctl#3209: rdpa_cmd_tm_ioctl() OUT: FAILED: cmd=0 tm(0) rc(0)
<4>ERR: tcont_root_tm_get#2135: rdpa_tcont_get FAILED: tcont(2) rc(-6)
<4>ERR: rdpa_cmd_tm_ioctl#2583: dev_root_tm_get() failed: dev_type(2) dev_id(2) rc(35)
<4>ERR: rdpa_cmd_tm_ioctl#3209: rdpa_cmd_tm_ioctl() OUT: FAILED: cmd=0 tm(0) rc(0)
<4>ERR: tcont_root_tm_get#2135: rdpa_tcont_get FAILED: tcont(3) rc(-6)
<4>ERR: rdpa_cmd_tm_ioctl#2583: dev_root_tm_get() failed: dev_type(2) dev_id(3) rc(35)
<4>ERR: rdpa_cmd_tm_ioctl#3209: rdpa_cmd_tm_ioctl() OUT: FAILED: cmd=0 tm(0) rc(0)
<4>can't send sysb - no Tcont US cfg for gem (1)
<4>[0;33;41m[ERROR ploamPort] get_gem_object_by_port_or_flow,1687: Failed to get GEM flow ID by GEM port: error -2
<4>[0m
<4>[0;33;41m[ERROR ploamPort] ploamIOCgetGemPortCfg,847: ploamIOCgetGemPortCfg: error -2
<4>[0m
<4>[0;33;41m[ERROR ploamPort] get_gem_object_by_port_or_flow,1687: Failed to get GEM flow ID by GEM port: error -2
<4>[0m
<4>[0;33;41m[ERROR ploamPort] ploamIOCgetGemPortCfg,847: ploamIOCgetGemPortCfg: error -2
<4>[0m
<4>[0;33;41m[ERROR ploamPort] get_gem_object_by_port_or_flow,1687: Failed to get GEM flow ID by GEM port: error -2
<4>[0m
<4>[0;33;41m[ERROR ploamPort] ploamIOCgetGemPortCfg,847: ploamIOCgetGemPortCfg: error -2
<4>[0m
<4>mcast_gem <1> added to if <gpondef>

Una prueba que se me ocurre es editar el SN en la ONT Huawei a ver si pierde la conexión, y así sé si está bloqueado por SN o no es necesario.

EDIT: He cambiado el SN de la ONT Huawei y sigue funcionando, la autenticación es sólo por IDONT entonces.

A ver si me podéis echar un cable para hacerla funcionar. Gracias.

EmuAGR

Según leo por ahí, la HG8240H parece funcionar con OLTs Alcatel y con todo lo que he probado con la Nano G y sigue sin funcionar, tiene pinta de que es eso. Vamos, que no me toca nunca la lotería del silicio y ahora tampoco me toca la lotería del GPON. orz

🗨️ 2
BocaDePez
BocaDePez

Si es una Huawei lo tienes jodido porque solo funciona bien con Equipos Huawei. Cosa de no seguir los tandares y añadir mierdas propietarias.

Si es una Nokia Te funcionará cualquiera sin problemas

🗨️ 1
rbetancor
1

Al contrario, mon-ami, las OLT Huawei se tragan practicamente cualquier modelo de ONT de cualquier frabricante.

Las OLT más japutas, son las Alcatel, que no solo son japutas, sino que son una soberana MIERDA de OLTs.

Aleck Trevelyan
2

Buenos dias compañero. Prueba el perfil 3, en mi caso tengo fibra con O2, y no se que modelo de OLT tendre en mi zona, pero he probado 4 ONTs distintas y todas me han funcionado. Entre ellas la HG8240H, una Nokia , alcatel, y por ultimo la ONT Ubiquiti Ufiber Loco. En mi caso con el perfil 2 no habia manera de Sincronizar y con el perfil 3 todo perfecto, asi que atacale con el perfil numero 3.

🗨️ 7
BocaDePez
BocaDePez

Porque tu OLT es Nokia.

EmuAGR

Pues voy a probar con el Perfil 3, que pensaba que no servía en operadores grandes. ¿Es suficiente cambiando el IDONT?

EDIT: ¡Funciona! No he tenido que tocar nada raro, había revertido la configuración de SN y MAC y dejado el IDONT con los ceros detrás. Pues nada, por si alguien del futuro lee esto, que sepa que hay que intentar probar todos los perfiles antes de rendirse. Muchas gracias, Aleck.

🗨️ 5
Aleck Trevelyan
1

Me alegro mucho de que te funcione, ademas entiendo muy bien tu situacion, por que quieres dejarlo todo bien configurado y es frustrante que no termine de funcionar.

Esa ONT es muy buena, de lo mejorcito, asi que disfrutala a tope!!!

daveric
1

Me encantan los finales felices… :)

🗨️ 1
EmuAGR

Y a mí, ver las cosas funcionando exactamente como uno quiere es muy satisfactorio. 😀

Juanmana

Buenas

que es el perfil 3, no lo encuentro?

yo tengo la ONT 8240h y no hay manera de q me vaya fijo en o2

saludos

🗨️ 1
EmuAGR

Esto del "Perfil 3" es para la ONT Ubiquiti Nano G, no para la Huawei HG8240H. A la Huawei no hay que tocarle nada salvo la contraseña (IDONT) para conectarse a la red Movistar.

daveric

Yo ahora mismo te escirbo con una ONT igual a la que te esta dando problemas. Estoy bajo una conexion Vodafone NEBA.

No se si tendra que ver, por probar, pero yo no tengo los ultimos ceros que tu tienes. Tengo solo la f2020… en total 13 digitos tras la f.

A veces los ultimos ceros se los ponen para que la ONT deje validar al configuracion. A mi no me los añade, no puedo entrar ahora mismo, pero hace dos o tres dias entre y esoy convencido de que no me los ha añadido, tengo la misma version de firmw.

EmuAGR

Dejo otra pregunta por aquí: ¿Hay alguna manera fácil de acceder a la interfaz de configuración de la ONT desde detrás del router neutro? Conectando directamente a la IP de la ONT con un ordenador en la misma subred es fácil, pero me gustaría acceder a él sin tener que desmontar todo…

Es algo que probablemente podría averiguar con un par de horas de búsqueda intensiva, pero si alguien lo sabe de antemano me ahorraría bastante tiempo.

EDIT: Supongo que funcionaría configurando una WAN virtual alternativa con una IP estática en la subred de la ONT, sin VLAN y con bridge, lo cual no es posible en mi Netgear D7800. Con el ZTE H218N creo que sí es posible porque uso un método similar para hacerlo funcionar como ATA y switch sin NAT, pero pierdo prestaciones. Si tal más adelante cuando tenga tiempo lo pruebo.

pepejil

Pregunta desde la ignorancia: ¿Qué ventajas supone usar tu propio ONT?

🗨️ 9
EmuAGR

Que este tiene una pantalla con numericos y es más bonico, chiquitico y funciona con PoE, a diferencia del trasto de Huawei. Si no hay limitaciones de velocidad, ninguna diferencia, quizás dependiendo del modelo poder usar los puertos RJ11 para VoIP.

Me tiene que llegar un medidor de consumo, pretendo ver si hay ahorro eléctrico o tampoco.

🗨️ 8
pepejil

Lo digo por eso, porque creo que la operadora con sus ONTs de fábrica no limitan la calidad de servicio y desconocía qué otras funciones podría proveer la ONT.

Lo de poner el teléfono directamente en el RJ11 del ONT es una ventaja, al fin y al cabo puedes tener el router apagado para no tener Internet pero si el fijo.

🗨️ 7
EmuAGR

En Movistar/O2 puedes terminar la VLAN de voz en la ONT y ejecutar la aplicación SIP, a la vez que dar salida a la VLAN de datos hacia el router neutro.

Y bueno, según estuve investigando, poca gente ha podido aprovechar los RJ11 del HG8240H. Antes Movistar los provisionaba ahí, pero ahora si cambias cualquier cosa en la línea te los desactivan en la OLT y se desconfigura la ONT. Y con NEBA no tengo muy claro que funcionen porque la voz va en la misma VLAN que los datos, habría que hacer funcionar el Huawei como router con DMZ al segundo router y doble NAT o cosas raras.

Ahora mismo la voz la saco con un ZTE H218N que uso como ATA y switch gigabit de 5 puertos a la vez. Así puedo tener el teléfono fijo al lado del PC en vez de donde el router.

🗨️ 6
pepejil
Inacho
🗨️ 4
EmuAGR
BocaDePez
BocaDePez
🗨️ 2
Inacho
Inacho
Inacho

Me alegro que ya tengas solucionado el problemilla

Una pregunta:

El ONT Ubiquiti Nano G, se calienta mucho ?

Yo actualmente estoy utilizando una ONT Huawey HG8240H y que funciona sin problemas, pero calentita…, calentita.

Un saludo

🗨️ 2
EmuAGR

Al tacto está muy caliente sin llegar a quemar, más o menos similar a la Huawei, quizás un poco más porque es más compacta.

Aleck Trevelyan

La Ubiquiti Nano G tiene un consumo de 7,5w y si que se calienta (dentro de unos limites, nada alarmante), sobre todo si estamos en temperaturas por encima de los 22 grados. La ONT HG8240H anda tambien sobre 8W y por un lado se pone calentita. Despues tenemos la Ubiquiti Ufiber loco, que consume 3,5W y se calienta menos.

Personalmente compre la Ubiquiti modelo Loco por su bajo consumo. Aunque el modelo Nano G, es muy interesante por toda esa informacion que muestra en su pantalla , pero lo malo es que consume el doble y tiene esa conexion Poe que es un cacharro mas. Aun asi, cualquiera de las dos opciones es acertada.

Sobre las ventajas que comentabais de las Onts, Algunas parece que dan problemas de saturacion y en algunos casos, la compañia telefonica puede actualizar el firmware sin nosotros saberlo, y poner alguna version que funcione peor que antes.