BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Transferencia archivos windows 7 a saltos

djares01

Buenas,

Tengo un problema que he intentado buscar pero no veo a nadie con un caso similar al mio. Estoy copiando ficheros entre 2 pcs, ambos con windows 7 64 bits usando una conexion lan gigabit.

El problema es que cuando empiezo a copiar ficheros, el pc esta varios segundos copiando ficheros a 30mb/s y de golpe se pausa la transferencia, pasa un tiempo de 10 a 30segundos, y vuelve a enviar a 30mb/s y asi todo el rato. He probado a desactivar ahorro de energia, a activar tramas jumbo y a tocar todo lo que yo se, pero sigo sin determinar porque me pasa esto.

Decir que tambien tengo un mac con snow leopard y con el no me pasa ese problema, envia mas lento porque es un portatil, pero no se pausa nunca la transferencia, solo me pasa entre windows. El otro dia tambie lo probe con otro pc con windows 7 64 bits y me pasa lo mismo.

¿Alguien sabe que puede ser? mientras se estan enviando los archivos el disco duro trabaja a tope, pero luego se para por lo que no es un tema de consumo ni de recursos ni de HDD.

Un saludo

quilloquepasa

Utiliza un servicio FTP.

Saludos :wink:

🗨️ 1
djares01

Un FTP no es la solucion, yo lo que quiero es compartir archivos en red, no tener que montar un ftp que si quiero abrir un archivo me toca copiarlo en local.

BocaDePez
BocaDePez

Sí, a mí me ha pasado y el problema son los drivers Gigabit que mete el W7 de serie.

Me apuesto mi sueldo de este mes (cero, porque estoy desempleado) a que tienes una Realtek integrada en placa, ¿no?

Los drivers de la página oficial de Realtek son los buenos. ¡Mételos y verás qué cambio!

🗨️ 3
djares01

Me falla igual, de hecho creo que ya tenia los drivers de realtek puestos porque el instalador de realtek ya me habia detectado que tenia unos.

Decir que un pc si lleva placa realtek, y el otro una marvell yukon. Y despues de actualizar ambos, sigue igual, unos segundos enviando a buena velocidad, pero luego caida de velocidad y recuperacion al cabo de unos segundos.

🗨️ 2
BocaDePez
BocaDePez

¿Conexión directa con cable cruzado, o a través de un switch?

🗨️ 1
djares01

A traves de un router wifi dlink dir-825

BocaDePez
BocaDePez

¿Tienes antivirus?. Prueba a desintalarlo, y,después, utiliza la herramienta de limpieza de la página del fabricante del antivirus, para su completa desintalación.

Si tienes Kaspersky, o lo has tenido en algún momento instalado en ese equipo, no vale con desintalarlo, sino que será necesario formatear y reinstalar el SO, ya que es la única manera de eliminar los ADS incompeltos que crea en el File System, que dañan la transmisión de red.

No es seguro que haciendo esta prueba se solucione tu problema, pero...

Si el antivirus que tuvieras es el MSE, no hace falta que hagas esta prueba, porque MSE es el único que no puede causar este tipo de problemas.

🗨️ 4
BocaDePez
BocaDePez

Además de lo anterior, prueba a utilizar Robocopy para copiar los archivos. Abre el Símbolo del Sistema, escribe y ejecuta el comando siguiente:

Robocopy ruta_origen ruta_destino nombre_archivo

Para obtener más información acerca de cómo utilizar Robocopy, escribe Robocopy /? en un símbolo del sistema y, a continuación, presiona ENTRAR.

🗨️ 3
BocaDePez
BocaDePez

Después de haber probado lo anterior, tanto la desinstalación de antivirus, como el resultado del robocopy, si tampoco se corrigiera el problema en cuestión:

Desactiva la "red inteligente" de W7, para probar si el problema fuera causado por un router incorrecto o un firmware intermedio inválido, que impide a W7 negociar correctamente.

Para ello, arranca la consola en modo elevado (botón derecho Símbolo del Sistema> selecciona, Ejecutar como administrador), y ejecuta los dos comandos siguientes:

netsh interface tcp set global autotuninglevel=disabled

netsh interface tcp set global rss=disabled

Si, desactivando la negociación del tamaño de ventana de W7, se corrigiera el problema de lentitud de transferencia de archivos, lo bueno es que ya sabrías quién origina el problema, pero lo malo es que en tu red hay algún componente hardware malo (router y/o firmware intermedio), que no clumple las RFC.

En cualquier caso, lo que puedes estar seguro es de que el problema no esta en W7, sino en algún componente hardware/software, que impide a W7 hacer su trabajo correctamente.

🗨️ 2
djares01

Pues despues de probar el robocopy (con el cual iba igual con las desconexiones) he probado a desactivar las ventanas del tcp con los comandos que me has comentado y funciona!

He estado mirando, y tiene su parte de logica que por algun motivo o el windows (o segun tu el router) cierra la ventana de la conexion cuando sobrepasas ciertos umbrales. Voy a mirar a ver si en la configuracion del router tengo algun QoS que me afecte a la lan, porque el dlink que tengo trae muchas opciones.

Probare a ir activando y desactivando opciones, porque supongo que tampoco interesa desactivar estas funciones del windows. Ademas me interesa poder transmitir al maximo que me permita la red, ahora mismo se me queda la conexion a 200mbps y he llegado a ver transferencias a veces de 500 y 600mbps.

Muchas gracias.

🗨️ 1
BocaDePez
BocaDePez