Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Bugs/Devel

? Soporte completo para emojis Unicode en BandaAncha.EU ??

Josh
1

Como estaba prometido, la web ya soporta el conjunto completo de emojis Unicode, dejando atrás el sistema de códigos que utilizábamos hasta ahora. ?

Aunque el picker de emoticonos del editor sigue mostrando los mismos que antes, ahora en versión Unicode, cualquier carácter emoji Unicode soportado por nuestro sistema operativo se visualizará en la web, inclusos los nuevos 72 emojis de Unicode 9.0 cuando estén disponibles. Para ello hay que utilizar el teclado de emojis ? o copiar y pegar desde otra fuente.

Además, los emojis no solo aparecen en el cuerpo de mensajes y noticias, si no en títulos, firmas de usuarios, etc. Esto abre la puerta a nuevos abusos ?, para los que tendremos que añadir nuevas comprobaciones al enviar a medida que molesten (cómo permitir máximo un emoticono en el título). Es probable que también haga acto de presencia algún bug ?.

BocaDePez
BocaDePez

Enorme :) BA un paso siempre por delante

BocaDePez
BocaDePez

Cualquier usuario normal solo ve los mismos que ya había antes pero muchisimo más feos.

Como los cambios se queden así me parece una absurdez, casi un paso atrás.

BocaDePez
BocaDePez

En Windows da pena verlos.

🗨️ 11
BocaDePez
BocaDePez

Ya te digo, en Linux se ven en blanco y negro pero son chulos, en windows son feos de cojones y casi ni se distingue lo que son.

Josh
1

Pues si, son feos de cojones. Probablemente hagamos una sustitución por javascript en el navegador para mostrar los antiguos en windows.

🗨️ 9
BocaDePez
BocaDePez

Y eso que tengo Windows 10. Seguramente en 7 sólo se vean cuadraditos.

🗨️ 1
BocaDePez
BocaDePez

Efectivamente

yomimmo

Usando Oddyssey en otros SO se ven exactamente como en W7, feos del copón.

NetSpot

Depende mucho de la fuente que se tenga instalada y que cubra los caracteres de los emojis en particular. Por eso a algunos se le ven cuadros y otros los ven feos de mal parir.

?

EDIT: me ha borrado lo que he escrito despúes del emoji dichoso al enviar.

Bueno, decía que por eso Twitter los convierte a imágenes y la paliza que os váis a dar, para que se vean bonitos, no sé si compensa.

🗨️ 5
Josh

No, he trasteado esta mañana con una regexp que sustituye codepoints por el emoji en SVG y parece una buena solución ?

🗨️ 4
NetSpot
🗨️ 3
Josh
🗨️ 2
WiLZy
-1
NetSpot
BocaDePez
BocaDePez

Otro problema, en W7 solo se ven cuadraditos

🗨️ 9
BocaDePez
BocaDePez

Windows 7 salió hace ya más de seis años, es hora de actualizarse.

🗨️ 3
BocaDePez
BocaDePez

El ABS se inventó hace unos 30 años. No lo uses, es muy antiguo.

🗨️ 2
BocaDePez
BocaDePez

Vas a comparar la sofisticación de los ABS de entonces con los de ahora.

Pues igual con el Windows.

🗨️ 1
BocaDePez
BocaDePez
mceds

En Firefox/Opera/Chrome/Chromium para Linux, también aparece algún cuadradito (entre "emojis" y "o").

🗨️ 2
mceds

Thanks. Sospechaba que algo habría de eso.

yomimmo

Seguro que tienes algo mal configurado en tu W7.

En el mío se ve así:

Imagen original en http://denpere.com/emojis.png

Cutres, porque son cutres, pero se ven todos, nada de cuadritos. IE11 y Chrome

🗨️ 1
BocaDePez
BocaDePez

Es un w7 instalado en un vmware sin prácticamente nada instalado y con firefox.

A no ser que hayan metido algún parche que lo corrija y que no tenga instalado no hay nada extraño.

BocaDePez
BocaDePez

¿cuando pondreis que las respuestas se ordenen por orden cronologico?

superllo

?

No paella no rules.

🗨️ 3
superllo
-1

Sí paella sí party. En Linux hay que instalar el soporte para el unicode 9.

Para Ubuntu hay un PPA, aquí las instrucciones en general.

Spyd

Windows 10 compilación 14372 soporta la paella de forma nativa.

🗨️ 1
superllo

Me imagino que ahora que ya ha salido como estándar las distribuciones irán poniendo el juego de caracteres por defecto en sus instalaciones.

Filiprino

??

🗨️ 1
BocaDePez
BocaDePez

??