BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Sonido: Realtek ALC1200 en Debian Squeeze

AMSTRAD

Buenas:

Tengo una Realtek ALC1200 en Debian Squeeze (netinstall para instalar sólo lo necesario), que me la detecta y de hecho funciona, pero el problema es que el volumen es muy pero que muy bajo.

Aun probando con alsamixer a subir el volumen al máximo, sigue siendo muy bajo, hasta el punto que si quiero escuchar un video de youtube por ejemplo, tengo que subir el volumen de los altavoces al máximo y rezar porque no haya mas ruido.

Si veo un video con el vlc, tengo que subir el volumen del vlc al 200% para escuchar a un volumen un poco normal.

¿alguna idea de como leches lo arreglo? Gracias.

Worked

Asi a bote pronto... puedes pastear el alsa-base.conf ?

🗨️ 19
AMSTRAD

Esto es lo que lleva:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

🗨️ 18
BocaDePez
BocaDePez

¿Sabes usar bien el alsamixer? Para ver todos los controles dale a la teclas de edición (cursor keys), las teclas con las flechas para el desplazamiento lateral, y mira si tienes demasiado bajo el control PCM.

🗨️ 13
AMSTRAD

PCM lo tengo al 100%, y sí, sé desplazarme por alsamixer.

Un saludo.

🗨️ 12
BocaDePez
BocaDePez
🗨️ 11
AMSTRAD
🗨️ 10
BocaDePez
BocaDePez
🗨️ 9
BocaDePez
BocaDePez
AMSTRAD
🗨️ 7
BocaDePez
BocaDePez
🗨️ 6
AMSTRAD
🗨️ 5
BocaDePez
BocaDePez
🗨️ 4
AMSTRAD
🗨️ 3
BocaDePez
BocaDePez
🗨️ 2
BocaDePez
BocaDePez
Worked

Prueba una cosa, como root:

rmmod snd_hda_intel

modprobe snd_hda_intel

Por aquí han tenido problemas similares con tu placa ubuntuforums.org/showthread.php?t=881363&page=2 (Lo mismo que puede valer para ubuntu, debería valerte a ti)

🗨️ 3
AMSTRAD

root@debian:/home/miguel# rmmod snd_hda_intel
ERROR: Module snd_hda_intel is in use
root@debian:/home/miguel# modprobe snd_hda_intel

Esto es lo que me sale y no noto diferencia.

He probado ha añadir la linea que me has dicho más abajo en el alsa-base.conf y parece que ha mejorado algo.

🗨️ 2
Worked
BocaDePez
BocaDePez
BocaDePez
BocaDePez

Si arrancas con un Live CD de otra distribución, ¿los problemas se mantienen?

🗨️ 1
AMSTRAD

Cuando tenía Ubuntu 10.10 no tenía este problema.

BocaDePez
BocaDePez

Prueba añadiendo esta línea en alsa-base.conf y reiniciando alsa:

options snd-hda-intel model=6stack-dig probe_mask=1

🗨️ 1
Worked
1

Reiniciar alsa con el comando "alsa force-reload" y asegurate que no muestra un error diciendo que los modulos continuan cargados (sale en el unload)

vukits

Hazlo a machete..

Configura un pre-amp por software .. p.e. así

🗨️ 1
BocaDePez
BocaDePez
-1

WINDOSERO

BocaDePez
BocaDePez
1

Parecerá una tontería pero, ¿estás subiendo el volumen del hardware correspondiente? En Alsamixer, pulsa F6 y selecciona la tarjeta requerida. En este caso recuerda hacerlo como root para que te cargue los niveles en el siguiente reinicio del sistema. En caso contrario comprueba /etc/asound.state o las otras recomendaciones que te dieron anteriormente.

🗨️ 4
BocaDePez
BocaDePez
-1

¿Quién es el cipote que se dedica a votar los mensajes?

🗨️ 3
BocaDePez
BocaDePez

What did you mean with 'votar'?

🗨️ 2
superllo

Touch the triángulos that are on the derecha, one verde and other rojo.

🗨️ 1
BocaDePez
BocaDePez
pcmaster

Si los controles de volumen de Alsamixer son correctos, comprueba los de Pulseaudio.

En mi netbook (Un Asus eee) el micrófono casi no captaba sonido, un volumen mínimo, solución (un tanto curiosa) fue bajar al mínimo el segundo canal del micrófono de pulseaudio (el micro es mono, sólo tiene un canal).

A ver si en tu caso va a ser algo parecido...