Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
678 lecturas y 12 respuestas
  • 12

    Sincro OpenWRT en Dlink DSL-g624t

    he instalado el ultimo kamikaze, ya que backfire me parece demasiado nuevo.

    voy a hacer un hotspot y tal ( ya que el driver sólo soporta WEP) .. por el momento os dejo unas estadisticas :D

    dem Stats]
    US Connection Rate: 2308 DS Connection Rate: 5773
    DS Line Attenuation: 37 DS Margin: 9
    US Line Attenuation: 23 US Margin: 7
    US Payload : 3304224 DS Payload: 7908816
    US Superframe Cnt : 23668 DS Superframe Cnt: 23668
    US Transmit Power : 15 DS Transmit Power: 18
    LOS errors: 0 SEF errors: 0
    Errored Seconds: 0 Severely Err Secs: 0
    Frame mode: 0 Max Frame mode: 0
    Trained Path: 1 US Peak Cell Rate: 5443
    Trained Mode: 1024 Selected Mode: 1024
    ATUC Vendor Code: 4244434D ATUC Revision: 2
    Hybrid Selected: 2 Trellis: 1
    Showtime Count: 1 DS Max Attainable Bit Rate: 5956 kbps
    BitSwap: 1 US Max Attainable Bit Rate: 2308000 bps
    Annex: AnxM psd_mask_qualifier: 0x0020
    Power Management Status: L0 DS HLINSC: 0
    US ACTPSD: -345 DS ACTPSD: -367
    Total init. errors: 0 Total init. timeouts: 0
    Showtime init. errors: 0 Showtime init. timeouts: 0
    Last showtime init. errors: 0 Last showtime init. timeouts: 0
    ATUC ghsVid: b5 00 42 44 43 4d 93 d3
    T1413Vid: 00 00 T1413Rev: 00 VendorRev: 00
    ATUR ghsVid: b5 00 54 53 54 43 00 00
    T1413Vid: 00 00 T1413Rev: 00 VendorRev: 00

    [Upstream (TX) Interleave path]
    CRC: 0 FEC: 0 NCD: 0
    LCD: 0 HEC: 0

    [Downstream (RX) Interleave path]
    CRC: 0 FEC: 497 NCD: 0
    LCD: 0 HEC: 0

    [Upstream (TX) Fast path]
    CRC: 0 FEC: 0 NCD: 0
    LCD: 0 HEC: 0

    [Downstream (RX) Fast path]
    CRC: 0 FEC: 0 NCD: 0
    LCD: 0 HEC: 0

    [ATM Stats]
    [Upstream/TX]
    Good Cell Cnt: 68838
    Idle Cell Cnt: 2121887

    Tx Packets Dropped Count: 0
    Tx Bad Packets Count: 2

    [Downstream/RX)]
    Good Cell Cnt: 164767
    Idle Cell Cnt: 5314283
    Bad Hec Cell Cnt: 0
    Overflow Dropped Cell Cnt: 0
    Rx Packets Dropped Count: 0
    Rx Bad Packets Count: 0

    [SAR AAL5 Stats]
    Tx PDU's: 6190
    Rx PDU's: 7142
    Tx Total Bytes: 3181768
    Rx Total Bytes: 7796973
    Tx Total Error Counts: 0
    Rx Total Error Counts: 0

    [OAM Stats]
    Near End F5 Loop Back Count: 0
    Near End F4 Loop Back Count: 0
    Far End F5 Loop Back Count: 0
    Far End F4 Loop Back Count: 0
    SAR OAM Ping Response Drop Count=0
    Este tema lleva más de 6 meses inactivo. Es recomendable que abras un nuevo tema para retomar la conversación.
    1
    • Bueno, al final sí monté un hotspot.. bastante simplón,…

      Bueno, al final sí monté un hotspot.. bastante simplón, basado en nodogsplash, ante la falta de espacio para instalar freeradius.

      para flashearlo, hay que hacerlo desde winbugs, ya que hay problemas raros con ftp.

      hay que tener conexión de adsl y tenerla configurada (i.e. al enchufar el cable ethernet al router, que se pueda navegar), saber de GNU/Linux y saber manejar vi .

      ya que al día siguiente tuve que dar de baja el ADSL (otra vez), no he tenido tiempo para confirmar si el QoS o las funciones avanzadas funcionan. (hombre.. nodogsplash lleva magnificos scripts de iptable .. vete tú a saber)

      de hecho, la cosa está muy, muy verde..

      por lo menos con configuración básica da un rendimiento Wan-to-Lan axcelente.

      1º, instalamos OpenWRT Backfire asi

      2º, accedemos por cable

      3º, editamos /etc/confg/wireless

      y nos aseguramos de que tenga esta pinta (en vez de OpenWRT, ponemos el SSID que deseemos tener.. y elegimos canal, claro)

      config wifi-device  wlan0
      option type acx
      option channel 5

      # REMOVE THIS LINE TO ENABLE WIFI:
      # option disabled 1

      config wifi-iface
      option device wlan0
      option network wifi
      option mode ap
      option ssid OpenWrt
      option encryption none

      editamos /etc/config/network .. a fin de añadir este bloque

      config interface wifi
      option type bridge
      option ifname wlan0
      option proto static
      option ipaddr 192.168.2.1
      option netmask 255.255.255.0
      option nat 1

      i.e. .... mi fichero network tendría esta pinta(lo pongo por consistencia.. el vuestro no debe ser igualito): (la config. adsl es para jazztel)

      # Copyright (C) 2006 OpenWrt.org

      config interface loopback
      option ifname lo
      option proto static
      option ipaddr 127.0.0.1
      option netmask 255.0.0.0

      config interface lan
      option type bridge
      option ifname eth0
      option proto static
      option ipaddr 192.168.1.1
      option netmask 255.255.255.0
      option nat 1

      config interface wifi
      option type bridge
      option ifname wlan0
      option proto static
      option ipaddr 192.168.2.1
      option netmask 255.255.255.0
      option nat 1

      ## Example for ATM bridging.
      ## Useful for PPPoE or IP over ATM. Will create 'nas${unit}'
      #
      config atm-bridge
      # option unit 0
      option encaps llc
      option vpi 8
      option vci 35
      # option payload bridged # some ISPs need this set to 'routed'

      config interface wan
      ## PPPoE:
      option ifname nas0
      option proto pppoe

      ## PPPoA:
      # option ifname atm0
      # option proto pppoa
      # option encaps llc
      # option vpi 8
      # option vci 35

      ## Both:
      option username "my_username"
      option password "my_password"

      4º, reiniciamos el router (con reboot basta)

      5º instalamos los paquetes

      según este post, hay que instalar unos cuantos módulos adicionales

      opkg update
      opkg install ip
      opkg install iptables-mod-extra
      opkg install iptables-mod-imq
      opkg install iptables-mod-ipopt
      opkg install kmod-ipt-extra
      opkg install kmod-sched
      opkg install tc
      opkg install nodogsplash

      6º, editamos /etc/nodogsplash/nodogsplash.conf según las instrucciones

      el mío tiene esta pinta .. (muy muy básico... no tengo configurado ni QoS ... de hecho, con poner, o cambiar esto vamos apañados)

      GatewayInterface br-wifi

      fichero de configuración muy poco editado

      #
      # Nodogsplash Configuration File
      #

      # Parameter: GatewayInterface
      # Default: NONE
      #
      # GatewayInterface is not autodetected, has no default, and must be set here.
      # Set GatewayInterface to the interface on your router
      # that is to be managed by Nodogsplash.
      # Typically br-lan for the wired and wireless lan on OpenWrt White Russian.
      # May be br-lan on OpenWrt Kamikaze.
      #
      GatewayInterface br-wifi

      # FirewallRuleSet: authenticated-users
      #
      # Control access for users after authentication.
      # These rules are inserted at the beginning of the
      # FORWARD chain of the router's filter table, and
      # apply to packets that have come in to the router
      # over the GatewayInterface from MAC addresses that
      # have authenticated with Nodogsplash, and that are
      # destined to be routed through the router. The rules are
      # considered in order, and the first rule that matches
      # a packet applies to it.
      # If there are any rules in this ruleset, an authenticated
      # packet that does not match any rule is rejected.
      # N.B.: This ruleset is completely independent of
      # the preauthenticated-users ruleset.
      #
      FirewallRuleSet authenticated-users {

      # You may want to open access to a machine on a local
      # subnet that is otherwise blocked (for example, to
      # serve a redirect page; see RedirectURL). If so,
      # allow that explicitly here, e.g:
      # FirewallRule allow tcp port 80 to 192.168.254.254

      # Your router may have several interfaces, and you
      # probably want to keep them private from the GatewayInterface.
      # If so, you should block the entire subnets on those interfaces, e.g.:
      FirewallRule block to 192.168.1.0/16
      FirewallRule block to 10.0.0.0/8

      # Typical ports you will probably want to open up include
      # 53 udp and tcp for DNS,
      # 80 for http,
      # 443 for https,
      # 22 for ssh:
      FirewallRule allow tcp port 53
      FirewallRule allow udp port 53
      FirewallRule allow tcp port 80
      FirewallRule allow tcp port 443
      FirewallRule allow tcp port 22

      }
      # end FirewallRuleSet authenticated-users

      # FirewallRuleSet: preauthenticated-users
      #
      # Control access for users before authentication.
      # These rules are inserted in the PREROUTING chain
      # of the router's nat table, and in the
      # FORWARD chain of the router's filter table.
      # These rules apply to packets that have come in to the
      # router over the GatewayInterface from MAC addresses that
      # are not on the BlockedMACList or TrustedMACList,
      # are *not* authenticated with Nodogsplash. The rules are
      # considered in order, and the first rule that matches
      # a packet applies to it. A packet that does not match
      # any rule here is rejected.
      # N.B.: This ruleset is completely independent of
      # the authenticated-users and users-to-router rulesets.
      #
      FirewallRuleSet preauthenticated-users {
      # For preauthenticated users to resolve IP addresses in their initial
      # request not using the router itself as a DNS server,
      # you probably want to allow port 53 udp and tcp for DNS.
      FirewallRule allow tcp port 53
      FirewallRule allow udp port 53
      # For splash page content not hosted on the router, you
      # will want to allow port 80 tcp to the remote host here.
      # Doing so circumvents the usual capture and redirect of
      # any port 80 request to this remote host.
      # Note that the remote host's numerical IP address must be known
      # and used here.
      # FirewallRule allow tcp port 80 to 123.321.123.321
      }
      # end FirewallRuleSet preauthenticated-users

      # FirewallRuleSet: users-to-router
      #
      # Control access to the router itself from the GatewayInterface.
      # These rules are inserted at the beginning of the
      # INPUT chain of the router's filter table, and
      # apply to packets that have come in to the router
      # over the GatewayInterface from MAC addresses that
      # are not on the TrustedMACList, and are destined for
      # the router itself. The rules are
      # considered in order, and the first rule that matches
      # a packet applies to it.
      # If there are any rules in this ruleset, a
      # packet that does not match any rule is rejected.
      #
      FirewallRuleSet users-to-router {
      # Nodogsplash automatically allows tcp to GatewayPort,
      # at GatewayAddress, to serve the splash page.
      # However you may want to open up other ports, e.g.
      # 53 for DNS and 67 for DHCP if the router itself is
      # providing these services.
      FirewallRule allow udp port 53
      FirewallRule allow tcp port 53
      FirewallRule allow udp port 67
      # You may want to allow ssh, http, and https to the router
      # for administration from the GatewayInterface. If not,
      # comment these out.
      FirewallRule allow tcp port 22
      # FirewallRule allow tcp port 80
      # FirewallRule allow tcp port 443
      }
      # end FirewallRuleSet users-to-router

      # EmptyRuleSetPolicy directives
      # The FirewallRuleSets that NoDogSplash permits are:
      #
      # authenticated-users
      # preauthenticated-users
      # users-to-router
      # trusted-users
      # trusted-users-to-router
      #
      # For each of these, an EmptyRuleSetPolicy can be specified.
      # An EmptyRuleSet policy applies to a FirewallRuleSet if the
      # FirewallRuleSet is missing from this configuration file,
      # or if it exists but contains no FirewallRules.
      #
      # The possible values of an EmptyRuleSetPolicy are:
      # allow -- packets are accepted
      # block -- packets are rejected
      # passthrough -- packets are passed through to pre-existing firewall rules
      #
      # Default EmptyRuleSetPolicies are set as follows:
      # EmptyRuleSetPolicy authenticated-users passthrough
      # EmptyRuleSetPolicy preauthenticated-users block
      # EmptyRuleSetPolicy users-to-router block
      # EmptyRuleSetPolicy trusted-users allow
      # EmptyRuleSetPolicy trusted-users-to-router allow

      # Parameter: GatewayName
      # Default: NoDogSplash
      #
      # Set GatewayName to the name of your gateway. This value
      # will be available as variable $gatewayname in the splash page source
      # and in status output from ndsctl, but otherwise doesn't matter.
      # If none is supplied, the value "NoDogSplash" is used.
      #
      # GatewayName NoDogSplash

      # Parameter: GatewayAddress
      # Default: Discovered from GatewayInterface
      #
      # This should be autodetected on an OpenWRT system, but if not:
      # Set GatewayAddress to the IP address of the router on
      # the GatewayInterface. This is the address that the Nodogsplash
      # server listens on.
      #
      # GatewayAddress 192.168.1.1

      # Parameter: ExternalInterface
      # Default: Autodetected from /proc/net/route
      #
      # This should be autodetected on a OpenWRT system, but if not:
      # Set ExtrnalInterface to the 'external' interface on your router,
      # i.e. the one which provides the default route to the internet.
      # Typically vlan1 for OpenWRT.
      #
      # ExternalInterface vlan1

      # Parameter: RedirectURL
      # Default: none
      #
      # After authentication, normally a user is redirected
      # to their initially requested page.
      # If RedirectURL is set, the user is redirected to this URL instead.
      #
      # RedirectURL www.ilesansfil.org/

      # Parameter: GatewayPort
      # Default: 2050
      #
      # Nodogsplash's own http server uses GatewayAddress as its IP address.
      # The port it listens to at that IP can be set here; default is 2050.
      #
      # GatewayPort 2050

      # Parameter: MaxClients
      # Default: 20
      #
      # Set MaxClients to the maximum number of users allowed to
      # connect at any time. (Does not include users on the TrustedMACList,
      # who do not authenticate.)
      #
      # MaxClients 20

      # ClientIdleTimeout
      # Parameter: ClientIdleTimeout
      # Default: 10
      #
      # Set ClientIdleTimeout to the desired of number of minutes
      # of inactivity before a user is automatically 'deauthenticated'.
      #
      # ClientIdleTimeout 10

      # Parameter: ClientForceTimeout
      # Default: 360
      #
      # Set ClientForceTimeout to the desired number of minutes before
      # a user is automatically 'deauthenticated', whether active or not
      #
      # ClientForceTimeout 360

      # Parameter: AuthenticateImmediately
      # Default: no
      #
      # Set to yes (or true or 1), to immediately authenticate users
      # who make a http port 80 request on the GatewayInterface (that is,
      # do not serve a splash page, just redirect to the user's request,
      # or to RedirectURL if set).
      #
      # AuthenticateImmediately no

      # Parameter: MACMechanism
      # Default: block
      #
      # Either block or allow.
      # If 'block', MAC addresses on BlockedMACList are blocked from
      # authenticating, and all others are allowed.
      # If 'allow', MAC addresses on AllowedMACList are allowed to
      # authenticate, and all other (non-trusted) MAC's are blocked.
      #
      # MACMechanism block

      # Parameter: BlockedMACList
      # Default: none
      #
      # Comma-separated list of MAC addresses who will be completely blocked
      # from the GatewayInterface. Ignored if MACMechanism is allow.
      # N.B.: weak security, since MAC addresses are easy to spoof.
      #
      # BlockedMACList 00:00:DE:AD:BE:EF,00:00:C0:1D:F0:0D

      # Parameter: AllowedMACList
      # Default: none
      #
      # Comma-separated list of MAC addresses who will not be completely
      # blocked from the GatewayInterface. Ignored if MACMechanism is block.
      # N.B.: weak security, since MAC addresses are easy to spoof.
      #
      # AllowedMACList 00:00:12:34:56:78

      # Parameter: TrustedMACList
      # Default: none
      #
      # Comma-separated list of MAC addresses who are not subject to
      # authentication, and are not restricted by any FirewallRuleSet.
      # N.B.: weak security, since MAC addresses are easy to spoof.
      #
      # TrustedMACList 00:00:CA:FE:BA:BE, 00:00:C0:01:D0:0D

      # Parameter: PasswordAuthentication
      # Default: no
      # Set to yes (or true or 1), to require a password matching
      # the Password parameter to be supplied when authenticating.
      #
      #
      # PasswordAuthentication no

      # Parameter: Password
      # Default: none
      # Whitespace delimited string that is compared to user-supplied
      # password when authenticating.
      #
      #
      # Password nodog

      # Parameter: UsernameAuthentication
      # Default: no
      # Set to yes (or true or 1), to require a username matching
      # the Username parameter to be supplied when authenticating.
      #
      #
      # UsernameAuthentication no

      # Parameter: Username
      # Default: none
      # Whitespace delimited string that is compared to user-supplied
      # username when authenticating.
      #
      #
      # Username guest

      # Parameter: PasswordAttempts
      # Default: 5
      # Integer number of failed password/username entries before
      # a user is forced to reauthenticate.
      #
      #
      # PasswordAttempts 5

      # Parameter: TrafficControl
      # Default: no
      #
      # Set to yes (or true or 1), to enable traffic control in Nodogsplash.
      #
      # TrafficControl no

      # Parameter: DownloadLimit
      # Default: 0
      #
      # If TrafficControl is enabled, this sets the maximum download
      # speed to the GatewayInterface, in kilobits per second.
      # For example if you have an ADSL connection with 768 kbit
      # download speed, and you want to allow about half of that
      # bandwidth for the GatewayInterface, set this to 384.
      # A value of 0 means no download limiting is done.
      #
      # DownloadLimit 384

      # Parameter: UploadLimit
      # Default: 0
      #
      # If TrafficControl is enabled, this sets the maximum upload
      # speed from the GatewayInterface, in kilobits per second.
      # For example if you have an ADSL connection with 128 kbit
      # upload speed, and you want to allow about half of that
      # bandwidth for the GatewayInterface, set this to 64.
      # A value of 0 means no upload limiting is done.
      #
      # UploadLimit 64

      # Paramter: GatewayIPRange
      # Default: 0.0.0.0/0
      #
      # By setting this parameter, you can specify a range of IP addresses
      # on the GatewayInterface that will be responded to and managed by
      # Nodogsplash. Addresses outside this range do not have their packets
      # touched by Nodogsplash at all.
      # Defaults to 0.0.0.0/0, that is, all addresses.
      #
      # GatewayIPRange 0.0.0.0/0

      6º, inciiamos nodogsplash, a ver cómo funciona

      /etc/init.d/nodogsplash start

      si logramos conectarnos por wifi .. i..e nos aparece el perrito, le damos clic y a los pocos segundos podemos navegar... pues dejamos habilitado el servicio y reinciamos

      /etc/init.d/nodogsplash enable
      reboot

      fin :D

      este tuto lo he hecho, porque casi todos se basan en router que soporten VLAN's ... y el switch Marvell de Dlink, como que no :P

      saludos

    • Interesante.....no hay ningun otro router que soporte…

      Interesante.....no hay ningun otro router que soporte openwrt? (lo digo por eso de forzar el snr a tu antojo y eso y que se guarde en los reinicios)

      PD Ari: Ya me va bien internet (y con el linksys puesto)............ :S, así sin mas, asique seguramente ya hayan actualizado mi central para vdsl, es lo mas probable, incluso creo que si cambio el perfil llego a 14 megas jajaja (10 casi 11 con fastpath)

      • 6

        OT on/ Me alegro, ya era hora :D ¿Has mirado en el tema sobre…

        OT on/ Me alegro, ya era hora :D

        ¿Has mirado en el tema sobre centrales vdsl2, el que tiene chincheta? Aunque no sé si van/vamos retrasados con la lista :-/ OT off/

        Saludos :)

        • Lo que estoy mirando es que al cambiar de perfil me han…

          Lo que estoy mirando es que al cambiar de perfil me han limitado el FastPath a 6 megas?????????????????????????????????????????????????????????????

          Es que ya me empiezo a cagar en dios y en su puta madre de jazztel

          Curiosa sincro de 6143kbps (antes de cambiar los perfiles soncronizaba a 10300kbps)

          Pero que puta broma es esta??

          • 6
            Tienes un perfil de 6 megas para el fastpath, por lo que…

            Tienes un perfil de 6 megas para el fastpath, por lo que parece :-/

            Si miras por el foro verás que hay gente que ha perdido sincro en fastpath. A algunos se les solucionó apagando y encendiendo el router. A otros les ha tardado. Y otros parece que aún no la han recuperado.

            Paciencia, intenta llamar a Jazztel y cuida ese lenguaje, que así no solucionas nada, ya lo sabes ;)

      • Es lo que obtengo con este par (con razón no me dejaron…

        Es lo que obtengo con este par (con razón no me dejaron contratar el VDSL :P ) .. en modo optimo son 7 u 8M :D .. fijate que el TI te da el máximo de subida a coste de perder 2 o 3M de download :D .

        cuando tenga el wifi configurado (el driver no es para tirar cohetes), lo pincharé al PTR..

        repito, que todavía no he acabado :D

        saludos

        PD: por cierto, habiendo cambiado a bootloader pspboot, desde linea de comandos no existe a /proc/ticfg ... i.e. la modulación hay que ajustarla desde ordenes en el bootloader ... así que...para comodones, hay que dejar el bootloader original adam2 tal como está .. (aunque pspboot es mejor)