Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Sin mensajes push de Whatsapp conectado con Digi

vukits

EDIT2:

aun cambiando de router, sigo teniendo los mismos problemas.

me veo obligado a cambiar de ISP, porque no vivo ahí y no tengo tiempo de depurar el problema

EDIT: una vez adquirida ip pública, el router ha empezado a congelarse... Digi me ha cambiado a un router más nuevo, a ver qué tal

EDIT2: los cabritos me han puesto el mismo módelo.... Me han forzado a irme de la compañía

Resulta que en casa de mi madre no llegan los mensajes push de Whatsapp.

Una vez abierto socket, ya funciona.

Sospecho jugareta de CGNAT ....

voy a pedir que me saquen.

un saludo

BocaDePez
BocaDePez
2

Android emite latidos cada 28 minutos para mantener la conexión abierta, pero algunas compañías móviles cierran la conexión antes de esos 28 minutos. De este modo no se reciben las notificaciones push.

Existen aplicaciones que aumentan la frecuencia de los latidos, para asegurarse de que la conexión no se cierra y se reciben bien las notificaciones, por ejemplo: Hearbeat fixer ( play.google.com/store/apps/details?id=io…tfixerforgcm ) . Te permite ajustar el periodo del latido.

Prueba a ver si te funciona. Hay otras aplicaciones parecidas, puedes buscar en Google Play por " push notification fixer "

Saludos.

🗨️ 7
pepejil

Android emite latidos cada 28 minutos para mantener la conexión abierta, pero algunas compañías móviles cierran la conexión antes de esos 28 minutos. De este modo no se reciben las notificaciones push.

Los routers HFC de Lowi cierran la conexión a los 10 minutos de estar inactivos y en ningún momento he tenido problemas con las notificaciones. Por otro lado, la mayoria de CG-NAT de las redes móviles también liberan conexiones mucho antes de esos 28 minutos y tampoco hay quejas masivas.

El problema puede estar entre como está compilado ese Android, los accesos a Google Play y también cuando está "dormido" a través de una red Wi-Fi.

🗨️ 6
BocaDePez
BocaDePez

Para completar lo que dije antes, Google Firebase Messaging suele emitir los latidos cada 28 minutos en el caso de que la conexión a Internet sea vía red móvil, y cada 15 minutos en caso de que la conexión a Internet sea via red WiFi. Esto se puede monitorizar, o se puede comprobar el historial de eventos.

Si dije todo lo de antes, es porque yo he tenido ese problema en varias compañías de móvil y se me ha arreglado con los programas que sugerí ante, reduciendo el periodo del latido (en mi caso 5 minutos fue bien, aunque cambia de una compañía a otra)

En algún caso también sucede que si Android está configurado en modo ahorro de energía, a veces también se pueden perder notificaciones push en algunos teléfonos.

Si lo que he comentado le sirve de ayuda a alguien bien, y a quien no le sirva, también :-)

Saludos.

🗨️ 5
BocaDePez
BocaDePez

Algo que me fue de bastante ayuda, fue monitorizar el historial de eventos de Google Play Services, para verificar cada cuanto tiempo se cerraba la conexión y cada cuanto tiempo se enviaban los latidos.

BocaDePez
BocaDePez

Hola, interesante. A mi me pasa pero no le di mas importancia al tema. El caso que yo uso LineageOS desconectado de Google totalmente, por lo tanto no tengo nada de la google playa service ni ostias. Se puede hacer algo?, manipulando android por terminal?, alguna idea?.

Un saludo e interesante tema.

🗨️ 3
BocaDePez
BocaDePez
1
BocaDePez
BocaDePez
1
🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez
1

Que curioso. A mí me pasaba igual con un Pixel pero con iPhone no me ocurre. La verdad es que nunca supe muy bien a quién culpar.

La verdad es que 28 minutos (como indica el forero de aquí arriba) es un pasote, no me extraña que no te "cuelgue" antes el ISP.

🗨️ 1
vukits

con un Xiaomi pasa

BocaDePez
BocaDePez
1

Si el móvil es Android prueba Ajustes>Wi-Fi >Ajuntes avanzados(los 3 puntos de arriba a la derecha)>Usar Wi-Fi en suspensión>Y marcar “Siempre” .

vukits

EDIT: una vez adquirida ip pública, el router ha empezado a congelarse... Digi me ha cambiado a un router más nuevo, a ver qué tal

🗨️ 3
BocaDePez
BocaDePez

Qué bueno. Voy a recomendar Digi a todo el mundo.

BocaDePez
BocaDePez

Que router tenías?

🗨️ 1
vukits

tenía el primero, blanco sin antenas..

No iba mal, hasta que un día empezó a ir mal.. (pedi que actualizaran firmware, pero creo que ya lo hacen automaticamente, o no lo hacen en absoluto)

BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
vukits

aun camiando de router, sigo teniendo los mismos problemas.

me veo obligado a cambiar de ISP, porque no vivo ahí y no tengo tiempo de depurar el problema