Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra/Cable

Servidor FTP con ONO128

BocaDePez
BocaDePez

Hola, mi cuestion es sencilla.

Queremos montar un servidor de FTP en un ordenador enganchado a ONO 128K. Hemos instalado el server:
ARGOSOFT FTP Server 1.4.0.1. Lo hemos probado desde el propio ordenador haciendo ftp sobre la propia direccion IP del ordenador en internet, desde otro ordenador conectado con una tarjeta de red y un RJ45 cruzado... y funciona perfectamente.

El problema es q no conseguimos conectarnos al servidor desde ningun otro ordenador externo. Lo hemos probado tanto desde ordenadores conectados tambien a ONO, como a telefono. Nada de nada, no se conecta.

De hecho no sale absolutamente nada en el log del Server.

Hemos probado haciendo funcionar el server en puerto 21, y otros superiores e inferiores al 1024. Lo hemos probado sin firewalls ni antivirus. Nada de nada.

Otro compañero lo ha probado desde una conexion ONO300 y le pasa exactamente lo mismo. Desde su propio ordenador, o uno en su LAN de casa: perfecto. Desde fuera nada de nada.

Alguien sabe donde esta el problema?. Q coño estamos haciendo mal?.

P.D. Perdonad si estamos preguntando una jilipollez, pero creo q ya hemos dejado claro q no tenemos ni puñetera idea, verdad?. :-?

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
NetVicious

En un 128 lo tendrás que montar por encima del 1023, en un 300 no tendrías que tener ningún problema.

Cuando lo teniais montado por encima del 1023 probasteis a acceder desde local para ver si el server estaba ahí.

Tambien tienes que controlar el tema de firewalls, el que lleva el XP de serie tambien.

🗨️ 9
BocaDePez
BocaDePez

El tema de firewalls lo descartamos, xq simplemente los quitamos todos. Lo hemos tenido funcionando sobre WIN98SE. Q yo sepa, ese windows no tienen ninguna movida
de firewall propio, no?.

Respecto de los puertos. Lo hemos probado en dos. Lo prrobamos en el puerto 21, pero como nos dijeros q los puertos del 0 al 1024 estan capados en ONO128, lo volvimos a poner en el 1313. Pero no funciono en ninguno de los dos casos. ¿?

Podria ser problema del servidor de FTP?. Pero si funciona desde el propio ordenador, y desde otro de la LAN de casa; xq no va a funcionar desde uno externo en internet???.

O esto es dificil, o soy tonto. ¿? :-(

🗨️ 8
NetVicious

Win98SE no tiene firewall no.

ONO filtra del puerto 0 al 1023 para ser exactos ;)

En el 1313 debería funcionar tanto en la red local como desde fuera, cuando lo pusistes en el 1313 lo probastes en local.

Desde fuera daba algún tipo de error ? Se quedaba colgado al intentar la conexión pasiva o algo de eso?

🗨️ 1
BocaDePez
BocaDePez

Con puertos superiores e inferiores al 1024, lo hemos probado tanto en local desde el propio ordenador, como desde otro conectado a la LAN y funcionaba Ok. Pero desde fuera nada de nada.

Cuando nos intentamos conectar desde fuera, el explorer dice q no se puede conectar. Los clientes de FTP dicen cada uno algo distinto; pero en definitiva; q no se puede conectar y blablabla.

En cualquier caso el ordenador desde el q se intenta acceder no se bloquea, solo dice q no se puede. ( como si no hubiera ningun servidor de FTP en la IP especificada¿?¿? ). El ordenador q tiene el server no registra ni siquiera el intento de acceso en los logs.... y os juro q la IP esta bien puesta.

Hemos hecho pings a la IP del servidor de FTP y esto funciona bien. ( a lo mejor es una tonteria, pero por si acaso lo hemos hecho ).

:-?

alchemy

Lo que puede pasar es que te FTP este configurado solo para escuchar por la tarjeta de red de tu lan y no por la que esta conectada al CM...

como no especificas como tienes configurada la red de tu casa no te puedo decir mas, pero esto es una posibilidad.

Sino prueba con otros servidores de FTP mas simples a ver que pasa. y a modo de consejo te recomiendo que no9 pongas un w98 como servidor de ftp, se va a colgar cada 2x3, no esta preparado para ser servidor de nada ( casi ni de cliente de nada.... ;) )

🗨️ 5
BocaDePez
BocaDePez

Te comento:

La ultima prueba la hemos hecho en el ordenador de un colega q tiene ONO300 en WINME. Solo tiene el ordenador conectado al modem con una unica tarjeta de red. Y aunque parezca mentira ( no no me pongo colorado ).... no le funciona tampoco; ni x encima del 1024 ni x debajo.

De todos modos, el servidor de FTP no funciona para todas las tarjetas de red q tengas instaladas?. Nosotros en casa, cuando lo probabamos en la LAN, lo haciamos a la IP: 192.168.0.1. Desde el propio ordenador lo haciamos a ambas: la de la LAN y la de internet. Y desde fuera solo a la de internet. Todas funcionaban OK, excepto la ultima.

Voy a probar lo del server, xq es lo unico q me queda por probar...., pero es q seria la ostia q funcione en local, y no desde fuera, no????.

Perdonad si suelto alguna parida a lo bestia, q de esto no entiendo mucho y me da la impresion de q me meto demasiado deprisa. Asi pues vaya mi ignorancia reconocida por delante.

Gracias por la ayuda tios.

🗨️ 4
Cesalv
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
Ealonso

No te voy a desvelar nada nuevo, pues todo se ha dicho en post anteriores, pero por hacer un resumen y si te aclaro algo pues me alegro:

- En ONO128, efectivamente los puertos estan cerrados por ONO hasta el 1024, es decir poniendo cualquier puerto por encima de este en el servidor de FTP, deberia funcionar sin problemas.

- Yo tengo conex. con ONO y el server de FTP funciona bien, solo me dio una pega cuando tenia dos ordenadores conectados en red, uno con dos tarjetas una para el modem cable y la otra para la red, y active la conex. compartida de internet, entonces nadie podia conectar con el FTP, pero eso con winroute, sysgate o cualquier otra cosa lo solucionas.

- En definitiva, no conozco ese servidor de Argosoft, yo de Argosoft tengo el de correo, he utilizado el G6 y el Serv-U, y con ellos no he tenido ningun problema, solamente que los clientes han de activar el PASV mode, pero por lo demas pa dentro a chupar del bote sin pegas.

Una cosa si te aconsejaria, si quieres como sabes que ONO a veces cambia la IP, puedes ponerte un redireccionador tipo xxxx.dns2go.com, para no tener que estar dando a la peña la ip y que ataquen siempre aunque la cambien.

Bueno un saludo y si necesitas algo pa eso tamos.

🗨️ 4
carner

Buenas mi problema es exactamente el mismo, o por lo menos muy similar:tengo conexión a 128 k y me resulta imposible realizar ftp desde internet,tb he probado varios puertos y todo eso pero nada de nada,desde red local sin ningun problema.
mi configuracion es la siguiente:
- 2 equipos: un xp y un 98Se,el primero es el que tiene conectado el CM motorola sb4200 por USB y en este equipo esta instalado el winroute,ambos equipos estan conectados entre si por un hub 100 y tarjetas de red 3com.

tengo dos dudas (entre otras mil):
la primera es que os he oido hablar de que se pueden realizar reglas en el winroute para redireccionar los puertos pero no tengo ni idea de como se hace y l otra duda es que como desactivo el firewire que trae el xp.
espero que me deis alguna solucion valida y gracias de antemano :-)

NetVicious

Exacto exacto es del 0 al 1023, es decir el 1024 se puede usar ;)

🗨️ 2
carner

a mi sigue sin funcionarme... podeis darme mas ideas ¡¡¡
gracias. En red interna si que funciona, he probado con mas puertos y nada. :-( .

🗨️ 1
yomimmo

El winroute no lo he usado pero creo que tu caso concreto deriva de el debes ajustar los parametros de nat.
Decirle que makina de la red debe responder a las peticiones que se hagan al puerto usado para ftp.
En tu caso concreto si por ejemplo tienes el ftp en el port 1313 puedes decirle que las peticiones al port 1313 te las redireccione al port 21 de la ip 192.168.100.x, siendo esta la mkina en la que tienes el servidor de ftp.

Otra cosa, al tener el winroute debes conectarte desde fuera en modo pasivo.