BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Servidor DHCP del HGU MitraStar con O2 no asigna IP

25aVela97

Tengo en mi casa la siguiente configuración que paso a detallar (lo que no nombro, esta tal y como está cuando se resetea a estado de fabrica):

  • Router principal (HGU MitraStar GPT-2541GNAC): nombre y contraseña wifi cambiado, wifi plus (5G) desactivada pero con band steering activado, para que en una misma valla el 2.4 y 5G, IP de este router en 192.168.1.1 y contraseña acceso a router cambiada.
  • Router secundario (HGU MitraStar GPT-2541GNAC): nombre y contraseña wifi cambiado, wifi plus (5G) desactivada pero con band steering activado, para que en una misma valla el 2.4 y 5G, IP de este router en 192.168.1.2, DHCP desactivado y contraseña acceso a router cambiada

El router principal es el que recibe la fibra desde la calle, mientras que el router secundario está conectado al router principal mediante cable ethernet, para poder usar este último como punto de acceso, para poder tener internet en toda la casa (casa muy grande, el wifi solo llega a menos de la mitad de la casa). Si no estoy confundido el que da la IP es el router principal, aunque el dispositivo se conecte al router secundario

La duda es la siguiente: cada x tiempo, más o menos unos 5 días, los router dejan de conectar tanto por wifi como por cable, pone "esperando asignación de IP", además del teléfono fijo que no funciona, cosa que solo se soluciona si apago y vuelvo a encender el router principal, y vuelve a suceder lo mismo más o menos pasado el tiempo que indico anteriormente.

Siendo la pregunta: hay algo mal en la configuración de alguno de los dos routers que he dicho anteriormente para que pase esto.

Información extra: tanto el router principal como secundario, tienen el mismo nombre y clave de acceso wifi, los únicos dispositivos que se conectan, son dos móviles por wifi, un PC solo por cable, y otro PC algunas veces por cable y otras veces por wifi

vukits

no entiendo por qué no les programas un reinicio cada dos días (o diario), p.e., de madrugada

🗨️ 3
25aVela97

En primer lugar gracias por responder, lo primero porque no se me había ocurrido, en segundo lugar, no se como se hace, he estado mirando por internet y creo que no se puede desde la configuración del router, y tercero, porque creo que eso solo sería un parche, algo temporal, pero no encontraría lo que origina el problema para que suceda lo que cuento.

🗨️ 2
vukits

no se como se hace

  1. Compra un par de temporizadores electrónicos, que te permite ajustar el minuto y el día de la semana en la que quieres reiniciar (en mi caso, tengo programado un reinicio todos los días de madrugada a las 4:00 , excepto Sabado y Domingo)

pero no encontraría lo que origina el problema

por supuesto, si puedes sacrificar decenas de horas depurando logs de Wireshark y de Syslog. Yo personalmente, no tengo este tiempo, y en mi caso le puse a mi router una solución que aunque es un parche es definitiva.

un saludo

PD: antiguamente, con el firmware DD-WRT , se programaba un watchdog interno que en cuanto veía que un punto de acceso había perdido conectividad, se reiniciaba.

🗨️ 1
25aVela97

Exacto, tiene toda la razón del mundo, claro yo pensaba de si había algo propio en el software del router, pero no, y no es cosa lo de estar horas viendo los logs, gracias igualmente por su ayuda.

Black Hole

Disculpa, pero ¿no son ambos routers de fibra? ¿es que tienes 2 líneas de fibra? No llego a entender por qué llamas a uno primario y al otro secundario, que da a entender que depende del primero.

🗨️ 8
25aVela97

Exacto son dos routers de fibra, pero el principal, es el que recibe la fibra de la calle, mientras que el secundario se conecta con el principal mediante ethernet para poder usarlo como punto de acceso. Voy a modificarlo en el post para que quede más claro

🗨️ 7
Black Hole

Gracias por la aclaración. Entiendo que los dispositivos por WiFi encuentran el servidor DHCP del router principal para obtener IP aunque se conecten a la WiFi del secundario.

En ese caso hasta cierto punto es lógico que si se cuelga completamente el primer router, no proporcione ni IPs ni salida a Internet a los dispositivos. Queda confirmar si el secundario ve al primario (por ejemplo desde un PC con IP fija que tengas enchufado al secundario, puedes entrar en el secundario pero no en el primario). Por tu explicación presupongo que solo se va el primario. Si se van hasta los teléfonos, tiene la pinta que se ha colgado todo el aparato y no solamente algunos de sus servicios. Tal vez por algún fallo de firmware, por saturación de sus tablas NAT, o hasta por un bajón de corriente…

Si tienes PCs conectados las 24h, desde alguno de ellos quizás podrías programar una tarea para reiniciar el router primario, bien a través de web o de SSH, no conozco el aparato.

🗨️ 6
25aVela97

Si eso es lo que pienso, que se va el principal, lo que comprobar cuando se va si desde el secundario se ve el principal, no lo he probado ninguna de las veces que me ha pasado, tendré que hacer lo de reiniciarlo aunque sea manualmente, yo he puesto es post por si había algo raro en las pocas configuraciones que tengo en los dos routers, por si había algo mal que hiciera saltar las alarmas a gente que seguramente tenga más conocimientos que yo en estos temas.

Muchas gracias por responder y por su ayuda

🗨️ 5
25aVela97
🗨️ 3
urbex
1

En el HGU secundario, ponle el idONT que extraigas del HGU que te instaló O2 (el principal), como te han dicho los compañeros. Luego una vez puesto el idONT, apagalo y conectale el latiguillo de fibra, enciendolo y dejale que cargue la configuración automática. Cuando este configurado, hazle un reset de fábrica, pulsando unos segundos el botón reset que esta en la parte de detrás del router. Para que se actualice el fimware a la última versión.

Una vez hecho esto, vuelve a poner el HGU principal en su sitio, conecta el HGU secundario por cable de red al puerto 1 Ethernet, desactiva DHCP y ponle una IP estática de un rango alto como el 192.168.1.254, para que no haya conflictos de IP's con en el servidor DHCP del HGU principal. También en el HGU principal, asignale la IP fija del HGU secundario, para que cuando DHCP del HGU principal detecte la MAC del HGU secundario, le reserve siempre esa IP, y no se la asigne a otros dispositivos, aunque usando un IP de valor alto es improbable, pero por si acaso. Desactiva también en el secundario, todas las opciones de enrutamiento, como: NAT, UPnP y el firewall.

En los HGU la verdad, es que funcionar como punto de acceso, no es su mayor fuerte. Yo tengo un Askey RTF3505VW, que me encontré en un punto limpio, y nunca he sido capaz de hacerlo funcionar como AP, ya que el HGU tiene band steering, que por simple comodidad, me interesaba. Y además que he leído, que solo uno de los modelos que hay de HGU MitraStar, permiten funcionar como AP, no sé si será cierto.

🗨️ 1
PercebesBenz
1

Es que yo no entiendo por que os torturáis con estos esquipos. Pillaos algo que pueda meterse OpenWrt hombre.

ciencia
1

Yo tengo un problema similar con el HGU, siendo una configuración "estándar" en la que solo tengo el router y ya está. Tengo mi PC conectado por ethernet, y el resto de dispositivos por Wi-Fi.

Observo lo que comentas, cada X días (puede ser aleatorio, al día siguiente o al cabo de 6 o de 20 días), el router deja de dar IP (el DHCP deja de funcionar).

Tras reiniciar el router varias veces, con la tocada de narices que eso supone (mi PC al estar conectado por ethernet le puse IP estática y así ya no se ve afectado por este problema), descubrí una cosa: Para "resolver" el problema (temporalmente, hasta que vuelva a pasar), basta con reiniciar solo el DHCP. Para ello, si entras al menú "Red Local", donde te pone DHCP y un desplegable ACTIVADO, cámbialo a DESACTIVADO. Guardas, y luego vuelves a cambiarlo a ACTIVADO, y guardas. Con eso, los dispositivos vuelven a recibir direcciones IP (si hace falta, los desconectas del wi-fi y los vuelves a conectar).

Aun así, de tantas veces que me pasa, he acabado por poner IP estática a todos mis dispositivos y a tomar por c…

Para mí está claro que es un problema del firmware del router. No sé por qué hace eso. Podría ser que se quedara sin direcciones IP para dar, pero me extraña porque todos los dispositivos los tengo registrados en el router con MAC para que les dé siempre la misma IP…

🗨️ 2
vukits

Para ello, si entras al menú "Red Local", donde te pone DHCP y un desplegable ACTIVADO, cámbialo a DESACTIVADO.

si haces un apagado eléctrico del router como he sugerido más arriba, eso no es necesario

🗨️ 1
ciencia
1

Ya lo sé. Lo doy como alternativa si no quieres apagar el router y volverlo a encender, o reiniciarlo. Como en mi caso, el PC tiene IP estática, si lo apago pierdo internet durante un par de minutos, y la IP pública asignada me cambia.