Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra/Cable

Servicio IP fija con cablemodem en modo bridge y router neutro detrás no funciona

Rmoreirac

Ayer contraté el servicio de IP fija de Vodafone. Tengo un cablemodem Technicolor TC7230 (STEB.80.44) puesto en modo bridge, con un Asus AX11000 detrás. Cuando me activaron el servicio ayer, la WAN tuvo un corte, pero la IP no me cambia, sigue siendo dinámica.

Ahora estoy haciendo pruebas (más tarde teletrabajo y no puedo andar enredando) y veo que si el cablemodem está en modo router (lo he reseteado a valores de fábrica) si coge la IP que Vodafone me ha asignado. Cuando vuelvo al modo bridge, el Asus coge otra IP diferente.

En WAN connection type lo tengo puesto en Automatic IP. Si fuerzo el modo manual, me pide máscara y gateway, y los de Vodafone no me lo dan. Si le meto yo lo que creo que es (un /24 y el gateway igual que la IP pero terminado en .1) no funciona.

He probado a meter la MAC del CM en la parte de clonado MAC en WAN (tanto la MAC CM como la MAC MTA), pero nada, asi no funciona ni coge IP dinámica.

Les he escrito ahora un Twitter a los de VF empresas, que normalmente me suelen solucionar los problemas mejor que cuando llamo.

Solo me queda que alguien me confirme que esto de la IP fija solo funciona con el CM de VF en modo router, y no en modo bridge, que es lo que me temo.

MasterL

En su momento yo lo usaba clonando la MAC

pero aun asi un par de veces en varios años tuve que reiniciar el router no pillaba la IP fija. la red de Vodafone me acabo asignando otra IP fija. me dijeron que el soporte oficial era con su router. como tu dices no puedes configurar la IP fija manualmente y por eso a veces tuve ese problemilla.

tienes que clonar la mac que viene en la caja del router en una pegatina.

pero si no funciona igual te toca probar otra operadora, ademas recuerdo que la empresa pagaba 10 euros al mes por la IP fija. no era barato precisamente para que vayan así de rigidos con su router. eran los tiempos de Ono y no habia otra cosa pero ahora pues hay mas oferta.

BocaDePez
BocaDePez
2

Buenos Días! La respuesta es sencilla, con esa configuración NO podrás.

El problema es el DHCP de VF. Si clonas la MAC del TC7230 en tu router, no te dará IP y si no lo haces, te dará una dinámica.

La única opción que tienes es, en el Asus, no clonar la MAC (Dejar la suya) y pedirles que, en su servidor DHCP cambien la asignación de tu IP a la MAC WAN del Asus. Nunca me ha puesto pegas, pero la verdad es que eso lo he hecho con empresas, no sé si será tan fácil con un contrato de particulares.

Saludetes!

🗨️ 1
Rmoreirac

Muchas gracias! Intentaré esto. Tengo contrato VF Empresas.

Un saludo!

rbetancor

¿Tenías el CM el bridge cuando te activaron el servicio o lo pusiste en bridge después?, porque de eso dependerá que MAC es la que tengan en el DHCP de VF asignada para darte la IP fija.

No puedes "clonar" la MAC del cacharro de VF en el Asus, porque el CM no dejará salir ese tráfico. Por lo menos a mí, dejaba de funcionarme si le ponía al neutro, la MAC WAN del CM.

En su momento, con Ono, me bastó con poner el CM en bridge y volver a pedir IP por DHCP, me la asignó y listo, pero es muy probable, que eso depende de la red HFC sobre la que estés colgado, ya se sabe, cada operador de HFC de los que integraban Ono, hacía las cosas "a su manera".

Tema a parte … ¿estás en una zona HFC donde la IP te cambie? … porque por lo menos en la zona HFC donde estaba yo, la IP no cambiaba ni a tiros … en 10 años, cambió 1 vez.

🗨️ 6
Rmoreirac

Tenía los 300Mb y al pedir el cambio a 1Gb me pusieron este CM. Me lo dejaron tal cual viene de fabrica, como router. Yo lo cambie a bridge, y asi funciona bien con el Asus detrás como neutro.

Al contratar el servicio de IP fija, el CM ya estaba en modo bridge, y tampoco cogia la IP que me habían asignado. Tan solo volviendo a modo router, cogió la IP.

En cuanto a la última pregunta, pues no me cambia mucho la IP, igual 1 o 2 veces al año.

🗨️ 5
rbetancor

En cuanto a la última pregunta, pues no me cambia mucho la IP, igual 1 o 2 veces al año.

Pues no tiene mucho sentido pagar por un servicio que no vas a necesitar … configurar un DDNS en el Asus y a correr millas. Para el par de veces al año que te va a cambiar, ni te enteras.

🗨️ 4
Rmoreirac

La idea es montar un servidor de correo y una web en un NAS que tenemos. Lo hice hace un par de años, pero un coñazo por el tema del DDNS.

🗨️ 3
pepejil
🗨️ 2
Rmoreirac
🗨️ 1
pepejil
BocaDePez
BocaDePez

Una cosa es la MAC de HFC y otra la de WAN.

En el caso de los TC7230 como numera las MAC es así

Ejemplo:

00:11:22:33:44:55 HFC < La que se activa en CMTS

00:11:22:33:44:56 MTA < Teléfono

00:11:22:33:44:57 WAN < Donde se provisiona la IP dinámica/fija

Entonces en el router debes modificar la MAC por la WAN, es a la que está asignada la IP fija, si cambias por una MAC cualquiera verás que cambias de IP a tu antojo.

De hecho en la pegatina del router deberias ver las diferentes MAC.

🗨️ 4
Rmoreirac

En la pegatina de la caja, como dices tengo solo 2 MAC:

  • CM MAC: XX:XX:XX:XX:XX:D0
  • MTA MAC: XX:XX:XX:XX:XX:D1

He probado a meter ambas en asus1.webp

Y no ha funcionado. Me sale el siguiente mensaje en el log del router: WAN Connection: ISP's DHCP did not function properly.

Si le quito la MAC:

Apr 8 06:33:10 WAN Connection: WAN was restored.

Apr 8 06:33:13 DHCP client: bound 2xx.xx.xx.xxx/255.255.255.0 via 2xx.xx.xx.x for 3600 seconds.

🗨️ 2
vukits

ISP's DHCP did not function properly.

esto es un bug del Asus… pasa con varios équipos.

¿Has probado la mac XX:XX:XX:XX:XX:D2?

🗨️ 1
Rmoreirac

Si, y nada :(

Y así desde la D0 hasta la D9. Con la D6 me ha dado otra IP del rango dinámico 82.x.x.x. LA 5 y la 7 son de la Wifi, y la 8,9 nada tampoco xD

Si es un bug, pues poco puedo hacer…

Rmoreirac

Lo que no he probado es, meter la MAC en el Asus, y después reiniciar el CM.

BocaDePez
BocaDePez

Entonces es la acabada en D2 la que debes indicar y después reset de router

🗨️ 1
Rmoreirac

Pues no ha habido suerte. He puesto la D2, reiniciado CM y reiniciado router y nada :(

vukits

Si fuerzo el modo manual, me pide máscara y gateway, y los de Vodafone no me lo dan. Si le meto yo lo que creo que es (un /24 y el gateway igual que la IP pero terminado en .1) no funciona.

¿Por qué no sacas dichos datos del cablerouter directamente?

🗨️ 8
Rmoreirac

Luego pego la captura, pero no aparecían, si mal no recuerdo.

Rmoreirac

Buenas:

Esto es lo que sale:

ip2.webp

Y si que he notado, que se abre esta regla de NAT sola cuando el CM está en modo router:

ip1.webp
🗨️ 6
vukits

ahí faltan un montón de datos (como sabrás)… falta MAC de la interfaz WAN, falta Mascara, Gateway, etc,etc.

Veo tres soluciones a esto:

*Resetear el Asus a ajustes de fábrica, y dar su MAC a Vodafone, para que te asignen ahí la IP estática por DHCP

*Pedir que te cambien el router por un Sagemcom F@ST 3686 , que es muchisimo más manejable y se pueden sacar varios datos de ahí

*Dar de baja la IP fija y empezar a usar DNS dinámica (DYNDNS ofrece registro MX para sus nombres de dominio, por lo que deberías poder mandar correos).

un saludo

🗨️ 5
Rmoreirac
1

Pues no ha habido suerte… probé a resetear de fabrica, nada. Le cargue el firm de Merlin, nada. Finalmente los de VF me dijeron que no pueden poner la MAC de un equipo ajeno a ellos en su router por cuestiones de seguridad.

Así que he pedido la baja de la IP fija, y miraré algo tipo DYNDNS.

Gracias a todos por la ayuda!!

🗨️ 4
telemako
🗨️ 1
AsmGuy
🗨️ 1
vukits