BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Router ZTE F680 no muestra menu VOIP (Alta en pepephone router aparentemente de masmovil)

yorelito

Hola,

Me acabo dar de alta en Pepephone, ya que no cobran cuota de línea, me han puesto un ZTE F680 (que diria yo que es de masmovil por la contraseña del interface web masmovil/masmovil).

Cuál ha sido mi sorpresa cuando el apartado VOIP en applications no aparece, aparentemente porque esta capado. He virtualizado mi número de teléfono de casa de toda la vida con netelip pero ahora no puedo configurar el router. Quiero evitar comprar un gateway sip ya que el router tiene la capacidad.

He comprado un TTL y activado el servicio Telnet se pueden ejecutar comandos Unix aparte de los 4 de busybox que permite por defecto.

Me gustaría saber si alguien sabe cómo puedo cambiar a base de comandos la configuración SIP o si mejor aún... se puede extraer de alguna forma el usuario y password del interface web con privilegios de admin para hacerlo desde ahí.

Muchas gracias!

vukits

el tema va más o menos así.

pero no sé cuál es la contraseña de admin

haceis un reset al router y accedeis con el nombre de usuario y contraseña root antes de que se actualice podréis aún conseguir las nuevas claves de acceso"

Lee lo comento más abajo ( aquí) para evitar tanta cosa de que si te actualizan tal o cual o te quitan usuarios y demás.

Aparte, así podrás tener más de un SSID activo a la vez, entre otras cosas.

🗨️ 6
yorelito

He hecho lo que se menciona en el post de pulsar el boton reset varios segundos y loguarte con admin/admin, y después...

- Primer paso:

Security -> Service Control -> Modify -> desactivar "Enable" -> Guardar

- Segundo paso:

Administration -> TR-069 -> añadir algo en "username", el mío por ejemplo es "69cpe69" en vez de "cpe"

He guardado cambios y reiniciado el router con la fibra desconectada... pero en cuanto que conecto la fibra se me reinicia la sesión del interface web y desaparece la cuenta admin:admin y se vuelve a la configuración que tenia antes.

¿Sabes como se puede hacer para retenerl a?

🗨️ 5
vukits

vaya tela.

¿has probado a meter la configuración SIP antes de conectar el router a internet?

quizás tengas suerte, y no se borre (sólo quede oculta)

🗨️ 4
yorelito

se borra la config nada mas conectar la fibra.

el fichero se encuentra en /userconfig/etc/db_default_cfg.xml

he buscado otro fichero de igual tamaño en todo el árbol de directorios y en /etc hay uno con el nombre de db_default_MasMovil_cfg.xml junto con otros tantos... de Jazztel y extranjeros.

he visto unos scripts en /etc/init.d/ que restauran los ficheros de /userconfig/cfg con los de /etc/ siguiendo una lógica de regiones. algo así...

 regioncode=$1

        regionname=`busybox sed -n "s/^${regioncode}:\(.*\)/\1/p" ${ETC_DB_REGIONCODE}`

        echo "==================================================================="

        echo "region code:$regioncode"

        echo "region name:$regionname"

        ETC_DB_CFG_XML=/etc/db_default_${regionname}_cfg.xml

        if [ -f "$ETC_DB_CFG_XML" ]; then

                busybox cmp $ETC_DB_CFG_XML $USR_DB_DEFAULT_CFG_XML 1>/dev/null 2>&1

                if [ $? -ne 0 ]; then

                        echo "USR_DB_DEFAULT_CFG is different from ETC_DB_CFG!"

                echo "cp $ETC_DB_CFG_XML to $USR_DB_DEFAULT_CFG_XML "

                cp -f $ETC_DB_CFG_XML  $USR_DB_DEFAULT_CFG_XML

        else

                        echo "USER_CFG is same as ETC_CFG, donot need copy"

                fi

        else

                echo "current : 0" > $USR_CFG_TYPE_FILE

        fi

        echo "==================================================================="

asi que he probado a copiar mi fichero de config tanto en /etc/ como en /userconfig/ para que sean iguales y no me los machaque y no ha funcionado... se han restaurado ambos..En el siguiente intento directamente he modificado los scripts para que no ejecute las lineas con comandos "cp"para evitar que me copiase ficheros sobre los míos... y al igual que los demás al reiniciar los ficheros de script se han restaurado por los originales.hagas lo que hagas al reiniciar se restauran los ficheros. Lo raro es que si metes ficheros nuevos(con nombres diferentes) no los borra, con lo que entiendo que no restaura carpetas completas sino ficheros concretos.
ya no se me ocurre que hacer.

🗨️ 3
vukits
🗨️ 2
yorelito
🗨️ 1
vukits
BocaDePez
BocaDePez

He hecho lo que se menciona en el post de pulsar el boton reset varios segundos y loguarte con admin/admin, y después...

- Primer paso:

Security -> Service Control -> Modify -> desactivar "Enable" -> Guardar

- Segundo paso:

Administration -> TR-069 -> añadir algo en "username", el mío por ejemplo es "69cpe69" en vez de "cpe"

He guardado cambios y reiniciado el router con la fibra desconectada... pero en cuanto que conecto la fibra se me reinicia la sesión del interface web y desaparece la cuenta admin:admin y se vuelve a la configuración que tenia antes.

¿Sabes como se puede hacer para retenerla?

🗨️ 1
BocaDePez
BocaDePez

Buenas. ¿Conseguiste solucionar esto? Estoy en Pepephone con el mismo problema exactamente que tu. Saludos.

🗨️ 3
BocaDePez
BocaDePez

Yo también tengo el mismo problema: me acaban de poner la fibra de Pepephone con el router F680 dichoso, que viene con la VoIP capada. El usuario y la contraseña son 1234/1234 pero el técnico no me ha dicho su usuario/contraseña para configurarlo. Quiero ponerle una línea sip de Netelip, pero no hay manera de acceder a la configuración en el router.

🗨️ 1
ToooWuu
1

el técnico no me ha dicho su usuario/contraseña para configurarlo

No puede darte la contraseña porque el usuario "admin", que es el que puede configurar el VoIP, está restringido.
Aún con su contraseña no podrías acceder.

¿Como "desbloquear" el usuario admin?
Hay varios mensajes en este foro donde lo explican. Yo mismo puse en este hilo el enlace a uno de ellos.