BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra/Cable

Router HFC Technicolor TC7230 en modo puente, se reinicia con qBittorrent en Linux

Jeronimo17

Uso Linux Mint para casi todo, incluso se lo tengo puesto a un familiar en su portátil.

Hace tiempo vi que en su casa el router se reiniciaba al usar Linux Mint por cable, que le hice una instalación hasta la habitación. Con Windows 10 en el mismo portátil no se reiniciaba nunca. Al cambiar el MTU en Linux de 1500 a 1400, ya no le ha vuelto a suceder (en su caso) el problema (no termino de entender que problema puede tener el firmware del router)


En mi casa tengo el Technicolor TC7230 en modo puente a un OpenWrt, y tambien se me ha reiniciado cuando le he dado caña a qBittorrent (lo uso poco pero siempre me ha pasado con torrent descargando archivos grande como de 30GB).

Acabo de cambiar el enlace de OpenWrt con el TC7230 el MTU a 1400 y parece aguantar.

El router con OpenWrt sin problemas no falla.

No se si sabeis algo del tema o si teneis problemas de este tipo probar a poner 1400 de MTU, supongo que para que no le lleguen paquetes muy grande al router de Vodafone que provoque su reinicio.

Jav9i

a mi en Digi me pasa que cuando un torrent tiene muchas conexiones, muchas veces se me satura el router, pero a mi me pasa en windows, pero es muy posible que lo que pasa es que Linux le meta mas caña al router que windows, lo que hace que se sature, ademas que comunmente los equipos para HFC suelen sen menos potentes, el que sean archivos grandes me hace pensar aún mas que es por saturacíon del router, por que le da tiempo a conectar a mas seeders y hacer mas conexiones.

🗨️ 1
Jeronimo17

Si es correcto eso, pero en ese caso debería saturarse el que tiene OpenWrt, el de la operadora esta en modo puente no gestiona las NAT

Jeronimo17

Me ha pasado una vez más con qBittorent aun con 1400 MTU, estoy intentando probar con descarga directa curl http://fra36-speedtest-1.tele2.net/1000GB.zip -o /dev/null y no consigo que falle, no se que se me escapa con Torrent ( y que se reincia ese router lo tengo comprobado, tira el fijo también)

2Fast
1

Croe que has obviado lo más habitual en estos casos: Mirar el log del router para comprobar que esos reinicios no hayan sido los famosos "microcortes" debidos a interfencias, ruidos o niveles incorrectos de la señal HFC.

Que con el MTU en 1400 no se haya dado la coincidencia de que se reinicie la conexión, ha sido pura coincidencia. Déjalo en 1500.

🗨️ 7
Jeronimo17

En el caso de mi familiar te aseguro que era conectar el cable y reiniciarse sin parar, hasta cambiar a 1400 de MTU en Mint.

En mi caso si que dudo que sea eso, en este router (TC7230) no se como mirar el LOG de DOCSIS.

Llevo descargando en descarga directa 176 GB a 300 Mb/s sin problema pero con qBittorent como haga 2 descargas de 30 GB se reinicia

🗨️ 6
Jav9i

la descarga directa hace 1 conexión, torrent hace muchas, hay que tener eso muy en cuenta

🗨️ 5
Jeronimo17

Pero me pregunto a un router en modo puente ¿Le afecta el numero de conexiones que haya o solo la velocidad total?

Torrent lo tengo limitado a 50 conexiones por Torrent y 100 global

¿Hay algún test que pueda probar esto fuera del P2P?

🗨️ 4
Jav9i
1
🗨️ 3
Jav9i
Jeronimo17
1

Otra cosa que se me ocurre, después de descartar que un numero alto de conexiones parece no afectar (fuera de P2P), es en el router OpenWrt bloquear el acceso hacia 192.168.100.1 en la WAN.

El motivo de esto es que el firmware de Vodafone como toquetes los menús rápidos te comes un reinicio, es un mírame y no me toques y he pensando que lo mismo qBittorrent hace un escaneo quizas vía DHT o algo parecido y mande muchos paquetes hacia esa IP del router de Vodafone y siendo tan inestable llegue a provocar un reinicio.

Haré pruebas así

🗨️ 1
Jeronimo17

Descartado

Uptime since last reboot 0 days 00h:09m:41s

vukits

Los firmwares de Vodafone son una castaña.

Mi H500S se reiniciaba cuando le daba mucha caña con descargas de Steam y Origin.

A otro usuario, su cablerouter se reiniciaba cuando usaba VozIP.

Desconozco si le puedes pinchar una sonda SNMP al router , o un Syslog, a ver qué escupe.

PD: presupongo que su fuente de alimentación va bien de potencia… porque en équipos embebidos, cuando la CPU tira mucha corriente, se reinicia el router. (y presupongo que está bien ventilado también. )

🗨️ 1
Jeronimo17
1
utp.webp

Ya creo haber encontrado el problema el protocolo μTP (uTP) del Bittorrent, lo he desactivado y ya no falla, he buscado y efectivamente hay más casos github.com/qbittorrent/qBittorrent/issues/11750

Lo de la fuente de alimentacion en otra ocacion la probé con una carga electronica y llegaba a 3A sin problemas (me dedico a la electrónica).

Gracias

PD: Me suena haber tenido el problema hace mucho tiempo pero ni idea que operadora/router tenia y haberlo comentado en algún sitio.

PD2: Ayúdanos a resolver tu ❓ duda aprentando el botón ✔ en la respuesta correcta ¿Como? No veo botón (Firefox desde Linux Mint) @Josh