BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Error 1920 al usar Robocopy para hacer backup del sistema de archivos

Solospam

Estoy tratando de hacer un backup puro de mi sistema de archivos.

Habitualmente uso Robocopy de windows, pero ahora me esta dando el error 1920 [carpetas de sistema]

Alguien conoce cómo evitar este problema, actualmente uso 'robocopy [carpeta de origen] [carpeta de destino] /MIR /xj'

Gracias de antemano.

raxor
2

¿Estas copiando carpetas del sistema operativo? Podría ser que algún fichero de solo lectura que existe en destino ahora no exista en origen y al llevar el parametro MIRror no pueda eliminarlo.

Yo uso Unstoppable copier y quito las ACL (dejo las fechas del fichero).

Otra opcion mas avanzada es Richcopy variante de robocopy pero que usa hilos de procesos y es mucho mas rápido.

Y si lo que quieres hacer es un backup del SO puedes hacer una imagen con Macrium Reflect, que es mucho mas rápido ya que copia bloques.

🗨️ 1
Solospam

Estaba copiando la carpeta "usuarios" para formatear y vender el equipo.

De esta forma, me garantizo que las carpetas de configuración de firefox, google chrome etc se copian tal cual.

Luego un escaneo ""deep" de virus, rockits, etc y a otra cosa con un pc nuevo.

Gracias por el aporte

BocaDePez
BocaDePez

Yo de parámetros a robocopy le paso: /r:2 /w:2 /b /NJH /np /xo /v /ts

En tu caso puede que el /b ayude.

🗨️ 1
Solospam
1

te falta el "xj" para evitar cinculaciones... yo usé el /r:1 /w:1

el /b no lo conocía, gracias por el aporte

BocaDePez
BocaDePez

Si quieres una imagen bit a bit del disco, usa una live de Linux con dd.