Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
812 lecturas y 16 respuestas
  • Roaming entre 2 APs

    Les comento… Tengo un problema que me va a hacer salir loco.

    Actualmente vivo en un chalet de dos plantas bastante amplio, el problema de esto es que como es lógico el wifi no llega a todas partes.

    Tengo Movistar fibra 100 MB Y he cableado toda la casa con cable de red CAT 6 por los tubos de las paredes (Están separados de los de la instalación eléctrica y el cable es blindado FTP)

    Con lo que he puesto 2 puntos de acceso más conectados por cable al router principal para cubrir toda la superficie de la casa.

    He puesto ambos con el mismo SSID para que solo haya una red wifi y los Routers hagan Roaming

    Actualmente mi red está montada así:

    El problema es que cuando voy andando por la casa y cambia desde un punto de acceso a otro pierdo la conexión, es decir, me hace el cambio pero pierde conectividad, he probado a configurar a los dispositivos inalámbricos (en este caso un Samsung Galaxy note 4) una IP fija y nada de nada..

    El mikrotik tiene habilitado el DHCP mientras que los puntos de acceso lo tienen deshabilitado

    Así es como está configurado el punto de acceso del Router COMTREND VG-8050 de Movistar:




    Y así está el AR-5381u de Jazztel:




    Para configurar el mikrotik seguí este tutorial:

    www.adslzone.net/postt311611.html

    Seleccionando la opción de archivo de configuración sin movistar TV y sin wifi (Ya que no tengo contratado Movistar TV y ese modelo de mikrotik no tiene wifi incorporada)

    El cable a los puntos de acceso lo conecta utilizando el puerto LAN 1 y dejando el puerto WAN (el del teléfono en el caso del router de Jazztel) vacío

    ¿Qué estoy haciendo mal?

    Este tema lleva más de 6 meses inactivo. Es recomendable que abras un nuevo tema para retomar la conversación.
    1
    • te recomiendo usar el wap5813n (con firmware Openwrt) como…

      te recomiendo usar el wap5813n (con firmware Openwrt) como router neutro (ponerlo en lugar del Mikrotik)

        • BocaDePez BocaDePez
          6

          Prueba lo que te dijo el compañero de arriba : Edita las…

          Prueba lo que te dijo el compañero de arriba :

          Edita las interfaces locales para que no te pertenezcan al switch (ether1-4 master=none) y luego crea un bridge ( /interface bridge add name=bridge-lan) y añade esas interfaces como puertos (/inetrface bridge port add bridge=bridge-lan interface=ether2 al 4).

          Recuerda que entonces el servidor DHCP lo tienes que hacer sobre el bridge y no sobre el ether2.

          /system backup save por lo que pueda pasar :D

    • BocaDePez BocaDePez
      6

      El problema esta en que el switch ethernet de mikrotik sigue…

      El problema esta en que el switch ethernet de mikrotik sigue creyendo que tu mac ethernet esta sigue en el otro puerto.

      Une los puertos del mikrotik a través de un bridge, no haciendo que copien uno del otro.

      Lo siguente es que los ap hablen spanning tree (STP) con el bridge creado para que informen de que direcciones mac tienen conectadas.

    • 6

      yo he tenido este problema. Después de muchas pruebas, he…

      yo he tenido este problema.

      Después de muchas pruebas, he llegado a la conclusión de que es probablemente debido a que los routers o sus switches no gestionan bien los paquetes ARP, esto es, saber a qué dirección MAC van los paquetes IP, por lo que al cambiar de un router a otro, siguen intentando enviar los paquetes por el "camino antiguo", por lo que no funciona el tema.

      Mi unica solución ha sido cambiar de router/punto de acceso a una combinación que funcione. Por ejemplo, en casa tengo un WRT54G y 2 puntos de acceso TP-Link y me hace roaming entre ambos correctamente. En casa de mis padres tengo el router de fibra de movistar que ahora no recuerdo la marca, un WRT54G y otro punto de acceso tp-link (3 puntos de acceso) y el roaming funciona bien cambiando de uno a otro. Pero me costó llegar a esta combinación, porque con la mayoría de routers que dan al darse de alta en las compañías (que tengo unos cuantos) no me funcionaban, da igual cómo los configures, creo que es algo de la parte switch del trasto que no se puede configurar.

      Así que me temo que te toca buscar otros modelos de router o puntos de acceso hasta que des con una combinación que te funcione.

      Saludos!