Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Reset con kernel 2.6 y udev con 2.4

BocaDePez
BocaDePez

Hola:

Tengo 2 dudas:

1.- Me pasé a la rama testing de Debian pero me dejó de funcionar el ratón USB. Me imagino ke es por el udev y mi kernel 2.4 (creo ke udev de testing sólo funciona para >= 2.6.algo).
Mi pregunta es: ¿puedo usar el udev de la sarge? y si puedo ¿cómo lo instalo? ¿cambio otra vez el repositorio a sarge y hago el apt-get del udev?

2.- La otra es que hice un apt-get para bajarme la imagen del kernel 2.6... todo ha ido bien pero al arrancar se resetea todo el rato. ¿como puedo ver que es lo que esta reseteando el pc? va demasiado rápido para ver que intenta ejecutar para ke se me haga un reset... ¿deja algun log en algún sitio? Lo digo por entrar con el kernel 2.4 y mirar un poco en google :D

Un saludito a tod@s y gracias

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
Pridebowl

Ehi, aqui encontrabase un comentario despeñado del moderator de este foro.

¡¡¡Exigimos que todo vuelva a la normalidad, de la forma mas prudente posible e eficaz!!! 8-) :-D

El udev, no lo he trasteado todavia pero si he cambiado alguna vez del 2.4 al 2.6 y podria decir que no es del todo limpio el arranque en el 2.4 despues de instalar el 2.6.

Pa mirar los logs /var/log/ macho, mas bien mira /var/log/messages y /var/log/dmesg y /var/log/X* por si las mosquis raras. :D

Supongo que apt-get install udev y no creo que haya ningun problema.
apt-cache search udev.

Un saludo

🗨️ 1
anthrax

te lo había dejado para ti :D

Saludos 8)

anthrax

1) En principio al instalar udev no debe afectar a ningún dispositivo que antes funcionase.
Prueba a desconectar y volver a conectar el ratón USB una vez ya esté arrancado el GNU/Linux. A continuación ejecuta el comando dmesg que debería enseñar algo similar a esto en las últimas líneas:

usb 1-1 new low speed USB device using uhci_hcd and address 4
usb 1-1 configuration #1 chosen from 1 choice
input Microsoft Microsoft Notebook/Mobile Optical Mouse 2.0 as /class/input/input4
input USB HID v1.10 Mouse [Microsoft Microsoft Notebook/Mobile Optical Mouse 2.0] on usb-0000:00:1d.0-1

Normalmente el fichero del dispositivo de los ratones USB es /dev/input/mice. Comprueba que al conectar al ratón este fichero existe.

Las X's también usan este fichero a la hora de acceder/configurar los ratones USB:

$ grep mice -B 5 -A 5 /etc/X11/xorg.conf

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5

2) Respecto al reinicio automático del kernel, necesitariamos que nos dijeras que es lo que dice. No creo que se llegue a guardar ningún log, porque seguramente no llega a montarse ninguna partición ...

Saludos 8)
P.D: Si te interesa el tema de udev + 2.6 aquí te paso algunos enlaces:
(link roto)
wiki.gentoo.org/wiki/Udev (inglés)
reactivated.net/writing_udev_rules.html (inglés)

🗨️ 2
BocaDePez
BocaDePez

Hola:

Soy el ke inicio el post.

Para el punto 1 me autorespondo por si le ha pasado a alguien antes:

- Tras pasarme a testing (etch) en debian udev de testing no funciona con un kernel 2.4. El ratón por USB lo reconoce y si lo kito y lo vuelvo a poner sale el mensaje de mouse USB reconocido.
El problema: al configurar las X no detecta el ratón en /dev/input/mice. Cuando intentas arrancar las X, busca el dispositivo y al no encontrarlo te las tira abajo.
Solución: no se si es correcta pero elimine udev con apt-get, cambie los repositorios a sarge e instale udev y ahora si me funciona. He de decir que el gestor de ventanas ke puse era gnome + xorg (todo de testing), por lo que no se si el problema es de xorg o del propio gnome (si puedo instalo algún gestor ligerito para hacer una prueba).

- Para el punto 2: mi problema es que no veo que pone al iniciar (demasiado rápido)... empieza la carga típica y en la 5 línea mas o menos se reinicia. Me gustaría saber si hay algun log con lo que carga nada mas encender el PC, para ver que está produciendo el conflicto. También decir que la placa de mi PC es algo antigua y entiendo que el kernel 2.6 pueda tener problemas con ella (pero me gustaría investigar algo mas antes de dejarle obligatoriamente el kernel 2.4 a este PC)

Un saludo y gracias a Anthrax y a Pridebowl por las respuestas.

PD.- muy bueno el post ke habéis subido a los enlaces fijos el otro día con problemas típicos solucionados

🗨️ 1
anthrax

¿ Has comprobado en los dos casos (udev de etch & sarge) que al conectar el ratón exista el fichero /dev/input/mice ?

Lo más seguro es que en el udev exista la regla para crear el fichero de dispositivo del ratón.

$ grep mice /etc/udev/rules.d/*

/etc/udev/rules.d/udev.rules:KERNEL=="mice", NAME="input/%k"

Mi distribución es Kubuntu 5.10 (Breezy Badger), pero en debian debe ser igual o casi.

Si existe esa regla veo raro que no se genere el fichero /dev/input/mice al conectar el ratón USB ... :o

Saludos 8)