BandaAncha.eu

  • 🔍 en 📰 artículos ⏎
  • 🔍 en 💬 foros ⏎
  • 🔍 en 👇 este 💬 foro ⏎
  • 🔍 en 👇 este 💬 tema ⏎
Regístrate Regístrate Identifícate Identifícate
Fibra
💡

Remplazar router Digi ZTE H3600 por uno con OpenWrt

sergioam
3
Cambiar router Digi ZTE H3600 por OpenWRT

Esto es como una continuación de este otro post donde indican cómo reemplazar la ONT Zte F601 v7: Cómo cambiar la ONT Zte F601 v7 por un Ufiber Loco sobre fibra Digi.

Seguí a rajatabla ese post para instalar mi ONT, luego la conecté a mi router neutro, un Linksys WRT3200ACM:

  • Hardware: ARMv7 Processor rev 1 (v7l)
  • Firmware: OpenWrt 21.02.0 r16279-5cc0535800 / LuCI OpenWrt-21.02 branch git-21.231.26241-422c175.

Me he puesto 1Gb de Fibra Smart (red propia de Digi), y el router reemplazado ha sido el Zte ZXHN H3600.

Prerrequisitos

Para conectar nuestro router necesitamos pedir a Digi las credenciales PPPoE, que las mandan de inmediato por correo. Además allí nos indican también que la VLAN 802.1Q es la 20, aunque eso deberíamos saberlo ¿no?

Configuración de OpenWrt

Cuando tengamos todo podremos proceder. Elegid un método, o ambos para aseguraros que todo ha quedado ok (doble check!):

Via SSH/Terminal/pantallitas negras

Archivo /etc/config/network:

config interface 'wan'
    option proto 'pppoe'
    option username '1234567@digi'
    option password 'PaSS'
    option device 'wan.20'

config device
    option type '8021q'
    option ifname 'wan'
    option vid '20'
    option name 'wan.20'

He quitado las partes poco importantes, estas que menciono son las claves.

Vía admin/web/LuCI

Vía LuCI, primero crearemos un nuevo device para la VLAN 20 en Network → Interface → Devices:

vlan
VLAN

Y luego configuraremos la WAN para que haga uso de este "device" en Network → Interface → Interfaces → WAN → Edit

wan
WAN

Lo importante aquí es el Protocolo, el Device (wan.20) y las credenciales PPPoE que nos mandaron por correo.

Bonus: Acceso a la UI de la ONT Ufiber

Si a mayores queréis tener acceso al ONT desde la LAN del router (vamos, desde cualquier equipo conectado al router, por cable o wifi), basta con añadir un interface estático contra la IP donde tengamos configurada la ONT, en mi caso 192.168.10.1:

config interface 'ONT'
    option proto 'static'
    option device 'wan'
    option ipaddr '192.168.10.2'
    option netmask '255.255.255.0'

O vía LuCI:

ont
ONT

Ese .2 es la IP que tendrá el router para la ONT, lo mismo que si os conectáis con un PC directamente al ONT vía cable. Con esto, accediendo a http://192.168.10.1/ ya nos cargará la UI del ONT.

aeri

Buen tuto, ¿qué tal se comporta el WRT3200 con 1Gb?

🗨️ 3
sergioam
1

Gracias!

Pues va bastante sobrado, es una bestia parda, la única pega que tiene a día de hoy es que no tiene WiFi 6, por lo demás bien. Llevo años con él, desde que tenía Adamo 1Gb en mi anterior piso, al mudarme he estado con Movistar 600Mb hasta ayer que pase a 1Gb de Digi.

load
Load

Esa es la carga haciendo un speedtest de por medio, con (sin exagerar) unos 20 dispositivos wired/wifi conectados ahora mismo.

Y claro, de velocidad pues lo que de Digi en ese momento, normalmente me está dando entre 800 y 900poco de bajada, 900poco de subida siempre. Lo mismo que me daba el router de Digi el rato que estuvo conectado.

🗨️ 2
aeri

Muy bueno saberlo, tengo el mismo modelo solo que con 300Mb y la CPU en un test ronda el 17%, lo que pasa es que gestiona más interfaces y tiene varios servicios desplegados. Por lo que veo está preparado sin problemas para el giga.

🗨️ 1
sergioam

Si, sin problema.

Por ponerle pegas al aparato (que no todo sean cosas bonitas), para no tener jaleo con la wifi es recomendable desactivar el radio2, tercera antena de 5GHz pero que usa otro driver chungo. Con radio0 y 1 activas para 2.4 y 5 va que chuta.

vukits

muchisimas gracias.

lo agrego al repositorio

🗨️ 1
sergioam

Editado, puse mal el router, es el WRT3200ACM, no el 3600 (que ni existe).

VicentAntonio

¿Tan malo es el ZTE H3600? Es el que me han puesto a mí y va bastante mejor que el de Lowi de cable (TCL 7230.L)

🗨️ 1
sergioam

No (no sé), no es un tema de malo o no, es un tema de tener control sobre la parte de infra que me sea posible. Controlar mis actualizaciones, mi software, y mis aparatos. Que no me lo actualice la operadora cuando quiera, me lo reinicie, o lo que sea. Y por cacharrear/aprender, monitorizar el aparato, etc etc.

TxarlyM

Hola a todos. Como vosotros tengo fibra de Digi con el mismo Router ZTE ZXHN H3600 y a los 2 dias de haberlo instalado ya tenía en mente cambiar ese Router por otro por un solo motivo : La wifi no es estable. Cada cierto tiempo se pone a negociar la velocidad de la Wifi y cuando eso ocurre si estoy haciendo un llamada, videoconferencia, etc se corta. Además la intensidad de la Wifi es muy pobre dándome transferencias de unos 91Mbps. Las Wifis conectadas a la red de 5G sincronizan a 1300/144, 1300/244, 1300/517 ó 1300/867 según le da al Router por establecer la velocidad. La distancia desde el equipo principal al Router es de aproximadamente 6m y solo hay un tabique de pladur hueco que puede dificultar un poco que llegue la señal. Según los técnicos debería tener transferencias cercanas a los 450Mbps, aun siendo el Router así de malo. Encima este Router, como todos los de Digi, están grabados con una versión de Firmware al que le han eliminado la cuenta de Admin para que no podamos hacer modificaciones.

Si a eso añadimos que de todo el catálogo de Digi éste Router es el que tiene las características más básicas; no soporta 160Mhz de ancho de banda y solo llega a 80Mhz en 5G y a 40Mhz en 2.4G…Me quedó claro que el Router hay que cambiarlo lo antes posible y ya con paciencia intento hacer que el teléfono fijo me funcione de alguna manera.

He probado otros routers alternativos : Un Asus TUF AX5400, que de funcionar bien con la conexión de Digi me lo hubiera quedado. Solo llegó a funcionar 2 horas hasta que empezó a dar errores de autenticación en las credenciales de PPPoE, no pude volverlo a conectar y acabé devolviéndolo. El segundo Router que probé ha sido el Huawei AX3 Quad Core y pude conectarlo sin problemas, pero la conexión WAN se desconecta y se vuelve a conectar sin motivo aparente. He clonado la MAC del ZTE en el Huawei y parecía que se había resuelto, pero sigue sucediendo lo mismo y los cortes se producen menos pero se siguen produciendo. También he comprobado que la intensidad de la señal es más baja incluso que con el Router ZTE de Digi, pero al menos la conexión es bastante estable a 1300/867.

Dispongo también un ZTE F6640 de Virgin que igual puedo usarlo como punto de acceso ya que tiene usuario Admin , es Wifi 6 y me sincroniza a 1300/1300 sin problemas. Podría ser otra solución.

Necesito recomendaciones de Routers que funcionen bien y tengan una buena cobertura Wifi. No tiene por qué ser de Wifi 6. Puede ser un Wifi AC, pero al menos quiero conseguir que las Wifis de mis equipos sincronicen a 1300/1300 (al menos que sea con Wifi 5) y que la conexión sea estable.

Saludos y gracias.

🗨️ 5
sergioam

Sobre los problemas que comentas del router que pone Digi, no te puedo decir porque lo cambié según se fue el instalador por la puerta. Vamos, que no lo he usado.

En el post comento qué equipos uso yo, el router lo he usado con Adamo, Movitar y ahora Digi, nunca he tenido problemas. Y mucho menos como los que comentas.

La wifi no me ha dado problemas nunca, aunque ahora uso la de un AP Netgear por tener wifi6, pero hasta hace no mucho he usado siempre la del router, y sin problemas.

w3c

Confirmo la mala conexión WIFI del ZXHN H3600. Con Livebox Fibra de Orange (500mbps contratado) me daba ~450mbps por WIFI. Ahora con 1 Gbps el WIFI no llega a mas de 70-80 Mbps. El PC tiene una tarjeta WIFI 6 de Asus, con 2 antenas.

🗨️ 3
TxarlyM

Al final me he liado la manta a la cabeza, y he decidido cablear la casa con cable Cat.6A y aunque me ha salido la cosa un poco cara ya tengo en los equipos las velocidades que debo tener… Así que en lugar de cambiar de Router lo que voy a cambiar es de compañía en cuanto pueda. Son solo 2 meses de permanencia, pero casi ninguno ofrece la fibra a 1Gbps. Digi podía ser la mejor opción, pero me ha defraudado por 3 motivos : 1.- Negarse al cambio de Router cuando estoy teniendo problemas. 2.- El CG-NAT, aunque pagando parece que lo quitan. y 3.- No facilitar todos los datos para tener Router propio y configurar la línea de Fijo.

Sólo si lograra poner un Router neutro que tuviera la Wifi estable y pudiera configurar el fijo con una caja VoIP externa podría plantearme el quedarme con la conexión de Digi, pero todos los procedimientos para extraer las credenciales VoIP son para otros Routers, no para el lamentable Zte H3600. Agradecería un montón si alguien tiene información de cómo hacerlo.

Saludos

🗨️ 2
w3c

El cable es la mejor opción. En mi caso, la casa no es mía y no puedo. En el pasillo tengo un enchufe muy cómodo, puedo meter un repetidor, si se queja mucho la familia :)

Gop

Yo lo que hice es poner un router Xiaomi ax3600 como punto de acceso, sencillo y potente. Por cierto, si te vas a otra compañía puedes que te den un router mejor (aunque lo dudo) y ninguna compañía te dará los datos de SIP (tendrás que buscarte la vida para sacarlos).

GroovyTorpedo

Buenas! buen tutorial, ayer he configurado la ONT sin problema siguiendo tus pasos y conectado a un USG 3P en un moment!

Lo unico que de momento no logro llegar a la ONT por WebUI una vez ya todo funcionando, la ONT tiene una IP de la misma Subnet que mi LAN, ¿Tendría que ponerle una IP en otra Subnet, por ejemplo, 192.168.1.254? Unifi no te permite crear una VNI como haces con OpenWrt, entonces me deja algo extrañado como hacer para llegar a el.

Gracias de nuevo!

blobby

Preguntilla, qué hacéis vosotros con la interfaz wan6? Dejarla en DHCP o hay que ponerle también el PPPoE?