Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Reemplazo de rutas a HTTPS en WordPress

Leste

¿Chicos, quien me ayuda un momento con un Wordpress?

No consigo localizar unas rutas en la instalación para forzar ese contenido a HTTPS, y necesito cambiar el dominio donde están alojadas por tanto no me sirve ningún complemento que haga force a httpS.

Gracias y Saludos.

rbetancor

Si el site era HTTP y lo quieres fozar a HTTPS ... creo que no te quedan más naipes que hacerlo directamente en la base de datos.

🗨️ 1
Leste

Digamos que la web tiene unos iconos que llevan la siguiente ruta:

dominiowebmasterpruebas.com/folder/img.png

Y el ssl me dice que hay contenido mixto y se queda en color gris

Necesito que la ruts sea:

HttpS://dominiodelaweb.com/.........

He intentado hacer replace en la BD, es decir, donde estuviera su dominio que lo cambie por el de la web, pero nada, y por mas opciones que miro en Back-end no veo ningun lugar donde editar la ruta.

Gracias por la ayuda

Bramante

Es una obviedad y seguro que lo has hecho, pero igual se te ha pasado por despiste, ¿tienes activada la opción de (no tengo ahora una instalación de WP a mano y no recuerdo nombres exactos) "Activar https" y en el campo de la dirección del site has introducido la URL completa, indicando HTTPS?

Con esas dos cosas, todas las peticiones deberían reescribirse de forma automática a HTTPS sin necesidad de nada más.

🗨️ 11
Leste

Si. Lo que pasa que con esa opción consigo que modifique la url que dejó el Webmaster añadiendo S al protocolo. Y lo que necesito es cambiar la ruta que sigue wp para buscar la imagen.

No se si me expliqué bien jejejeje

🗨️ 10
Bramante

No te entiendo.

¿Al pasar el site a HTTPS la localización de las imágenes ha variado?

Porque cambiando lo que hablamos, todo lo que el servidor sirva al cliente, lo hará bajo HTTPS. Si el usuario llega a ver las imágenes, la localización es correcta, nos quedaría ver por qué se produce el error de contenido mixto.

🗨️ 9
Leste

No, cuando el webmaster hizo la web, subió parte de los iconos de la misma a un dominio suyo (link roto)

Nosotros hemos migrado la web de hosting y al activar el SSL con el nuevo host, nos indican que hay contenido que no está alojado en el dominio de la web, y que encima de que el contenido es externo está en un directorio sin https.

Por eso al cargar la web, el candado permanece gris, por que usa los links de su dominio y no los links propios del site.

Es complejo, pero creo que ahora me expliqué

Mil gracias

🗨️ 8
Bramante
🗨️ 7
Leste
Leste
🗨️ 5
Bramante
🗨️ 3
Leste
🗨️ 2
Bramante
🗨️ 1
BocaDePez
BocaDePez
1