BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Configurar VLAN de Digi en Xiaomi Redmi Router AX6 con OpenWrt

Yujiro Hanma

Tengo el Xiaomi Redmi Router AX6 con OpenWrt. He intentado configurar la conexión WAN con el protocolo PPPoE introduciendo los datos que me facilitó Digi pero no conecta y supongo que es porque tengo que configurar la VLAN. A ver si me podéis echar una mano para hacerlo porque no tengo ni idea.

9dln8hlpol.webp7tq1whmmtz.webp
vukits
1

ruego leas este hilo

básicamente, te falta aplicar la VLAN (eth0.20), en el fichero /etc/config/network

config interface 'eth0'
option ifname 'eth0.20'
Yujiro Hanma

Vale he conseguido que funcione, es que hay que esperar un rato hasta que enlaza.

v4gkkocsit.webpifzq6jbkyc.webp

El problema ahora es navegación lenta y que no puedo abrir determinadas webs por ejemplo bandaancha.eu

He hecho un test de velocidad a speedtest y sí me ha dado buena medición

🗨️ 2
vukits

¿Quién hace de DNS?

🗨️ 1
Yujiro Hanma

No era problema de DNS. He seguido los pasos de este vídeo y ya todo funciona bien

youtube.com/watch?v=-Cv68PXdQMw

Ya puedo guardar en la caja el Zyxel de Digi, que no es mal router, pero el AX6 lo tengo de antes de pasarme da Digi.

Gracias por la ayuda

vukits

porfa, hazme el favor y pega aquí tu fichero de /etc/config/network (censura las claves PPPoE, claro está)

🗨️ 2
Yujiro Hanma
1
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd 0:06 :6 9::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1 eth2 eth3'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0.20'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username '0xxxxxxx5@digi'
	option password 'yyyyyyyyy'
	option ipv6 'auto'
	option keepalive '0'
	option mtu '1492'

config interface 'wan6'
	option ifname 'eth0.20'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
🗨️ 1
vukits

Magnifico, muchas gracias

caenix

Buenos días Yujiro,

¿Seguiste algún tutorial en castellano para instalar el OpenWrt en este router?

🗨️ 8
caenix

Buenas tardes amigo,

¿Por casualidad tienes los documentos descargados? Al entrar para descargar me sale error 404. Gracias

🗨️ 2
Yujiro Hanma

mediafire.com/file/19q9fe9aapovrgv/creat…oit.zip/file

Otra cosa que te tengo que decir ya que te veo decidido es que no me salió a la primera, no sé por qué razón varias veces después de subir el archivo 1.bin al intentar el 2.bin me daba error. Puede que fuera porque no tenía el firmware actualizado o por la url donde usé el .js

🗨️ 1
caenix
caenix

Buenos dias Yujiro,

Disculpa las molestias. He estado intentado hacerlo pero al pegar el código en la consola del navegador me sale este mensaje "Failed to fetch log" ¿Tienes alguna idea sobre ese error?

Gracias amigo

🗨️ 3
Yujiro Hanma
1

Tienes que copiar el código de "create_exploit.js" en la consola. Yo lo hice con el navegador Opera. Recuerdo que con el navegador Vivaldi me daba problemas.

🗨️ 2
caenix
🗨️ 1