Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
28 lecturas y 9 respuestas
  • Cerrado

    [Editado 29/12/02 08:26]

    6

    ¿¿¿redirecciones y servicios httpd???

    Saludos a todos soy nuevo en este foro, resulta que hace nada que tengo el adsl en casa y quiero habilitar un apache para mantener un sistema de foros, jeje...

    por supuesto prometo informaros del dominio en cuanto este activo, palabra.

    Bueno, aqui va el tema

    Efficient 5660 multipuesto

    el cable del modem-router enlaza directamente al servidor linux y este mediante otra targeta ethernet enlaza a un hub que repate la conexión mediante una pasarela a dos PCs.

    Del servidor Linux para atrás, no pasa nada pues lo tengo correctamente configurado y funciona.

    Pero el router no me deja acceder al servidor linux de fuera ahacia adentro, por mas filtros y mapeados que le he creado.

    Resulta que tengo las ipfiltering rules configuradas de tal manera:

    1 inbound deny any IP MASK tcp any_port equal_to_80

    2 inbound deny any IP MASK tcp any_port equal_to_21

    3 inbound deny any IP MASK tcp any_port equal_to_23

    4 inbound deny any IP MASK tcp any_port equal_to_139

    10 inbound permit any all

    (A mi parecer devo cerrar el 80 pues es el servicio que se me abre desde internet cuando intento entrar a la dirección www, no?)

    Tb tengo activado el NAPT con el mapeado:

    tcp 80/http DIRECCION_IP_LOCAL_LINUX

    En el Server Port Mapping no tengo ninguna selección hecha.

    ¿¿¿Alguien me puede dar una solución para no hacer accesible el servicio administrativo del router desde internet pero que si que me permita la redireccion del puerto 80 a una direccion local???

    NOTA: como ya digo he probado casi todo, HELP PLEASE

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      BocaDePez BocaDePez
      6

      hola, espero que esto te valga. Dices que tienes el apache…

      hola, espero que esto te valga.
      Dices que tienes el apache instalado en tu ordenata, Prueva meter en tu carpeta www que creastes para el apache un index.html(una pagina de vienvenida poe ejemplo) y si el httpconfig del apache lo tienes configurado pues te debe de funcionar y cuando llamen por http://tu ip pjblica. les saldra tu pagina de inicio y no tu router.
      Un saludo

    • Cerrado

      BocaDePez BocaDePez
      6

      bien ... parece que empieza a funcionar 1er PASO ====== la…

      bien ... parece que empieza a funcionar
      1er PASO
      ======
      la configuracion correcta es:

      multipuesto, con los servicios :

      IPFILTERING RULES
      1 inbound deny any IP MASK tcp any_port equal_to_21
      2 inbound deny any IP MASK tcp any_port equal_to_23
      3 inbound deny any IP MASK tcp any_port equal_to_139
      10 inbound permit any all
      (denegación de entradas a los puertos ftp, telnet y netbios)

      NAPT
      tcp 80/http dirección_IP_local
      tcp 443/ssl dirección_IP_local
      (redireccion de los puertos 80 y 443 hacia el servidor local linux)

      (ir añadiendo sugerencias para las ipfiletring rules, gracias)
      Saludos

        • Cerrado

          BocaDePez BocaDePez
          6

          por medio del interface web, no podemos configurar la iprules…

          por medio del interface web, no podemos configurar la iprules correctamente, se ha de emplear un telnet.
          Pero:
          ¿Cual es el comando correcto para esta regla ICMP?

          • Cerrado

            6
            vamos al menos yo lo hice por el configurador, y la regla me…

            vamos al menos yo lo hice por el configurador, y la regla me quedo asi:

            inbound deny any -- any -- icmp echo

            No pongas icmp all, pq entonces tampoco puedes hacer pings hacia fuera, (aparte de capar los otros tipos de icmp, si te interesa capar alguno hazlo)

        • Cerrado

          BocaDePez BocaDePez
          6

          si q funciona Max, pero por ahora voy a tenerlo rodando una…

          si q funciona Max, pero por ahora voy a tenerlo rodando una semana con el firewall cerrado para ir añadiendo los patchs para resolver los puñeteros xploits.
          Oye, añadí tb la regla antiping, se me quedo asi:
          1 inbound deny any any icmp all
          Por la sintaxis de las otras reglas me parece que deberia modificar el segundo any por la dirección de internet, no?

          Tu como lo has hecho?

          Saludos

    • Cerrado

      Creo que tu problema no es que tengas mal configurado el…

      Creo que tu problema no es que tengas mal configurado el router, es mas, creo q está perfecto el mapeo del puerto 80 hacia tu ip local, pero te hago esta pregunta:

      Al acceder a tu web desde donde accedes, desde LAN?

      Te digo esto pq si pones el dominio en tu explorador en LAN se chocará con el router y sólo verás a éste.

      Recomendación: Prueba a poner tu dominio desde otro ordenador q no esté enganchado al dicho router.

      Saludos.

      • Cerrado

        BocaDePez BocaDePez
        6

        Si, lo estaba probando siempre en modo local y claro tiene la…

        Si, lo estaba probando siempre en modo local y claro tiene la movida de q aunque pongas la ip estatica (internet) siempre te sale el configurador http del router, cosa q al principio moskeaba, pero ya hice las pruebas desde fuera y no accedo al configurador, pues el router mapea la dirección como WAN como externa y no como interna.

        El tema esta en que no se si devo activar los filtros y el NAPT a la vez. (esta claro q no devo activar un filtro contra el 80)
        Como bien dice MAX, si tapo el 80 en teoria tapo la entrada http, pero tb se puede encaminar el puerto http hacia uno semejante o convertir la conexión en una ssl (puerto 443) y hacer que el dns de internic o del proveedor q tengamos apunte hacia la ip en ese puerto o hacia la que hallamos elegido.

        Gracias MAX y RISKY
        Saludos