Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
127 lecturas y 3 respuestas
  • Cerrado

    Red local / NAPT / Servidor dentro / DNS

    Muy buenas. Tengo una red local, abierta a internet a través de un SS5660 con NAPT (sin DHCP). Bien, uno de los equipos se utiliza de servidor de varios elementos (correo, web, irc). A mi ip publica tengo asociada debidamente mi dominio.com. EL PROBLEMA ES

    No puedo usar ese nombre.com DENTRO de la red local

    Es decir, en cualquier parte del planeta, quien ponga http://www.midominio.com le sale mi apache correctamente, pero DESDE DENTRO DE LA LAN (donde tengo ips 192.168.0.2 - 12) No es asi. Es un problema de la resolución de nombres

    ¿Alguién tiene idea de cómo solucionarlo?
    P.D Los sistemas son todos Windows.

    Muchas gracias anticipadamente

    Andres Bernal

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      Es cierto.! Cree un lmhosts y ahora funciona!!! Y también (…

      Es cierto.! Cree un lmhosts y ahora funciona!!! Y también ( :-o es decoña, tras meses, dos soluciones en 15 minutos ) usando un proxy de la WAN. (configurando el navegador para usar ese proxy remoto). Así también funciona.

      ¡¡jajaja!!!

      Muchas gracias

      • Cerrado

        tienes un servidor dns en tu lan? y lo estás usando? ten en…

        tienes un servidor dns en tu lan? y lo estás usando? ten en cuenta que...
        si tu servidor web está en tu lan, y tienes tu router redireccionado con el puerto correspondiente a tu servidor, el dominio y demás lo tienes dado de alta. Si tu usas una dns pública (la de tu proveedor) cuando el dns de tu proveedor te resuelve la ip, apunta a tu ip pública, sin embargo, tu dentro de la lan que el servidor web, pues cuando vas a conectar te dice que nanay, pq intentarías conectarte al router, que no es capaz de redirigirte, con lo que necesitas un servidor dns en tu lan (o atacar directamente la ip del servidor web) o bien, como bien has hecho editar el lmhosts.

        No se si he aclarado algo... peroooo... jejej
        Un saludo.

    • Cerrado

      BocaDePez BocaDePez
      6

      Yo también tenia el mismo problema y lo solucioné poniendo en…

      Yo también tenia el mismo problema y lo solucioné poniendo en el fichero hosts de cada pc la IP local y el nombre del dominio.
      Es decir:

      www.midominio.com 192.168.x.x