Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
485 lecturas y 7 respuestas
  • Recuperar router Xavi 7968 (debrick)

    Buenos dias

    Esta entrada es para pedir ayuda a algun forero.

    Mi problema es el tipico, tras una mala actualizacion de firmware se me quedo muerto el router.

    He realizado el cable serie para conectarme por consola para ver como arranca, y este es el resultado:

    ---------------------------------------------------------------------------------------------------------------------------------------------

    FSB v0.06 PLL w ln p08 zi

    Solos 461x PP boot v1.5

    SDRAM size = 0x1000000

    Processor clock speed 264.0MHz

    Finding flashfs partition...done.

    Found Uncompress/Self extract image:

    UnComp.Length 0x3feb10 Comp.Length 0x130380

    Calling Configure_NVS_FromFile.

    LZMA 4.05

    Quantum v1.01

    Phys region /region/stung-sdram start @ 0xc00000, end @ 0x1000000, alignment 0x100000

    Allocatable memory starts @ 0x52cd00, end @ 0xc00000

    No, or invalid, configuration information in EEPROM - trying FLASH

    Valid configuration (size 64)

    DSL gateway version 10.0.1.56 (19th April 2007)

    BSP: Solos 4610 RD

    CSP: Solos 461x CSP v1.0

    Copyright (c) 2004 Conexant Systems Ltd.

    Entering crypto process.

    Base address of STUNG memory -> '0xc00000'

    Base address of STUNG memory -> '0xc00000'

    LrLrLr

    Œ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒr

    Œ2

    Œ2Lr

    Œ2

    ²N¾2B²BNNÌL2'N¼

    ²2r'¾Œ°2LL''°LL

    Œ2Lr

    Œ2

    Œ2Lr

    Œ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2LŒ2

    LŒ2LŒ2LŒrLrLrŒ²Â2ròNN>

    ²2r'¾ÌŒBòN|ŽBòN¾>

    Œ¼2NNÂ'¼Ì

    Œ°2NNÂ'¼

    ¾~Œ|²ÂNŒ¼BB²N¾B²¼ÌNN

    ¼2¾Br²¼LrLr

    ²2r'¾ÌŒBòN|ŽBòN¾>

    BL~¼°²L€r

    Œ<|LL

    LBò¼

    ¼Œ2N¾2B2Br

    Œ°2LL''°Ì

    Œ°2NNÂ'¼

    ¾~Œ|²ÂNŒ¼BB²N¾B²¼ÌNN

    ¼2¾Br²¼LrLrLr

    --------------------------------------------------------------------------------------------------------------------------------------------------------

    Como se puede ver, apartir de la linea "Base address of STUNG memory -> '0xc00000'" salen caracteres aleatorios y se cuelga el router. si no estoy confundido, entiendo que lo que intenta cargar en la direccion 0xc00000 es la imagen del firmware

    Comentar que he configurando manualmente la tarjeta de red con direccion IP 192.168.1.10, mascara 255.255.255.0 y puerta de enlace 192.168.1.1.

    Si detengo el arranque y entro en la consola, si conservo conectividad por lan, pero si lo dejo correr hasta que se cuelga, no hay conectividad lan, como si hubiera desconectado el cable fisicamente ( repito que todo esto con los parametros lan configurados manualmente.

    En ningun momento he conseguido respuesta de ping en 192.168.1.1.

    El sistema operativo es Xp sin antivitus ni firewal (instalacion limpia)

    Tengo el ultimo firmware para el router, pero esta comprimido en formato *.tar (que es el formato por defecto para actualizar este router desde el navegador), dentro del archivo tar hay un monton de archivos.

    imm.io/gc9U

    Se podria insntalar el firmware por consola serie?

    Se podria instalar el firmware con el comando netboot ?

    Se podria instalar el firmware con el comando xmodem ?

    Supongo que tendria que ser con un achivo tipo *bin (el *.tar no es valido)

    Habria que compilar el *.tar para pasarlo a *.bin ?

    si alguien me puede facilitar el *.bin y ayudarme a gravarlo en el router se lo agradeceria.

    saludos

    Este tema lleva más de 6 meses inactivo. Es recomendable que abras un nuevo tema para retomar la conversación.