Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra/Cable

Puertos en Thomsom TWG870

BocaDePez
BocaDePez

Hola,

Tengo dos equipos linux tras dicho router y quiero configurar una redirección al ssh.

En el router configuro la redirección 2222 al primero y 3333 al segundo.
2222 -> 192.168.0.100:22

3333 -> 192.168.0.101:22

Uno funciona y el otro no. Cambiando la boca del router el comportamiento es el mismo: Dónde está equipo1 pongo equipo2 y viceversa.

Si me conecto a equipo2 (192.168.0.101) puedo hacer ssh a equipo1 (192.168.0.100).

¿Alguien sabe que puede estar sucediendo?
¿Alguna herramienta para analizar lo que sucede en el router?

Gracias

BocaDePez
BocaDePez

Disculpar por ir tan al grano.

🗨️ 7
BocaDePez
BocaDePez

No hay nada que disculpar.

No sé si te has fijardo que no nos dices en ningún momento qué redirección es la que funciona y cuál es la que no funciona. :wink:

Una cosa, cuando dices "cambiando la boca el comportamiento es el mismo", ¿qué quieres decir exactamente? ¿que el que no iba sigue sin ir? Sería lo lógico, ya que la redirección es a una IP y no a un puerto. Las MACs y su asociación arp no cambian por intercambiar los cables. Lo raro sería que el que no iba, fuese cambiando la boca del router (salvo que haya otras movidas con VLANes y cortafuegos).

Por cierto, ¿por qué no irías a poder realizar una conexión SSH desde un equipo a otro? Se supone que ya estás dentro de la LAN y no fuera de ella.

🗨️ 6
BocaDePez
BocaDePez

Errata: quiero decir que la redirección NAT en el router es a una IP (y obviamente un puerto TCP/UDP) y no a un puerto físico del switch.

🗨️ 5
BocaDePez
BocaDePez

Hola!
Tienes razón. Disculpa.

Voy a poner un dibujo, espero que ayude.

El host 2 estaba conectado al puerto 2 del switch, y el host 1 estaba conectado al puerto 4 del switch. Y los intercambié.

Los Path en verde son los que me deja. Y el único que está sin marcar, es el que quiero hacer y no me deja.

Desde fuera de la LAN: puedo acceder a IP_PUBLICA:3333 y funcoina
puedo acceder a IP_VPN:22 y funciona

Si me conecto a Host2 (IP_PUBLICA:3333), puedo acceder a 192.168.0.100:22.

Pero no puedo: IP_PUBLICA:2222

He quitado todas las reglas de iptables en host1 y tampoco.

Muchas gracias

🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
BocaDePez
BocaDePez
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
mceds

Yo haría dos comprobaciones básicas, para empezar:

―Verificar, en cada equipo, que el servicio está a la escucha y en el puerto pensado: netstat -nplt
―Irme a un servicio online de NMAP (yo suelo usar el de Online-domain-tools) y "testear" cada uno de los puertos con las opciones:

-Pn -p PUERTO TU_IP