BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

El proceso SPOOLSV consume el 100% de la CPU

poxito

Pues eso es lo que pasa, al iniciar el ordenador el proceso spoolsv se pone con un consumo del 100% de la cpu, el ordenador no llega a colgarse pero esta rozando el limite, tengo que detener el proceso para que el ordenador vaya bien, y normalmente al detenerlo la primera vez se vuelve a ejecutar y tengo que volver a detenerlo, no se si tendra algo que ver, pero al entrar en impresoras e intentar agregar una impresora (ya que la quiero poner por red) me dice que no se puede realizar la operacion, esto lo dice al darle al boton de agregar impresora.
Alguien sabe porque puede ser y que funcion tiene dicho rpoceso?
Por si sirve de algo tengo el win xp home edition y como antivirus el bit defender 9, y no me ha detectado nignun virus, no se si hace falta mas informacion.

Espero alguna respuesta, gracias de antemano.

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
Estherilla

Bueno, yo como soy una chica tan hacendosa, con urgencia me iría a alguna página de esas donde te comprueban el ordenador online gratuitamente, como la de www.pandasoftware.es, y le pasaría un escaneado a ver. De todas formas, sería buena idea que instalaras el Ad-Aware de Lavasoft también, y le dieras otra pasadita con eso. Al final, con tantas pasaditas, el disco duro se te va a quedar como los chorros del oro.

¿Tu spoolsv.exe está en la carpeta Windows/System32? Porque si es así, puede que todo vaya bien. Pero si lo tienes en cualquier otro lado, mal asunto.

Es lo primero que se me ocurre. Mantenme informada. La experiencia me ha enseñado a no confiar nunca en un solo anti-virus.

Un beso (con precauciones, por si acaso me vayas a pegar algo).
Esther.

ZOTON

El proceso Spoolsv es propio de windows, pero también puede ser cosa de un troyano. Pásale alguna herramienta como el adware o el spybot.
Si parece limpio, prueba desinstalando todas las impresoras.

🗨️ 6
poxito

Estoy pasando el panda online y despues pasare el spyboy, pero me temo que no va a aperecer nada raro, al entrar en panel de control, en impresoras y faxes deberian de salirme dos impresoras virtuales, la del office y la del acrobat, pero no sale ninguna, antes tenia tambien una hp que estaba en red, pero como formatee el otro ordenador pues tuve que eliminarla para volver a instalarla de nuevo, pero ahi ha sido cuando ha venido el problema,ya ahora no sale ninguna impresora en la carpeta impresoras, y al darle a agregar imprsora me sale un cuadro de dialogo diciendo que no se puede completar la operacion.

He mirado en la carpeta system 32 y esta el archivo spoolsv, tabien he visto que hay una carpeta que pone spool, hay alguna cosa mas que pueda hacer? borrar el contenido de la carpeta spool y que sea lo que dios quiera? jajaja.

Gracias por responder, un saludo.

🗨️ 5
poxito

Se me olvidaba, en la carpeta spool me sale una carpeta que se llama drivers y aparece la mano como que es una carpeta compartida, otra que pone printers y otra que se llama prtprocs.
En esta ruta C:\WINDOWS\system32\spool\drivers\w32x86\3 si no me equivoco esta instalada la impresora HP que en teoria borre, estoy pensando en borrarla, a ver que pasa, alguna sugerencia...
Lo dicho, gracias.

🗨️ 4
ZOTON

He leído un caso similar también sobre una HP.
Puedes probar con la herramienta de microsoft Cleanspl.exe, que trae el Resource Kit (bájatelo desde AQUI)
Otra opción sería empezar a trastear el registro.

JoeDalton

Hay drivers de impresora no diseñados para el sistema operativo (o que están mal hechos) y hacen que el proceso del spool se ponga al 100% y/o empiece a consumir memoria.

Prueba a reiniciarlo con: net stop spooler y a continuación net start spooler.

De todas formas busca un driver actualizado.

🗨️ 1
poxito
GarabaTTo

Asegurate de no tener archivos pendientes de imprimirse en alguna impresora virtual. Creo que office ,adobe acrobat y algunos programas más las "instalan". Podrían estar mandando continuamente "orden" de imprimir, error, orden de imprimir, error, orden...

Guiller

Para el servicio spooler, o cola de impresion o algo asi en español (Mi window sesta en ingles)

Borar los fichero que tengas en c:\windows\system32\spool y \spool\printers\ (solo los ficheros, no los directorios)
El causante sera un documento que el driver no consigue imprimir

arranca el servicio otra vez y ya tendras impresoras
Si vuelve a pasar, actualiza el driver de las impresoras

🗨️ 2
poxito

No habia visto estas respuestas antes de poner el mensaje anterior, voy a probar lo que dices.
gracias

🗨️ 1
tecnicodavid

tambien revisa si tienes el office 2003, porque creo recordar que el office 2003 daba problemas con el spoolsv.exe