BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL

Problemas al transmitir imagenes desde una camIP al servidor FTP del router Huawei 556a de Vodafone

zapata123

Tengo un par de cámaras IP conectadas mediante WIFI al router. Estas cámaras envíaban las imágenes a un servidor FTP de la web sin problemas. He decidido dar de baja mi suscripción con ese servidor y configurar el que viene con el router, pero aquí viene el problema: las cámaras envían datos al servidor FTP pero no envían la imagen, crean una carpeta con la fecha del día, dentro de esta carpeta crean varias con la hora del día correspondiente pero dentro de las carpetas de la hora tendrían que estar los archivos de las imagenes y resulta que están vacías.

He instalado el cliente FireZilla en el pc y no hay ningún problema en envíar imagenes a la memoria USB mediante FTP.

Me estoy volviendo loco y no encuentro la solución.

Alguien podría echarme una mano??

Gracias por vuestra atención

BocaDePez
BocaDePez

Una explicación plausible sería que las cámaras enviasen mal los datos por FTP. Otra que el servidor FTP del router funcionase mal, pero sería extraño ya que se crean esas carpetas vacías que comentas, así que al menos el servicio está levantado y reconoce el comando MKDIR.

Para poder salir de dudas, lo primero que te aconsejo es que instales un servidor FTP en tu ordenador local y reprogrames la cámara para que use ese servidor, a ver si se comporta igual o no. Así se descarta alguna configuración de la cámara que pueda llevar a no subir la imagen.

🗨️ 1
BocaDePez
BocaDePez

Muchas gracias BocaDePez, tendré en cuenta tus consejos y ya contaré.

BocaDePez
BocaDePez

Si con Filezilla puedes subir bien las imágenes a mano desde el PC, el FTP funciona. Pero deberías fijarte cómo lo está haciendo exactamente.

No recuerdo muy bien si en Filezilla aparece por defecto el log de todos los comandos a bajo nivel que se están enviando al servidor. Por si acaso no salen, actívalo en las preferencias. Lo que sí hay es la posibilidad de forzar uno de los 2 modos de operación del protocolo FTP: o el activo o el pasivo. Conecta forzando uno de ellos y luego el otro, a ver cómo se está comportando el servidor FTP del router.

Si en uno de los dos modos no funciona, podría ser una explicación de por qué las cámaras no llegan a enviar datos. Supongo que el router estará medio capado para poder tener un log del servicio FTP y no se podrá saber a ciencia cierta. También desconozco si las cámaras pueden alternar entre FTP activo y pasivo.

BocaDePez
BocaDePez

Después de hacer todo lo que me indicas sigue sin funcionar y lo peor es que no sé muy bien por qué. He montado un servidor Filezilla en el pc y he dirigido ahí el tráfico de la cam. El resultado es que funciona bien. A continuación un extracto del log en el que no estan las lineas de creación de los directorios para resumir:

(000158)07/04/2016 17:07:48 - (not logged in) (192.168.0.196)> USER anonimo

(000158)07/04/2016 17:07:48 - (not logged in) (192.168.0.196)> 331 Password required for anonimo

(000158)07/04/2016 17:07:48 - (not logged in) (192.168.0.196)> PASS ******

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> 230 Logged on

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> TYPE I

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> 200 Type set to I

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> pwd

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> 257 "/" is current directory.

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> CWD /USBDisk_1/04.07.2016/17

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> 250 CWD successful. "/USBDisk_1/04.07.2016/17" is current directory.

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> CWD /USBDisk_1/04.07.2016/17

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> 250 CWD successful. "/USBDisk_1/04.07.2016/17" is current directory.

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> PASV

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> 227 Entering Passive Mode (192,168,0,5,41,176)

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> STOR Motion_2016.04.07_17_08_17.jpg

(000158)07/04/2016 17:07:48 - anonimo (192.168.0.196)> 150 Opening data channel for file upload to server of "/USBDisk_1/04.07.2016/17/Motion_2016.04.07_17_08_17.jpg"

(000158)07/04/2016 17:07:49 - anonimo (192.168.0.196)> disconnected..

A continuación monto un cliente FTP con Filezilla tambien en el pc y envío al router los mismos comandos que envía la cam, y no funciona. Un resumen del log:

Estado: Directory listing of "/USBDisk_1/04.09.2016/10" successful

Comando: pwd

Respuesta: 257 "/USBDisk_1/04.09.2016/10" is the current working directory.

Comando: PASV

Respuesta: 227 Entering Passive Mode (192,168,0,1,9,132)

Comando: STOR fzdefaults.xml.example

Error: Connection timed out after 20 seconds of inactivity

Estado: Desconectado del servidor

Estado: Conectando a 192.168.0.1:21...

Estado: Conexión establecida, esperando el mensaje de bienvenida...

Estado: Servidor no seguro, no soporta FTP sobre TLS.

Estado: Server does not support non-ASCII characters.

Estado: Logged in

Comando: STOR fzdefaults.xml.example

Respuesta: 553 Error: mapped /fzdefaults.xml.example. Only support to create file in USB storage (directory beginning with USBDisk_).

Comando: pwd

Respuesta: 257 "/" is the current working directory.

No sé si parte del problema es que en la raiz de Router no se puede escribir y que de ahí cuelga el disco USBDisk_1, y puede que la cam necesite escribir en ese directorio raiz, no se.......

A ver si se te ocurre algo....

Perdón por el tocho

Un saludo

🗨️ 3
BocaDePez
BocaDePez

Como aportas logs incompletos, no sabemos a qué viene lo de escribir el fichero "fzdefaults.xml.example" en la raíz. Pero lo que sí está claro es que el router no te está ofreciendo un entorno FTP con jaula "chroot" que defina el límite virtual a partir del que se escribe.

¿Cuál es la razón de querer escribir a un pendrive pinchado en el router? ¿El de no tener un PC funcionando en esa LAN las 24 horas del día?

vukits

CWD /USBDisk_1/04.07.2016/17

hmm... ahi debe de haber cierto problema..

Por cierto, ¿qué modelo y versión de camara es?

WiLZy
1

Prueba sin enviar el PASV antes de subir el fichero.