Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
69 lecturas y 5 respuestas
  • Cerrado

    [Editado 2/10/03 17:54]

    Problemas con FTP - Desesperacion!

    Hola:

    Hace algun tiempo contrate un servidor virtual privado, donde almaceno algunas webs. No he tenido nunca ningun problema... hasta ahora.

    Resulta que ahora intento conectar al FTP (como siempre) y tarda de 5 a 6 minutos en mostrar la lista de directorios. Si que llega a conectar, a aceptar el login y password, pero se queda parado en "getting file list" durante unos 6 minutos. Despues, puedes subir y bajar ficheros sin problemas, mientras no cambies de directorio, porque si no vuelve a esperar 6 minutos.

    Es desesperante, porque lo he provado todo, o casi todo.
    Modo activo, pasivo... he actualizado la version del firmware del router (3Com officeconnect812), he quitado firewall, he provado con otro PC, win98, winME, winXP,... hasta he provado con el MacOs en el mac.
    Mas de 7 clientes de FTP provados.
    Lo han provado desde Barcelona, Valencia, Castellon, Madrid... a todos les pasa lo mismo. A todos los que vayan desde una ADSL, porque desde CABLE (ONO) funcionaba a las mil maravillas.

    Es muy frustrante, ya que mis temores se dirigen a Telefonica como culpable. Tambien lo provaron desde una conexion Ya.com, pero vamos, eso pasa por Telefonica.

    Esta claro que el problema no es el servidor en si, porque he alquilado otro a otra compañia y me pasa lo mismo. Eso si, la version del servidor FTP es la misma (la que viene con el PLESK6 y cPanel).

    He hecho un tracert a la ip:
    =======================================
    C:\>tracert 69.57.148.19

    Traza a la dirección apollo.premierservers.com [69.57.148.19]
    sobre un máximo de 30 saltos:

    1
    2 263 ms 190 ms 76 ms 66.Red-217-127174.pooles.rima-tde.net [217.127.
    174.66]
    3 68 ms 71 ms 71 ms 148.Red-80-58-37.pooles.rima-tde.net [80.58.37.1
    48]
    4 68 ms 71 ms 71 ms 106.Red-80-58-72.pooles.rima-tde.net [80.58.72.1
    06]
    5 * * * Tiempo de espera agotado para esta solicitud.
    6 71 ms 71 ms 69 ms GE4-1-0-0-grtmadpe1.ri.telefonica-data.net [213.
    140.50.145]
    7 90 ms 94 ms 94 ms So7-0-0-0-grtparix1.ri.telefonica-data.net [213.
    140.36.146]
    8 178 ms 174 ms 172 ms P11-0-grtwaspx1.ri.telefonica-data.net [213.140.
    36.58]
    9 178 ms 178 ms 175 ms abovenet-3-2-grtwaspx1.ri.telefonica-data.net [2
    13.140.39.202]
    10 175 ms 175 ms 175 ms so-7-0-0.cr1.iad1.us.above.net [216.200.127.9]
    11 178 ms 175 ms 175 ms so-1-0-0.cr1.dca2.us.above.net [208.184.233.125]

    12 188 ms 187 ms 187 ms pos3-0.er1.atl4.us.above.net [208.185.0.230]
    13 183 ms 188 ms 185 ms pos15-0.er1.atl4.us.above.net [208.185.0.217]
    14 198 ms 203 ms 198 ms so-3-0-0.mpr1.iah1.us.above.net [64.125.31.25]
    15 199 ms 200 ms 200 ms 216.200.251.29.ev1.net [216.200.251.29]
    16 205 ms 208 ms 206 ms 207.218.245.42
    17 210 ms 211 ms 221 ms apollo.premierservers.com [69.57.148.19]

    Traza completa.
    =======================================

    En el salto 5 siempre da timeout... y es por donde yo creo que pueda venir el problema.

    Por si alguien necesita mas datos:
    La version del FTP remoto es ProFTPD 1.2.7 Server (ProFTPD)
    La IP es: 69.57.148.19

    Ya no se que mas pruebas hacer :'(
    Si se os ocurre algo, por favor, ayudadme.

    Muchas gracias por adelantado.

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      Hola: Pues para informaros que he provado muchas cosas con el…

      Hola:

      Pues para informaros que he provado muchas cosas con el problema del FTP.

      He estado leyendo que no es un problema exclusivamente mio, ya que afecta a todos los que tengan un hosting con panel de control Plesk6 (u otro que utilice el ProFTPD) y un router 3Com.
      Es una incompatibilidad entre el ProFTPD y el NAT de 3Com.
      En monopuesto si que funciona a las mil maravillas, y con un SpeedStream 5660 en multipuesto tambien funciona bien.

      Intente reportar un parte de Bug a proftpd.org pero no pude, ya que no soy un experto y ciertamente no se en que punto falla. Si alguien puede hacerlo, yo le proporcionare una cuenta de FTP para que pueda hacer las pruebas pertinentes.

      De momento, mantengo el 3Com en multipuesto para la navegacion normal... y cuando quiero acceder al FTP cambio el router por el SS5660 y subo lo que tenga que subir.
      Esto espero que sea temporal.
      De todas formas, estoy abierto a cualquier posible solucion para configurar correctamente el 3Com.

      Saludos y muchas gracias :)

    • Cerrado

      se filtra tráfico (seguramente icmp).Suele pasar, pero no…

      se filtra tráfico (seguramente icmp).Suele pasar, pero no creo que el problema del servidor FTP venga de ahi

      Saludos 8)

    • Cerrado

      BocaDePez BocaDePez
      6

      Lo lógico sería configurar el ProFTPD con las siguientes…

      Lo lógico sería configurar el ProFTPD con las siguientes opciones:

      UseReverseDNS off
      IdentLookups off

      Para mas info ProFTPD faq: (http://pdd.sourceforge.net/faq/proftpdfaq-4.html).

      Un saludo.

      • Cerrado

        Hola Primero que nada agradeceros que me hayais ayudado. Creo…

        Hola
        Primero que nada agradeceros que me hayais ayudado.
        Creo que ya se donde esta el problema.

        Se ve que es una incompatibilidad del NAT de 3Com con el ProFTPD. He leido en algun foro que se trata de esto.

        Prove a poner el router en monopuesto y, voilá, ya funciona perfectamente.

        Ahora la cuestion es como poder utilizar estos FTPs sin tener que estar en monopuesto, ya que tengo una red interna y no me gustaria tener que poner un proxy.

        Si a alguien se le ocurre una posible solucion, se lo agradeceria mucho.
        Tengo el firmware actualizado a la 2.1.2

        De necesitar un proxy, ¿cual me recomendais?

        Gracias de antemano.
        Un Saludo

      • Cerrado

        Wenas: Estoy esperando respuesta del admin del server para…

        Wenas:
        Estoy esperando respuesta del admin del server para ver como estaban puestos esos valores.
        Ya os comentare si era ese el problema

        Muchisimas gracias :)