Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
89 lecturas y 8 respuestas
  • Propuesto para mover a Redes

    BocaDePez BocaDePez
    6

    Problemas con la configuración del router Wireless de telefóncia (Comtrend CT536+)

    Hola a tod@s,

    acabo de recibir el router Wireless de Telefónica y ya lo tengo funcionando a pleno rendimeiento, salvo por un par de detalles.

    El caso es que quiero configurar uno de mis ordenadores (el sobremesa) quiero configurarolo como servidor Web, FTP y SSH (está funcionando con una Ubuntu). El caso es que hago los cambios pertinentes con la NAT, y "pasa" de mi olímpicamente. Si accedo desde fuera, puedo acceder a todos los servicios, pero si trato de acceder desde dentro, me resulta imposible.

    Os dejo el ejemplo del caso del SSH:

    dlopez@Obiwan:~$ ssh -Cl dlopez tocomoxo.homeip.net
    Write failed: Connection reset by peer
    dlopez@Obiwan:~$ ssh -Cl al059164 lynx.uji.es
    al059164@lynx.uji.es's password:
    ************************************************************************
    al059164@lynx ~$ ssh -Cl dlopez tocomoxo.homeip.net
    dlopez@tocomoxo.homeip.net's password:
    Linux Obiwan 2.6.27-4-generic #1 SMP Wed Sep 24 01:30:51 UTC 2008 i686

    [...]

    Last login: Tue Sep 30 19:15:53 2008 from lynx.uji.es
    dlopez@Obiwan:~$

    Valga decir que en este caso "Obiwan" es el propio servidor (como habréis podido comprobar).

    En el resto de servicios el resultado es similar. Sé que hay soluciones alternativas, que resolverían mi problema como acceder con la IP local, asignar los nombres a las IP's localmente, pero me parecen chapuzas para ocultar un problema que está en otra parte.

    Un saludo, y gracias por vuestra atención :)

    Este tema lleva más de 6 meses inactivo. Es recomendable que abras un nuevo tema para retomar la conversación.
    1
    • ¿Es posible que sea porque el servidor debe tener una…

      ¿Es posible que sea porque el servidor debe tener una dirección IP y pilla la externa?, es posible que si accedes desde dentro de tu red local a la IP de Intranet el servidor no te conteste porque puede creer que no va hacia él.

      De todas formas te mando este post al foro de Redes porque no tiene nada que ver con Telefónica.

      • BocaDePez BocaDePez
        6

        Tengo configurada la nata para que envie todo lo que vaya al…

        Tengo configurada la nata para que envie todo lo que vaya al puerto 22 (en el caso del SSH), para que lo envie al 2222 de la ip local del servidor, que es dónde tengo configurado el servidor ssh. Osea, que no creo que vayan por ahí los tiros, y si se lo atribuyo a la red de Telefónica. A no ser que alguien me demuestre lo contrario :S

        • Pero igual el servidor se da cuenta de su IP pública y todo…

          Pero igual el servidor se da cuenta de su IP pública y todo lo que no vaya a esa no lo reconoce. Me pasó con un servidor de correo donde trabajaba antes, le configuré la IP estática y si se accedía al puerto de correo desde dentro de la intranet no contestaba.

          Y por lo que dices, ¿no te llegan bien las conexiones desde fuera y mal las de dentro de la intranet?, es que por eso te lo he movido a otro sitio, la red de Telefónica sí que te iba y la intranet no (eso me ha parecido entender).

          • BocaDePez BocaDePez
            6
            La red interna me vá perfecta. El fallo es cuando trato de…

            La red interna me vá perfecta. El fallo es cuando trato de acceder desde la red interna a la IP externa.

            dlopez@Skywalker:~$ ssh -Cl dlopez tocomoxo.homeip.net
            ssh_exchange_identification: Connection closed by remote host
            dlopez@Skywalker:~$

            Skywalker es mi portátil, que está conectado a la red interna del que tengo como servidor. Los ordenadores no "saben" detrás de que IP están, todo vá a base de redirecciones de NAT que realiza el dichoso router.

            Vaya por delante que antes, con Ya.com si que me funcionaba el "negocio". Osea, que o bien es cosa de la configuración de la red de Telefónica, o del nuevo router.

            Saludos, y gracias por tu atención :)

            • Yo, tanto antes en Ono como ahora en Telefónica, si intentaba…

              Yo, tanto antes en Ono como ahora en Telefónica, si intentaba acceder a mi IP externa desde dentro no podía, es decir, si monto un servidor dentro de la intranet con la IP 80.58.25.69 (me lo acabo de inventar) externa e intento acceder desde dentro de la intranet a esa IP, redireccionados los puertos, no puedo entrar.

              Me extraña que desde ya.com sí que pudieras pero cosas más raras se han visto. A ver si alguien te da una ayuda pero no sé... ¿has probado a activar el DMZ a la IP de tu servidor?