BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Raspberry no conecta a internet en un Mikrotik

Solospam

Desde hace unos días estoy teniendo problemas con mi Raspberry, aunque realmente acabo de comprobar que los problemas los tengo con el router, un Mikrotik.

Tengo 2 Mikrotik (A) 172.16.1.1 y (B) 192.168.1.1

El router A es mi router principal , con VPN configuración bastante elaborada. Este router está conectado con el B mediante un túnel EoIP.

Desde hace unos días estoy teniendo problemas con mi Raspberry (172.16.1.70) ya que no me conecta a internet. Tras haber revisado todo una y otra vez y ver que todo está correcto hago la siguiente prueba, cambio la IP a rango del router B, y cambio PC a rango de router B y cual es mi sorpresa que en el router B la raspi si tiene internet y funciona adecuadamente mientras que en el router A no hay forma de que funcione con internet, he cambiado de 172.168.1.70 a otra dirección pero nada.

La raspi es capaz de resolver 172.168.1.5 pero no resuelve 172.16.1.1

¿Alguna idea de que puede estar pasando?

imagen.webp

PD, desde mi sobremesa tengo ping a la raspi pero desde el Mikrotik no

imagen.webp

Datos obtenidos desde el router B

imagen.webp
BocaDePez
BocaDePez

Evidentemente tienes un problema de concepto a la hora de enrutar.

O nos haces un dibujo sobre como estan conectados y adjuntas las configuraciones de los mkt, o no se te va a poder ayudar.

🗨️ 1
Solospam

En principio ya está solucionado.

He tirado el túnel EoIP y he comprobado que de esa forma la rpi tenía acceso a internet; lo he levantado y la raspi carece de acceso a la web.

Hoy he deshecho el túnel y lo he reconfigurado vía web (por fin funciona la VPN wireguard) y ahora la rpi tiene acceso a la web y yo tengo acceso a los recursos del lado B

Voy a dejarlo unos día con un ojo puesto a ver como respira…