Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Cablemodem HFC

Problemas de conexion con ONO bajo Linux

ParticleHunter

Hola a tod@s,

Os escribo por primera vez en este foro para haceros una consulta de relativa urgencia.

Vereis, tengo un amigo viviendo en Paterna (Valencia) con una conexion de 1 mega de ONO, el modem que se le suministro para la conexion es un Motorola SurfBoard 4200, que no tiene soporte para la conexion USB bajo linux (me parece casi una bajeza teniendo en cuenta la reputacion del fabricante, pero bueno...).

El caso es que despues de intentar realizar la conexion 'por si cuela por un casual del destino' y, efectivamente, ver que no funciona, le recomende que instalara un adaptador ethernet en su PC (la tarjeta de red de toda la vida, vamos) para realizar la conexion directamente sobre el puerto ethernet del modem.

El caso es que mi amigo, ademas por recomendacion mia, llamo a ONO para solicitar datos sobre la conexion como las IPs o cualquier otro dato que necesitara para poder conectarse... le dijeron que no necesitaba nada, que solo necesitaba poner la asignacion de IP de forma automatica (DHCP para los amigos).

Pues bien, despues de configurar bajo Linux (escritorio GNOME 2.10, distribucion Ubuntu Hoary 5.04 para x86) los adaptadores ethernet, e ir probandolos todos bajo pila DHCP sin ningun exito, empiezo a quedarme sin opciones, mi ultima recomendacion por ahora ha sido que mi amigo vuelva a llamar a ONO y le diga que sigue existiendo el problema...

Mi pensamiento es el siguiente: segun mi amigo, cuando enchufa bajo Windows el modem con USB este conecta solo a internet, luego mi razonamiento es que:

1. el modem ya tiene almacenados en su configuracion interna los datos de conexion, solo necesitando una IP de la pila DHCP de ONO para poder tener salida a internet.

2. el modem en si deberia tener una direccion IP interna, la de su 'propia' red local, aparte de una IP privada o el identificador que use para conectar con el nodo de ONO, de esta forma pudiendo existir y posteriormente habilitar el NAT (suponiendo que no este configurado, pues si esta activo entonces seria mucho mas facil)

Pues bien... lo que yo pienso en este caso es que mi amigo necesitaria saber cual es la direccion IP interna del modem, para poder de esta forma configurar el adaptador ethernet, para que, en lugar de usar DHCP, si suponemos que el modem tiene la capacidad de hacer bridging, solo tenga que pasarle una IP al adaptador que este en el mismo segmento de red que el modem, una mascara correspondiente y como puerta de enlace ponerle justamente la IP del modem.

Personalmente, no se si este procedimiento funcionara, pero estoy intentando dar con la solucion al problema de mi amigo, si pudierais orientarme un poco os lo agradeceria ;)

Gracias de antemano y un saludo cordial,

Julio Meca
julio25@telefonica.net
particlehunter@hotmail.com

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
BocaDePez
BocaDePez

A ver, yo uso SuSE 9.2 y tuve un problema similar. No creo que tenga nada que ver, pero por si te puede ayudar.

Para mi conexión a Wanadoo ADSL uso un modem-router de 1 puerto conectado a 1 router wifi que me da conexión wireless. Una vez configurado todo perfectamente podía acceder a la página de configuración del router wifi marcando en el explorador la ip del mismo (192.168.2.1), pareciendo estar todo correcto, pero la conexión no me dejaba pasar de ahí, es decir, no podía acceder ni al modem-router y mucho menos a internet. Era desconcertante, porque parecía un problema del router y no del linux, aunque luego no fue así.

Desesperado, encontré en la red cómo solucionar el problema. Tuve que añadir a /etc/sysconfig/network/ifcfg-----(lo que sea, en mi caso ifcfgwlan0, en tu caso será ifcfgeth0 seguramente) al comienzo del texto las líneas

DHCLIENT_MODIFY_RESOLV_CONF='yes'
DHCLIENT_SET_DEFALULT_ROUTE='yes'

Guardé el archivo y reinicié la red con
/etc/init.d/network restart
y todo funcionó.

Ya digo, no sé si será el mismo problema (es decir, que podías acceder a la configuración del router pero no podías pasar la puerta del mismo y acceder a internet). Pruébalo, a ver qué pasa.

OJO!! CREA COPIA DE SEGURIDAD DEL ARCHIVO DE TEXTO QUE MODIFICAS, POR SI NO ES ESTO PARA VOLVER AL ESTADO DE COMO ESTABAS AL PRINCIPIO.

Por cierto, otra cosa que detecté fue que tardo bastante en acceder a la página de configuración del modem-router (no del router wifi, que carga en el acto), cosa que con windows no sucedía. Si el problema que tienes es que la página no carga, espera un rato hasta que salga o bien la página de configuración del router o bien el mensaje de error.

Si se arregla, comenta cómo lo has hecho.

Un saludo

BocaDePez
BocaDePez

Soy el boca del pez de antes... lo he releido y parece tu amigo sigue con el modem usb que le proporcionó ONO. Con linux lo mejor que puede hacer es conseguirse un modem-router con conexión ethernet y conectarse con DHCP directamente a él. Supongo que ONO le podría proporcionar uno.

Un saludo.

🗨️ 2
ParticleHunter

Hmmm... no creo que esa sea la solucion, tal vez a largo plazo si, pero no se yo si se lo van a dar de gratis y por otro lado no suena muy bien eso de que cada vez que hay un problema se solucione cambiandolo todo

De todas formas estoy seguro de que tiene que haber alguna forma de hacerlo, en cuanto mi amigo se conecte al MSN le pasare las instrucciones que me has dado a ver si eso funciona

Un Saludo ;)

Julio

🗨️ 1
DDrDark

aver segun entiendo por lo de "adaptadores de eth" es que tiene una red interna con una tarjeta de red y otra con el modem? si es eso.. pues la tarjeta de red que este conectadaal cablemodem le activas el dhcp, a la otra la configuras con una ip local y activas el ip route para tener conexion en el otro pc
echo 1 > /proc/sys/net/ipv4/ip_forward

Luego sobre el NAT, los cablemodem no tienen NAT, ni abrir puertos, ni cerrar ni direccionar.

lo he vuelto a releer y creo que entendi bien, si necsitas ayuda me agregas al msn ddrdark@hotmail.com, ya que yo tengo lo mismo montado en un debian, 2 pcs en red local y con salida a internet, uno de los pcs hace de servidor con 2 placas de red

salu2

OnoSpainProblem

Con razon vas perdido.

Lo primero es indicarte que la ip de los motorola es la 192.168.100.1 a la cual puedes acceder 'solo' por el navegador.

Ono por ejemplo corta todos los menus y configuraciones y da igual que accedas al http del modem. Para poder acceder debes resetear el modem DESCONECTADO del cable coaxial.

Ese cable'modem', al igual que muchos otros, tiene 1 ip interna tipo 10.x.x.x y usa 2 MAC una es la HFC MAC y otra la USB MAC.

En el momento conectas la corriente del cable-modem, este adquiere desde el terminal de cable a que ip de tftp (Puerto 69) tiene que ir a recoger el CM, en funcion de su MAC, el fichero de configuracion.
Aqui coge los parametros de bajada, subida, etc y empieza a funcionar.

El cable-modem transmite desde ese momento hacia el exterior y hacia el interior, no hace nada mas, solo transmite.

Si desde el interior (ETH o USB) recibe un paquete de dhcp, transmite el dhcp y lo que le llega lo transmite al interior.

Es decir, la tarjeta de red, adquiere la IP de iNet.

El Motorola SB4200 tambien tiene la posibilidad, de dhcp interno, por lo que si esta configurado, asignara una 192.168.100.11 hasta la 192.168.100.42.

Puedes asignarle sin dhcp una IP a esa ETH que sea 192.168.100.101 con puerta de enlace 192.168.100.1 y con algunos ISP te funcionara. Con ONO da problemas.

Suerte con ONO, que la vas a necesitar.

🗨️ 1
overpeer

Puedes asignarle sin dhcp una IP a esa ETH que sea 192.168.100.101 con puerta de enlace 192.168.100.1 y con algunos ISP te funcionara. Con ONO da problemas.

Imagen original en http://bandaancha.st/img/asunto/14.gif Imagen original en http://bandaancha.st/img/asunto/14.gif Imagen original en http://bandaancha.st/img/asunto/14.gif Imagen original en http://bandaancha.st/img/asunto/14.gif Imagen original en http://bandaancha.st/img/asunto/14.gif Imagen original en http://bandaancha.st/img/asunto/14.gif Imagen original en http://bandaancha.st/img/asunto/14.gif Imagen original en http://bandaancha.st/img/asunto/14.gif Imagen original en http://bandaancha.st/img/asunto/14.gif Imagen original en http://bandaancha.st/img/asunto/14.gif Imagen original en http://bandaancha.st/img/asunto/14.gif Imagen original en http://bandaancha.st/img/asunto/14.gif

"te funcionara"?? el que?? xD

overpeer

- Apaga el cablemodem.
- Dejalo unos minutos apagado.
- Conecta el pc por ethernet al cablemodem.
- Arranca el cablemodem.
- Cuando este sincronizado arrancas el pc.
- Te aseguras de que esta correctamente configurado como DHCP.
- Si haces un ifconfig deberias ver la configuracion IP.

Si no funciona, prueba a cambiar la direccion MAC de la tarjeta de red (a veces funciona con esto xD ). Revisa que el demonio dhcpcd funciona correctamente.

El cablemodem NO PUEDE hacer NAT, el que asigne direcciones IP privadas del rango de su IP de gestion, es una boberia para evitar que si se pierde el sincronismo, los PCs ya no se puedan comunicar entre ellos, por eso les da "otras".

En el cablemodem no hay nada que configurar.

Un saludo.