Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
101 lecturas y 8 respuestas
  • Cerrado

    problemas com cisco 827

    wens, tengo este router y con la adsl de telefonica me funcionaba perfectamente, pero cuando me pasé a jazztel tube que actualizar la IOS (antes tenia la 12.2(4r)-xm2 y ahora tiene la 12.3(5)-t) por que si no no sicronizaba la linea. Desde que le puse esa IOS, me encuentro que a la que hace una hora que está el emule funcionando, el router no contesta ni a los pings ni tampoco puedes conectarte a él por telnet. Cuando te conectas por hyperterminal, ves que empiezan a salir mensajes de error tal que así:

    01:20:48: %SYS-2-MALLOCFAIL: Memory allocation of 65536 bytes failed from 0x8017C0F4, alignment 8
    Pool: Processor Free: 282228 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool

    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8016A2A8 8016BDE4 8017C0F8 8017B32C 8017B0B0 8015F5EC 80163A04
    01:20:48: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat node. No memory available
    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8017B0F8 8015F5EC 80163A04
    01:21:43: %SYS-2-MALLOCFAIL: Memory allocation of 65536 bytes failed from 0x8017C0F4, alignment 8
    Pool: Processor Free: 288344 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool

    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8016A2A8 8016BDE4 8017C0F8 8017B32C 8017B0B0 8015F5EC 80163A04
    01:21:43: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat node. No memory available
    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8017B0F8 8015F5EC 80163A04
    01:21:53: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat node. No memory available
    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8017B0F8 8015F5EC 80163A04
    01:22:03: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat node. No memory available
    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8017B0F8 8015F5EC 80163A04
    01:22:23: %SYS-2-MALLOCFAIL: Memory allocation of 65536 bytes failed from 0x8017C0F4, alignment 8
    Pool: Processor Free: 275060 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool

    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8016A2A8 8016BDE4 8017C0F8 8017B32C 8017B0B0 8015F5EC 80163A04
    01:22:23: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat node. No memory available
    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8017B0F8 8015F5EC 80163A04
    01:22:34: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat node. No memory available
    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8017B0F8 8015F5EC 80163A04
    01:22:50: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat node. No memory available
    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8017B0F8 8015F5EC 80163A04
    01:22:54: %SYS-2-MALLOCFAIL: Memory allocation of 65536 bytes failed from 0x8017C0F4, alignment 8
    Pool: Processor Free: 282068 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool

    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8016A2A8 8016BDE4 8017C0F8 8017B32C 8017B0B0 8015F5EC 80163A04
    01:23:00: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat node. No memory available
    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8017B0F8 8015F5EC 80163A04
    01:40:30: %SYS-2-MALLOCFAIL: Memory allocation of 65536 bytes failed from 0x8017C0F4, alignment 8
    Pool: Processor Free: 388936 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool

    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8016A2A8 8016BDE4 8017C0F8 8017B32C 8017B0B0 8015F5EC 80163A04
    01:40:30: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat node. No memory available
    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8017B0F8 8015F5EC 80163A04
    01:40:40: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat node. No memory available
    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8017B0F8 8015F5EC 80163A04
    01:40:50: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat node. No memory available
    -Process= "Chunk Manager", ipl= 4, pid= 1
    -Traceback= 8017B0F8 8015F5EC 80163A04
    01:41:00: %SYS-2-MALLOCFAIL: Memory allocation of 65536 bytes failed from 0x8017C0F4, alignment 8
    Pool: Processor Free: 383196 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool

    Alguien sabe pq ahora me da estos errores y con la IOS antigua no¿? el router tiene una 8Mb para la ios, 2Mb para el CWRS, 128Kb para la configuración, 1Mb de memoria ram+ una ampliación de 32Mb.

    pq ahora se queda sin memoria para hacer NAT y antes no le pasaba¿?

    Gracias de antemano.

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      visto que nadie ha sido capaz (o no ha querido ) de responder…

      visto que nadie ha sido capaz (o no ha querido ) de responder a esta simple(¿? :-P) pregunta, me la respondo yo mismo :-P

      el problema es un bug reconocido por cisco en algunas de sus IOS. la solución passa por instalar otra IOS en el router, pero esto solo es posible si la pillas por la mula, el bt o te la pasa algun amigo o tienes certificacion oficial de cisco, puesto que un usuario normal no puede acceder a la parte de la web donde estan las IOS para bajarselas.

      la mejor solucion que he encontrado (puesto que no tengo certificación de cisco ni nadie a quien pueda pedirle la IOS) es poner las siguientes lineas:

      ip nat translation timeout 600
      ip nat translation tcp-timeout 600

      que hace esto¿? muy sencillo. Este bug lo que hace es colapsar la memoria de la que dispone el router para almacenar su tabla de NAT. Llega un punto en que hay tantas entradas en la tabla de NAT que no queda más memoria disponible y el router deja de funcionar como dios manda hasta que se le hace un reset (apagar del todo y volver a iniciarlo, no vale el comando reload pq no limpia bien la memoria). Con estas dos lineas lo que hacemos es assignar una caducidad a las entradas de la tabla de NAT de manera que cada entrada caduca a los 10min. (600 seg.) i libera la memoria que estaba ocupando.

      Estos valores són modificables, no se cuales són los más recomendables, pero a mi estos són los que me van bien.

      • Cerrado

        BocaDePez BocaDePez
        6

        Hola. Tengo en la oficina el Router Cisco 820 de un solo…

        Hola.

        Tengo en la oficina el Router Cisco 820 de un solo puerto, pero que además gestiona 4 líneas de teléfono.
        Mi pregunta es como configurarlo para redirigir una serie de puertos a mi IP local, pues por defecto vienen cerrados.

        Saludos y gracias

        • Cerrado

          para abrir puertos tienes que entrar al router por telnet ()…

          para abrir puertos tienes que entrar al router por telnet () telnet [ip del router]) le metes el pass, entras en modo enabled [ena], pones el password de enabled, pones [conf term] para entrar en modo configuración i tecleas:

          ip nat inside source static [tcp|udp] [ip interna de la red] [puerto] interface Dialer1 [puerto]

          - [tcp|udp] : tipo de puerto, es decir TCP o UDP
          - [ip interna de la red] : la ip del pc que tengas en tu red al que quieras redirigir el trafico del puerto
          -[puerto]: el numero de puerto.

          si algo no queda claro, ya sabes donde postear :-P

          • Cerrado

            BocaDePez BocaDePez
            6
            Muchas gracias por contestar. He hecho lo que comentas pero…

            Muchas gracias por contestar. He hecho lo que comentas pero sigue dandome LowID en los programas P2P. Te copio la config del router, resultado de hacer un sh run :

            interface Loopback0
            ip address 10.127.240.218 255.255.255.255
            !
            interface Ethernet0
            ip address 192.168.1.1 255.255.255.0
            ip nat inside
            hold-queue 100 out
            !
            interface ATM0
            description ULL0000xxxxx-TESA4610000xxxxxxx
            ip address 10.127.240.222 255.255.255.252
            no atm ilmi-keepalive
            pvc gestion 9/32
            vbr-nrt 64 64 1
            oam-pvc manage
            encapsulation aal5snap
            !
            dsl operating-mode auto
            !
            interface ATM0.4 point-to-point
            description INTERNET-R200300xxxxxxx
            pvc INTERNET 8/35
            ubr 300
            oam-pvc manage
            encapsulation aal5mux ppp dialer
            dialer pool-member 1
            !
            !
            interface ATM0.5 point-to-point
            description VOZ-R103000xxxxxx
            ip address 80.173.104.198 255.255.254.0
            pvc ToIP 8/36
            vbr-rt 128 128 1
            oam-pvc manage
            encapsulation aal5snap
            !
            h323-gateway voip interface
            h323-gateway voip id gk_mad ipaddr 80.173.0.66 1719
            h323-gateway voip h323-id 963333259_Nuprovi
            h323-gateway voip bind srcaddr 80.173.104.198
            !
            interface Dialer0
            ip address negotiated
            ip nat outside
            encapsulation ppp
            dialer pool 1
            ppp authentication chap callin
            ppp chap hostname BA468EOT@iddeoull
            ppp chap password 0 RB1MOUI5
            ppp ipcp dns request
            !
            interface Dialer1
            no ip address
            !
            ip nat translation max-entries 4000
            ip nat inside source list INET interface Dialer0 overload
            ip nat inside source static udp 192.168.1.2 3128 interface Dialer1 3128
            ip nat inside source static tcp 192.168.1.2 3128 interface Dialer1 3128
            ip nat inside source static udp 192.168.1.2 2672 interface Dialer1 2672
            ip nat inside source static tcp 192.168.1.2 2672 interface Dialer1 2672
            ip classless
            ip route 0.0.0.0 0.0.0.0 Dialer0 permanent
            ip route 80.173.0.0 255.255.0.0 ATM0.5
            ip route 192.168.100.0 255.255.255.0 10.127.40.221
            ip route 192.168.102.0 255.255.255.0 10.127.40.221
            no ip http server
            !
            !
            ip access-list extended INET
            deny ip any 10.0.0.0 0.255.255.255
            deny ip any 172.16.0.0 0.0.255.255
            deny ip any 192.168.0.0 0.0.255.255
            permit ip 192.168.1.0 0.0.0.255 any
            deny ip any any

            Lo que viene a continuación es instrascendente pues se trata de la config de los números de teléfono que funcionan a través del router.

            La líneas que he añadido según lo que me has explicado han sido:
            ip nat inside source static udp 192.168.1.2 3128 interface Dialer1 3128
            ip nat inside source static tcp 192.168.1.2 3128 interface Dialer1 3128
            ip nat inside source static udp 192.168.1.2 2672 interface Dialer1 2672
            ip nat inside source static tcp 192.168.1.2 2672 interface Dialer1 2672


            No sé, me da la impresión de que tengo el router muy capado por los de Auna, pero no estoy seguro pues no conozco que significa exactamente cada comando de los de la lista.

            Saludos y gracias de nuevo por tu tiempo.

            • Cerrado

              [Editado 14/11/04 20:28]

              la respuesta es sencilla, tienes que poner el dialer0 no el…

              la respuesta es sencilla, tienes que poner el dialer0 no el dialer1, es decir:

              ip nat inside source static udp 192.168.1.2 3128 interface Dialer0 3128

              en vez de

              ip nat inside source static udp 192.168.1.2 3128 interface Dialer1 3128

              el dialer1 será el de los puertos de voz sobre ip, el dialer0 és el de la conexión a inet

      • Cerrado

        Llevo como una hora buscando este tema con la funcion de…

        Llevo como una hora buscando este tema con la funcion de busqueda para saber los comandos que utilizaste .... buf ...

        Lo ley un dia asi de pasada y cuando o he ido a buscar .... jurl!!

        Posteo simplemente para la proxima vez buscar por nick :D

        Un saludo.

        PD: Muchas gracias por la info ;)

      • Cerrado

        BocaDePez BocaDePez
        6

        si quieres te puedo pasar una ios que yo tengo para un soho…

        si quieres te puedo pasar una ios que yo tengo para un soho 97 ademas te puedo pasar los manuales de programación de de este router y para este proveedor en concreto