BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Problemas con la asignación de IP de mi smartphone con android

grimpador

Buenas tardes, espero explicarme bien del problema que tengo. En el garaje que tengo en la planta baja de mi edificio, donde vivo en el 6º, junto con mi hijo, hemos instalado mediante un Arduino Uno, reles, etc... una pequeña domotización de las luces, puerta automatica, camara vigilancia... El arduino va conectado a un router que tenia por casa, por conexión ethernet y el router me da la wifi para conectar mi smarphone y activar cualquier cosa, mediante una app hecha aproposito. Todo funciona perfectamente, menos un detalle. Teniendo en cuenta que mi router no tiene acceso a internet, en un futuro igual tiro cable porque la wifi no llega, cuando conecto por primera vez cualquier dispositivo al router funciona todo perfecto, el problema viene cuando me voy, mi smartphone pasa a consumir datos fuera de la conexión a la wifi del garaje, sin internet, y luego vuelvo, automaticamente se conecta a la wifi pero cuando utilizo la app me dice que me conecte que no estoy conectado. Bueno despues de horas hojeando que ocurre, me doy cuenta que, en la lista de wifis disponible donde me sale que estoy conectado, cuando pulso sobre mi conexión, me sale como ip la tipica 192.168.1.23, por ejemplo. Pero si voy a información del dispositivo, estado, alli me sale como ip una totalmente diferente 100.22.10.21, por ejemplo, me he dado cuenta que me entran datos. Es decir el movil me dice que estoy conectado a la wifi pero en realidad la wifi no funciona y si los datos. Si borro por completo esta wifi y la vuelvo a meter, si que funciona todo bien. Siempre el error es cuando antes de conectarse a la wifi se ha conectado a datos......Que puedo estar haciendo mal? Estoy seguro que si tuviera internet en el garaje, esto no pasaria pero, sin internet no se como configurarlo. Me podeis ayudar?

KirO

Me suena que hay una opción que permite forzar el uso de la wifi, pero ahora no tengo ninguna que no funcione a mano para que funcione.

Se me ocurre que tal vez puedas añadir una interfaz bluetooth para sustituir el wifi...

Saludos.

mceds

Si estuviéramos hablando de un dispositivo normal, yo apostaría por un problema al crear la tabla de rutas. Debería acabar con dos de ellas: una "default" que fuerce todo a salir por la interfaz GSM/3G y otra, con prioridad sobre la anterior, que redirija todo el tráfico de 192.168.1.0/24 a la interfaz WLAN (wifi).

Por tanto, el problema está en el móvil. Al volverse a conectar a la red wifi de tu casa, no crea esta ruta adicional.

Pero no tengo ni idea de cómo manejan estas cosas tanto Android como iOS (que tampoco lo especificas, lo mismo tienes una Blackberry).

🗨️ 1
BocaDePez
BocaDePez

Mi movil es un Bq con lollipop 5.02, creo por todo lo que leo y pruebo, que si pueda ser que este en el dispositivo, el problema. Cuando conecto en casa o cualquier router que si tiene conexión a internet no me asigna esa ruta adicional, funciona correctamente. He lanzado la consulta a BQ para ver si es cosa del movil y no de la red, que pensaba en principio.

vukits

¿qué modelo de router wifi usas?

🗨️ 1
BocaDePez
BocaDePez

Ahora tengo un comtrend de jazztel, pero me ocurria lo mismo con un tp-link dual band.