BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Conflicto en las dependencias al instalar OpenDKIM en RHEL 8

antey

Quiero instalar una aplicación llamada OpenDKIM en Red Hat Enterprise Linux 8. Tengo añadido el repositorio EPEL desde donde poder instalarlo en teoría.

Para ello hago yum install opendkim, el problema que encuentro son las dependencias que faltan para llevar a cabo la instalacion con exito.

Modular dependency problems:
Problem 1: conflicting requests
- nothing provides module(perl:5.26) needed by module perl-DBD-MySQL:4.046:8030020200511061544:3a70019f.x86_64
Problem 2: conflicting requests
- nothing provides module(perl:5.26) needed by module perl-DBD-SQLite:1.58:8030020200313075906:3a70019f.x86_64
Problem 3: conflicting requests
- nothing provides module(perl:5.26) needed by module perl-DBI:1.641:8030020200505125553:1e4bbb35.x86_64
Problem 4: conflicting requests
- nothing provides module(perl:5.26) needed by module perl-IO-Socket-SSL:2.066:8030020200430120526:1e4bbb35.x86_64
Problem 5: conflicting requests
- nothing provides module(perl:5.26) needed by module perl-libwww-erl:6.34:8030020200428102957:b967a9a2.x86_64
Error:
Problem: conflicting requests
- nothing provides libmilter.so.1.0()(64bit) needed by opendkim-2.11.0-0.28.el8.x86_64
- nothing provides libmemcached.so.11()(64bit) needed by opendkim-2.11.0-0.28.el8.x86_64
- nothing provides libmemcachedutil.so.2()(64bit) needed by opendkim-2.11.0-0.28.el8.x86_64
(try to add '–skip-broken' to skip uninstallable packages or '–nobest' to use not only best candidate packages)

Decir que tengo instalada la aplicación Perl 5.26. previamente.

Para ello trato de aplicar la solución provista aquí: yum module enable perl:5.26 -y, pero cuando vuelvo a lanzar yum install opendkim sigo en las mismas que lo arriba descrito.

Creo que el problema viene de los "conflicting requests" de las librerías:

  • libmilter.so.1.0() (64 bit)
  • libmemcached.so.11()(64bit)
  • libmemcachedutil.so.2() (64 bit)

¿Como hago para instalar estas librerías? Porque por ejemplo la libmencached, buscando por ahí, viene con la aplicación Sendmail, pero cuando trato de instalar la aplicación Sendmail, me sigue pidiendo otras dependencias faltantes. Y no puedo hacer un yum update del servidor a las bravas.

Black Hole

No se puede leer el artículo sin pagar… 🤨

Nombre de usuario

Necesitas habilitar el appstream repo:

subscription-manager repos –enable rhel-8-for-x86_64-appstream-rpms

🗨️ 1
antey

subscription-manager config –rhsm.manage_repos=1

subscription-manager repos –enable codeready-builder-for-rhel-8-x86_64-rpms