BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fijo

Problema de dns constante

BocaDePez
BocaDePez

Muy buenas, he preferido comentarlo por aquí antes de marearme y perder mi valioso tiempo con el servicio de atencion al cliente y técnico.

Mi red: router Cisco.

uso todos los puertos ethrrnet y a un tengo conectado un switch para poder conectar un router con el que simplemente me conecto a través de wifi desde otros dispositivos(movil) y una consola.

el caso es que no puedo acceder nunca a ningún equipo de mi Red local si asignó por dhcp. creo que es porque usa ipv6 y pasa del ipv4.

si me pongo ipv4 y iP estática en el pc aveces funciona. en general funciona. hasta que peta y aparentemente las dns dejan de resolver(pongo las de Google o las de opendns).

no puedo acceder al router si no pongo ip estática en los equipos.(para acceder a 192.168.1.1)

y lo que me pasa muchas veces es que los dns dejan de resolver... sin más. las ips siguen haciendo ping.

si cojo y vuelvo a poner la ip por dhcp me suele pasar que o funciona o da fallo de dns aunque estoy conectado a Internet ( esta vez con los dns de telecable cogidos por dhcp(.

No es cosa del sistema operativo porque tb me pasa desde el móvil.

no entiendo porque pasa....

resumiendo fallos de dns que sólo se solucionan reiniciando el router y aveces no eso(como ahora mismo que estoy sin poder resolver direcciones desde ningún dispositivo (

aclarar que el router que tengo conectado solo para tener otra Red wifi no tiene dhcp activado.

y no puedo acceder a nada de miRed local si uso dhcp del router de telecable.

No entiendo nada. Y se supone que soy técnico de sistemas en Red. no se donde esta fallando. No entiendo porque ela router no me comunica con x ejem la página 192.168.1.1 si no tengo la ipv4 como estática. no entiendo porque aveces funciona y otras no(por ejemplo si reinicio la ip estática nunca funciona ) y porque cuando falla hasta que no reinicio el router nada.

a ver si alguien puede darme algo de luz con el tema.

BocaDePez
BocaDePez

Ese router va mazo mal yo fui cliente de telecable pero me fui a vodafone ahora mi wifi va muy bien

BocaDePez
BocaDePez

Tal vez porque tener un titulo no implica que se sepa . Hazte un plano de la red interna , pon direcciones estaticas y un punto de acceso para el wi-fi en vez de un router porque parececque no sabes configurar el routing entre ambos . Recuerda que cada segmento de red tiene su propio direccionamiento IP

BocaDePez
BocaDePez

es que escribo desde el movil y es un poco tedioso.

vamos a ver. tengo un router conectado simplemente para tener un punto de acceso wifi extra. pero bueno ese lo tengo apagado ahora mismo.

desde que cambie la ip del pc conectado por cable a estática para poder acceder al router (192.168.1.1) (y accedi) me dejo de funcionar el dns en todos los dispositivos. no me resuelven los dns de telecable.

Se que tener un título no implica nada pero lo comento porque en el fondo esto son operaciones básicas y sencillas y no entiendo que ocurre.

buebo ahora tengo. el cisco de telecable con 4 conexiones. el tedi. un switch. un pc. y creo que en el otto tengo directamente el router que uso para el wifi(porwue lo uso? porque el alcance del de Cisco es una puta mierda y aparte no me hace cosas raras.

Porque al cambiar de ip dhcp a ip stqtiva y poner las dns de Google me deja de resolver la dns? porque al hacer eso en un equipo me dejan de resolver el resto con dns de telecable? no tiene sentido. Creo que voy a llamar para que me lo cambien o algo.

yo siempre pongo todo a estático y con este router n fui capaz por problemas al resolver el dns. yo lo que pienso es que de alguna manera telecable me capa los dns o por otro lado, que pasa del ipv4 y utiliza ipv6 (del cual no veo configuración en el cisco pero cusndo da ip por dhcp la ipv4 local no tiene sentido para mi es en plan 203.28.134.144 ) como ipv6 me parece más tedioso y no lo controlo tanto no lo tengo configurado y tal vez vayan por ahí los tiros. pero es que configurando todo con ipv4 estática debería de funcionar...

a ver si alguien con ese cisco y telecable tuvo este tipo de problemas y me sabe decir. es que tampoco me veo explicando esto por wtencion al cliente.

🗨️ 2
BocaDePez
BocaDePez

Eso que pones tiene el formato de ipv4

elu

Hola, hasta donde yo se :wink: la ip de acceso al MTA Cisco de Telecable es: 192.168.0.1

Telecable da servicio IPV4.

Si los cortes son desde hace unos 15 días hasta ahora, relájate... (todo se arreglara))

BocaDePez
BocaDePez

supongo que lo habras mirado, pero aver si tienes los dos routers con el DCHP activado y la red se esta volviendo loca

🗨️ 3
BocaDePez
BocaDePez

Si el segundo router no tiene dhcp( esta funcionando como un switch con wifi). eso funciona se todas formas lo tengo apagado.

Si le pongo ip estática y dns de Google me da error de dns no me resuelven.

ping me hace.. tanto con ip dhcp con dns de telecable como estática con los dns de Google

si hago ping a los dns de telecable no obtengo respuesta eso sí.

Creo que me voy a cambiar de compañía la verdad. aunque me da rabia. pero lo deje estar unas horas vuelvo y sigue fallando... yo trabajo desde casa y por internet no me puedo permitir que la Red se me vuelva loca.

🗨️ 2
BocaDePez
BocaDePez
2

¿En serio eres técnico de sistemas en red? Pues espero que en tu curro te desenvuelvas mucho mejor, porque si te he de ser franco, la información que nos has proporcionado en tu mensaje inicial, a mí por lo menos no me ha servido en absoluto para saber cómo es la topología de tu LAN, ni qué espacio de direccionamiento tiene. Te estás explicando como un libro cerrado, y ya le estás cargando el muerto al router de tu proveedor (¿eso es Asturias, no?) antes de poder sacar una conclusión coherente.

Tú a lo mejor lo tienes claro porque lo tienes delante, pero no explicas cómo conectas las cosas realmente, ni qué IPs tiene cada elemento. Cuando abres un hilo en un foro, tienes que fijarte siempre si alguna frase queda ambigua, para corregirla.

uso todos los puertos ethrrnet y a un tengo conectado un switch para poder conectar un router con el que simplemente me conecto a través de wifi desde otros dispositivos(movil) y una consola.

No explicas cómo estás conectando ese segundo router. No nos dices si es neutro y lo usas como router a través de su puerta LAN, o estás aprovechando un router que no sea neutro (como mucha gente por el foro hace) para usarlo solo como switch y hub inalámbrico. Sin saber eso no podemos saber si estás haciendo doble NAT, y sin eso, todas las posibles explicaciones posteriores quedan en el aire.

el caso es que no puedo acceder nunca a ningún equipo de mi Red local si asignó por dhcp. creo que es porque usa ipv6 y pasa del ipv4.

No sé entiende a qué llamas "Red local", puesto que no defines dónde te posicionas. No sabemos si llamas "Red local" a los equipos cableados que dependen del router de Telecable, y tú estás en un móvil o portátil que depende de la red inalámbrica de tu router en propiedad (que vamos, podrías haber dicho marca y modelo para saber de qué hablamos). Como no has dicho lo usas como router o como switch, no podemos saber si hay 2 dominios de difusión. Como no sabemos si usas doble NAT, tampoco podemos saber si hay 2 dominios de colisión. Como ves, ambigüedades por todos los lados.

si me pongo ipv4 y iP estática en el pc aveces funciona. en general funciona. hasta que peta y aparentemente las dns dejan de resolver

Aquí es donde empiezo a dudar que tengas conocimientos de redes. Las casualidades no existen. Si no sabes si está el equipo usando IPv6 o IPv4, empezamos muy mal. Todos sabemos que Microsoft decidió usar IPv6 en los "grupos en el hogar", así como protocolos de autodescubrimiento por difusión. El poner IPv4 estática no implica desactivar IPv6, pero la tabla de rutas es la que manda y dependiendo del destino, irá por un lado o por otro, o usará un stack u otro. Supongo que Telecable no te da IPv6 nativa y una puerta de enlace predeterminada en IPv6, pero ten cuidado con los túneles 6-to-4 del estilo Teredo.

Aunque el router de Telecable tenga relay de DNS (que lo desconozco), quien manda es la configuración del PC. Por DHCP podría ser que el DNS apuntase al propio router de Telecable si tiene relay, pero si una configuración estática en el PC apunta de manera manual y forzada a servidores DNS externos como Google u OpenDNS, irá a ellos directamente. Verifica con "ping" y "traceroute" que tienes conectividad hasta ellos, y verifica con "dig" o "nslookup" que te resuelven o no... pero hablar de que si a veces no va y aparentemente no resuelve, no te hace parecer muy profesional.

Luego hay otro tema que se me viene a la mente (como diría Coque de LQSA) y es que existen routers que ignoran IPs estáticas si éstas están dentro del rango esperado en su pool de direcciones para DHCP. Intenta siempre escoger direcciones que estén fuera de dicho rango, y en el caso de que ocupen todo el espacio (2-254), disminuir el rango del servidor DHCP. Ignoro si ese comportamiento lo tiene el router de Telecable.

🗨️ 1
mceds

Acabas de expresar lo que he sentido al leer el mensaje inicial.