BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

problema con Debian y DHCP

JOL

Esrimados colegas os voy a presentar mi problema:
Tengo un router que da servicio via wifi a dos ordenadores. En uno de ellos tengo instalado ademas del Windows, Mandrake y Debian. Despues de compilar el nucleo 2.6.10 y añadirle un driver para que funcionara mi tarjeta de red, en ambos linux consigo luz verde pero, mientras que en Mandrake ya esta todo listo, en Debian hay que configurar la red.
Este es el problema: ¿Cómo se configura el DHCP para mi situacion? ¿es posible saltarse el DHCP e introducir las DNS a mano, si es asi dónde?
La utilidad kwifimanager me deja configurar casi todo pero no la IP local que debe ser lo importante. He instalado las wireless-tools y mas o menos he hecho lo que he podido pero la configuracion del servidor DHCP es demasiado para mí.
Esperando vuestras amables respuestas me despido y no tengais reparo en intervenir con cualquier idea que se os ocurra siempre y cuando no sea (como algun gracioso tuvo la ocurrencia de escribir) "haz un apt-get......".
O sea queda claro que la red no me va en Debian pero que es solo un problema de configuracion.
Chao.

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
gorrister

Suponiendo que tu inteface de red sea ath0:
edita /etc/network/interfaces:

auto lo ath0

iface ath0 inet dhcp
wireless_essid elquesea
wireless_mode managed
wireless_channel numero_canal

🗨️ 12
JOL

1000 gracias por tu respuesta pero todavia no funciona. Te explico:
¿Que paquetes debo tener cargados para que vaya todo?
Aún así al etar la conexion encriptada tengo que entrar en el gestor de kde de wireless y al darle a actualizar configuracion entonces SI me coge el punto de acceso etc, EXCEPTO la ip local.
Me pregunto si no habria manera de cargar la red wlan0 sin pasar por este gestor que de todas maneras no soluciona nada.
Otra pregunta ¿hay que levantar la red obligatoriamente a posteriori con ipconfig o algo asi o puede ser cargada automaticamente?
Gracias de nuevo y un saludo.

🗨️ 11
BocaDePez
BocaDePez

Creo q no te voy a ser de mucha ayuda pero podrias mirar dhcp-client. esto se lanza normalmente en el arranque y te configura las interfaces que esten como:

auto eth0
iface eth0 inet dhcp

en /etc/network/interfaces

Si el problema es de la wlan, podrias mirarte la documentacion de waproamd.

waproamd is a Linux WLAN roaming daemon for IEEE 802.11
cards supported by a driver with wireless extension API. It may be
used for configuring WEP keys according to the WLANs available, and
automatically configures the network interface when an access point is
found.

ya se que te estoy diciendo "haz apt-get ...", pero tambien te digo "haz apt-cache search ..."

🗨️ 10
JOL

Te agradezco enormemente la intencion, quizás hayas dado con la solución.
Lo comprobaré por la noche :)
Perdona si te he molestado con el comentario primero pero es que estoy un poco cansado de aguantar "aportaciones" de ese tipo que lo unico que hacen es hacerle el juego a Billy Puertas.
Gracias de nuevo, si se te ocurre algo mas no lo dudes y escribe.

🗨️ 9
t3l3m4k0
🗨️ 8
JOL
🗨️ 7
t3l3m4k0
🗨️ 5
JOL
🗨️ 4
t3l3m4k0
🗨️ 3
JOL
🗨️ 2
t3l3m4k0
🗨️ 1
JOL
BocaDePez
BocaDePez