BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Problema con dbus

BocaDePez
BocaDePez

Hola a todos. Mi problema es el siguiente:
Deshabilite el servicio "Bus de comunicaciones (dbus)" porque tardaba mas de cinco minutos en iniciarse y ahora cuando entro a la pantalla de iniciar sesión no me reconoce ni el teclado ni el ratón en mi portátil. He probado con ratones y teclados USB pero nada. Solamente tengo opción a modificar el grub pulsando la tecla "E" cuando estoy en el grub o a entrar en una línea de comandos con símbolo "sh:grub>". Lo que busco principalmente es arrancar el servicio antes de iniciar el módulo. Mi sistema operativo es Linex.

Saludos y gracias!!

superllo

Bueno, ¿de donde lo has desactivado? porque si entras con un liveCD podrás volver a activarlo, ¿no?

🗨️ 1
BocaDePez
BocaDePez

Lo desactive desde mi sesión de usuario. El problema es que no puedo meter ningún live CD porque son PCs de la junta de Extremadura y no puedo entrar a la BIOS. Además, creo que esa opción esta incluso quitada de la ROM.

¿Alguna otra alternativa que no sea liveCD?

Un saludo y gracias!

vukits

ahora cuando entro a la pantalla de iniciar sesión

tendrás que loguearte en modo texto, ya que para el teclado no necesita de dbus ni nada..

de hecho, puedes forzar el S.O. a arrancar en modo texto (nivel 3) haciendo lo que dices de grub (fuente)

Iniciamos.

Cuando el grub de a elegir el O.S para iniciar nos posicionamos sobre el Kernel a iniciar y tecleamos la letra "e"
agregamos la palabra " text" al final de la linea que tiene el nombre del kernel a usar.

Apretamos Ctrl-x para iniciar.

cuando te salga la consola, y te hayas logueado como root ,

mete la siguiente orden (presupongo que LinEx está basado en Debian),dandole a 'intro'

update-rc.d dbus defaults 12

si no te comenta ningun error, al próximo reinicio (con escribir 'reboot'), dbus estará ejecutandose y tendrás tu ratón funcionando..

saludos

🗨️ 13
BocaDePez
BocaDePez

Vukits todo funciona bien menos el último comando!!

He conseguido arrancar en modo texto y todo pero al escribir el comando me muestra lo siguiente:

update-rc.d: using dependency based boot sequencing

update-rc.d: warning: dbus stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (1)

insserv: warning: current start runlevel(s) (3 4 5) of script `dbus' overwrites defaults (2 3 4 5).

insserv: script mountdevsubfsold.sh: service mountdevsubfs already provided!

insserv: script vboxdrv: service vboxdrv already provided!

Eso es todo lo que pone. Al reiniciar lo mismo de antes, ni ratón ni teclado. ¿Hay alguna otra forma de decirle que lo inicie?¿Editando algún archivo con gedit o algo?

Saludos y muchas gracias!

🗨️ 12
vukits

mejor para el ultimo,usa este

update-rc.d dbus defaults

sino, pues el servicio dbus se inicia manualmente

/etc/init.d/dbus start

y el gestor de sesiones (para loguearte con escritorio) con

/usr/sbin/gdm

saludos

🗨️ 11
BocaDePez
BocaDePez

PERFECTO!!

Muchísimas gracias me has salvado la vida!!

He hecho lo segundo y ya desde dentro lo he iniciado. Desactive el dbus porque cuando instalé la virtualbox me tarda como más de 5 minutos en iniciar el dbus en el arranque del sistema. ¿Tienes alguna idea de por qué puede ser y si tiene arreglo?

Muchísimas gracias de nuevo!! Saludos!!

🗨️ 1
vukits
BocaDePez
BocaDePez

Rectifico:

Al hecho eso pero sigue sin arrancar directamente. ¿Porque no se ha guardado el cambio?

Saludos y muchas gracias!!!

🗨️ 8
vukits
🗨️ 7
BocaDePez
BocaDePez
🗨️ 6
vukits
🗨️ 5
BocaDePez
BocaDePez
🗨️ 4
vukits
🗨️ 3
BocaDePez
BocaDePez
🗨️ 2
vukits
🗨️ 1
BocaDePez
BocaDePez